Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



179 posts

Master Geek


Topic # 101231 27-Apr-2012 10:04 Send private message

Hi - we have a marantz amplifier and wharfdale speakers (modus / vodus - can't remember exact model)
We had it all set up working in our place in Christchurch for 6 months before the feb 22nd quake. We lost our 42" plasma (smashed) in the earthquake and the speakers fell over and suffered minor cosmetic damage, but I tested them and they still worked ok
We have since moved to Auckland and have bought a new TV and I have now re-set up the home theatre system - except the sub doesn't seem to be working.

The light comes on when you turn the sub on and I have a single black RCA to Red / White RCA lead that I plug the black end into the amplifier and the red / white end into the input on the sub. The sub makes a humming / buzzg noise when you put the RCA leads in - so it seems the sub works, but when we play something through the system, nothing comes out of the sub. The volume is on 12 o'clock on the sub and makes no difference if I turn it up or down

I spoke to a man at Harvey norman and he just tried to sell me a special cable, which I don't believe I need at the moment

anyone have any suggestions what I can try to get it to work??

Create new topic


179 posts

Master Geek


  Reply # 615889 27-Apr-2012 10:09 Send private message

I should also add that I can't seem to locate the manual for the amplifier at the moment, but I have not altered any of the settings since we moved

6757 posts

Uber Geek
+1 received by user: 444

Trusted
Subscriber

  Reply # 615901 27-Apr-2012 10:31 Send private message

Vardus, I have one. You only need a standard RCA cable, get a new standard cable for $5 at an electronics store. Try plugging an iPod in to see what happens. I bought some speaker covers for mine when I broke the first lot so Wharfdale can probably sell you a new one or parts if it's broken.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear



179 posts

Master Geek


  Reply # 615910 27-Apr-2012 10:44 Send private message

timmmay: Vardus, I have one. You only need a standard RCA cable, get a new standard cable for $5 at an electronics store. Try plugging an iPod in to see what happens. I bought some speaker covers for mine when I broke the first lot so Wharfdale can probably sell you a new one or parts if it's broken.


Vardus - that's the one.... when you say a standard RCA cable, do you mean a single one each end?? if so where do I plug it in as there are 2 input (red / white) sockets on the sub.
If I wanted to plug the i-pod into the sub I'd need a headphone to RCA lead?
thanks

4750 posts

Uber Geek
+1 received by user: 119

Trusted

  Reply # 615914 27-Apr-2012 10:50 Send private message

Yeah get a headphone to rca cable and test that the sub is actually going.

If it is then you'll need to revisit your receiver settings to ensure a signal is actually being sent to the sub in the first place....

6757 posts

Uber Geek
+1 received by user: 444

Trusted
Subscriber

  Reply # 615916 27-Apr-2012 10:54 Send private message

OnceBitten:
timmmay: Vardus, I have one. You only need a standard RCA cable, get a new standard cable for $5 at an electronics store. Try plugging an iPod in to see what happens. I bought some speaker covers for mine when I broke the first lot so Wharfdale can probably sell you a new one or parts if it's broken.


Vardus - that's the one.... when you say a standard RCA cable, do you mean a single one each end?? if so where do I plug it in as there are 2 input (red / white) sockets on the sub.
If I wanted to plug the i-pod into the sub I'd need a headphone to RCA lead?
thanks


I dunno I just plugged into one and it worked so I didn't worry about it. Yes test it with a 3.5mm stereo to 2xRCA plug. They're worth $5 but dse sells them for up to $20.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear

2214 posts

Uber Geek
+1 received by user: 75

Subscriber

  Reply # 616263 27-Apr-2012 20:25 Send private message

Plug a single ended RCA from the receiver (make sure you're going out of the correct plug on your Marantz) and into the 'L Input' on the back of the sub.
You don't actually need a 2-1 RCA cable...

Can you take a photo of the back of your amp and the back of your sub, then post them up here so we can help. Cheers.



179 posts

Master Geek


  Reply # 623388 11-May-2012 09:27 Send private message

I've figured out why the sub wasn't working - I had it plugged into the wrong output on the amplifier DO'H!

I decided to have a good play around with it last night and have now got it all cranking - you can't play Iron Maiden & AC/DC through a home theatre system with no sub woofer!

thanks you your help!

Watchmaker Wizard
2404 posts

Uber Geek
+1 received by user: 57

Subscriber

  Reply # 623409 11-May-2012 10:00 Send private message

You can play it just fine if your main speakers are big enough ;) e.g. massive old-school ones with 12" drivers in them.




Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Moment of Truth?
Created by BarTender, last reply by Glassboy on 19-Sep-2014 01:32 (367 replies)
Pages... 23 24 25


IOS8 - Network Load
Created by FireEngine, last reply by joker97 on 18-Sep-2014 19:43 (36 replies)
Pages... 2 3


10 Iphone 128gb 6+ iphones this weekend at auckland airport
Created by frysie, last reply by TimA on 17-Sep-2014 22:02 (36 replies)
Pages... 2 3


Mr. Key to extradite Kim Dotcom?
Created by TimA, last reply by SaltyNZ on 18-Sep-2014 09:20 (126 replies)
Pages... 7 8 9


Spark DNS Issues - Amazing - Broadband Service Alert
Created by PeteS, last reply by Demeter on 15-Sep-2014 14:13 (307 replies)
Pages... 19 20 21


New On Account mobile plans - Red+
Created by NikT, last reply by paulspain on 18-Sep-2014 21:39 (18 replies)
Pages... 2


Bizarre Policy on plan change
Created by toejam316, last reply by FireEngine on 18-Sep-2014 20:22 (17 replies)
Pages... 2


2014 Holden SS (V8) or Ford XR6-T (in-line 6 turbo)
Created by joker97, last reply by ilovemusic on 16-Sep-2014 14:34 (71 replies)
Pages... 3 4 5



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.