Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
Buying anything on Amazon? Please use the Geekzone Amazon aff link.




922 posts

Ultimate Geek
+1 received by user: 14


Topic # 106587 26-Jul-2012 22:13 Send private message

My right front speaker in my 5.1 home theatre setup has recently started crackling whenever I turn the volume up or a loud sound comes through it. I've tried swapping the speaker with the left one and same issue so it's not the speaker itself. I also pulled out all the speaker connections from my AVR, checked the ends and put them all back in making sure the connections are all sound so it's not that either.

That seems to only leave the AVR itself I guess. A bit of googling suggests that the front right channel may be knackered. I tried resetting all the speaker settings and set up the surround again but it's still doing it.

What can I do from here? Is it likely the AVR channel is actually poked? If so, is there anything I can do about it myself? Anything else left to rule out?

I recently changed my front speakers to bigger more powerful floor standers but the crackling didn't start straight away. Haven't been thrashing them either, just started doing it a couple weeks ago.

Cheers




HTPC: Silverstone Crown CW02 case | Asus P5Q-L main board | Intel Dual core E8400 3.0GHz CPU | Thermalright Ultra120-Extreme Passive CPU Cooler | Blackgold BTG3540 TV Tuner & Hauppauge PVR-150 MCE Edition | Asus EN9600GT-Silent Passive GPU | 4GB Supertalent DDR2 800 RAM | 5+TB HDD space | LiteOn DH-401S BD/DVD/CD reader | Corsair HX-520w PSU | 1 single Noctua Silent Case fan | Logitech diNovo Bluetooth Media Desktop | Logitech Harmony 785 Universal Remote | Logitech Wireless Rumblepad 2 | Windows 7 Media Center, MediaBrowser & Arcsoft Total Media Theatre

Create new topic
2244 posts

Uber Geek
+1 received by user: 88

Subscriber

  Reply # 662669 26-Jul-2012 22:18 Send private message

What model of receiver do you have?
I feel it's time to send it off to a service agent...



922 posts

Ultimate Geek
+1 received by user: 14


  Reply # 662679 26-Jul-2012 22:45 Send private message

Dunnersfella: What model of receiver do you have?
I feel it's time to send it off to a service agent...


It's a Pioneer VSX-816. It's a cheapy that I've had for 5 years now but it's always been good enough for a 5.1 lounge system. Don't really want to spend hundreds getting it looked at/fixed if possible but I guess it's either that or junk it?

There's a little devil on my shoulder telling me to buy a new Marantz but I've mostly ignored him so far :)

New front speakers are JBL Northridge E60s fwiw




HTPC: Silverstone Crown CW02 case | Asus P5Q-L main board | Intel Dual core E8400 3.0GHz CPU | Thermalright Ultra120-Extreme Passive CPU Cooler | Blackgold BTG3540 TV Tuner & Hauppauge PVR-150 MCE Edition | Asus EN9600GT-Silent Passive GPU | 4GB Supertalent DDR2 800 RAM | 5+TB HDD space | LiteOn DH-401S BD/DVD/CD reader | Corsair HX-520w PSU | 1 single Noctua Silent Case fan | Logitech diNovo Bluetooth Media Desktop | Logitech Harmony 785 Universal Remote | Logitech Wireless Rumblepad 2 | Windows 7 Media Center, MediaBrowser & Arcsoft Total Media Theatre

53 posts

Master Geek


  Reply # 662695 26-Jul-2012 23:21 Send private message

Wouldn't hurt to do a reset back to factory defaults in case the digital processor has got itself in some kind of knot. I have a slightly older Pioneer which about once a year goes "funny" in the centre channel. This always fixes it. You should find the reset procedure towards the back of the book, under trouble shooting.

Cool



922 posts

Ultimate Geek
+1 received by user: 14


  Reply # 662696 26-Jul-2012 23:25 Send private message

Beavis: Wouldn't hurt to do a reset back to factory defaults in case the digital processor has got itself in some kind of knot. I have a slightly older Pioneer which about once a year goes "funny" in the centre channel. This always fixes it. You should find the reset procedure towards the back of the book, under trouble shooting.

Cool


Cheers man, will give that a go and report back!



922 posts

Ultimate Geek
+1 received by user: 14


  Reply # 663087 27-Jul-2012 20:07 Send private message

Factory reset and new speaker setup seems to have done the trick for now at least which seems to tell me it's not a hardware fault so cheers for that

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Click Monday Deals
Created by mrtoken, last reply by Krishant007 on 24-Nov-2014 17:11 (25 replies)
Pages... 2


Gull Employment Dispute.
Created by networkn, last reply by gzt on 26-Nov-2014 14:14 (140 replies)
Pages... 8 9 10


The Warehouse pulling R18 games and DVD's
Created by semigeek, last reply by Lias on 26-Nov-2014 14:21 (53 replies)
Pages... 2 3 4


Current Netflix payment method as of Nov 14 - Cant pay
Created by andynz, last reply by Kiwipixter on 25-Nov-2014 10:45 (33 replies)
Pages... 2 3


Lollipop no more
Created by ronw, last reply by kiwitrc on 26-Nov-2014 13:44 (13 replies)

Knock off electronics in The Warehouse
Created by jpoc, last reply by openmedia on 26-Nov-2014 13:01 (13 replies)

HP Stream 7 arrives
Created by gnfb, last reply by gzt on 26-Nov-2014 14:28 (12 replies)

Voda VDSL, Horrid offnet performance.
Created by TimA, last reply by ckc on 26-Nov-2014 10:54 (31 replies)
Pages... 2 3



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.