Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



6691 posts

Uber Geek
+1 received by user: 433

Trusted
Subscriber

Topic # 114014 5-Feb-2013 10:18 Send private message

When I reply to a message or try to post a new thread the area where I write messages (where I'm typing now) often takes ages to show. It took 20 seconds to show once the rest of the page rendered to write this message, for example, and I have another one on my consumer thread which took between 20 and 40 seconds.

I'm on a corporate network which seems to otherwise be working fine. Is it a frame, or some kind of fancy control that's taking time to load? If so why is the frame or control not cached on the client side?

I also noticed the other day avatar images don't seem to be cached on the client side, in that they load a bit slowly sometimes. I tried to look at the headers but the random filenames discouraged me from looking further.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear

Create new topic
BDFL
49502 posts

Uber Geek
+1 received by user: 4363

Administrator
Trusted
Geekzone
Subscriber

  Reply # 755946 5-Feb-2013 10:25 Send private message

The rich text editor is based on TinyMCE, a javascript editor. It loads from our server, not through the CDN. For me, on TelstraClear it loads almost instantly (I am using it right now). Your corporate network might be taking it sweet time to scan incoming scripts, or might have policies in place in your PC to scan things (check antivirus protection that acts as a "proxy" for your browser such as Avast and ESET).

As for the avatars we make all avatars in a page into a single image set to avoid multiple requests to the server. This reduces the number of requests considerably and make pages faster to render. In a new topic where people might be replying quickly the avatar sprite is rebuilt for each reply. After a page is full (15 replies) then it won't change and the sprite WILL be cached in your browser.

If you visit a page and the replies haven't changed since your last visit, or new replies are added by people who had already replied on that same page then the sprite will be same and it will use the cached version in your browser.

Again, if your company's policies clean the cache frequently, or if you have an option to clean the cache when closing the browser, or use those programs that "speed up your PC" by cleaning up the cache then you are out of luck.

In case you do have those "speed up your PC" programs, they are actually not doing any good by deleting cache files and would be good to turn that option off.







6691 posts

Uber Geek
+1 received by user: 433

Trusted
Subscriber

  Reply # 755949 5-Feb-2013 10:31 Send private message

It's usually fine at home, and all other page elements load quickly. It could be virus scanning or something, but my browser isn't under corporate control so caches stay intact. That it's served direct from GZ not the CDN may be key.

That's an interesting way to do the avatars. It'll speed up the load of a single page for sure, but overall I suspect it will increase the number of requests to the server. If I visit a thread over and over (as I do) as new replies build up every time I visit I'll request all the avatars. If they were individual and browser cached there would be a hit the first time, but after that only the odd avatar would load. It would obviously work between threads as well. It probably doesn't make a huge difference, but there will be computational overhead as well of course.

My day job is as a performance and security engineer, so I have some knowledge in this area.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear



6691 posts

Uber Geek
+1 received by user: 433

Trusted
Subscriber

  Reply # 755955 5-Feb-2013 10:35 Send private message

Interestingly, when I posted the reply my browser (firefox) showed the spinning wheel "doing what you said" form post for 30 seconds. The post actually worked quickly (I checked in another tab) but requesting the thread took ages.

Something's a bit weird with GZ today, no other sites having problem but it could be the network here.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear

BDFL
49502 posts

Uber Geek
+1 received by user: 4363

Administrator
Trusted
Geekzone
Subscriber

  Reply # 755956 5-Feb-2013 10:35 Send private message

timmmay: It's usually fine at home, and all other page elements load quickly. It could be virus scanning or something, but my browser isn't under corporate control so caches stay intact. That it's served direct from GZ not the CDN may be key.


www.gekzone.co.nz is based in AKL and time from WLG on TelstraClear is 20ms. If you're in AKL you can get as low as 3ms. The closest CDN server cdn.geekzone.co.nz is off SYD so times would be higher. Loading from www.geekzone.co.nz makes more sense from delivery seeing the script is only used on a handful of pages compared to things such as CSS and images (which are cached).

timmmay: That's an interesting way to do the avatars. It'll speed up the load of a single page for sure, but overall I suspect it will increase the number of requests to the server. If I visit a thread over and over (as I do) as new replies build up every time I visit I'll request all the avatars. If they were individual and browser cached there would be a hit the first time, but after that only the odd avatar would load. It would obviously work between threads as well. It probably doesn't make a huge difference, but there will be computational overhead as well of course.


That could be something to work on. We can easily replace the avatars sprite with lazy loading avatars, making it less requests per page, while caching individual avatars. 

We're moving servers at the moment but will look at that later.





BDFL
49502 posts

Uber Geek
+1 received by user: 4363

Administrator
Trusted
Geekzone
Subscriber

  Reply # 755957 5-Feb-2013 10:36 Send private message

timmmay: Interestingly, when I posted the reply my browser (firefox) showed the spinning wheel "doing what you said" form post for 30 seconds. The post actually worked quickly (I checked in another tab) but requesting the thread took ages.

Something's a bit weird with GZ today, no other sites having problem but it could be the network here.


It should really be something in the network as I'm getting instant pages. Also notice we have already moved live.geekzone.co.nz off this server - and believe me we serve a hundred thousand pages plus a day for that domain, so if nothing it's less load on the main server at the moment.







6691 posts

Uber Geek
+1 received by user: 433

Trusted
Subscriber

  Reply # 755960 5-Feb-2013 10:40 Send private message

I guess I'll just blame the network. I raised it because you said in another thread to raise things while you were moving stuff.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear

BDFL
49502 posts

Uber Geek
+1 received by user: 4363

Administrator
Trusted
Geekzone
Subscriber

  Reply # 756824 7-Feb-2013 09:56 Send private message

Note that preparing for the server move tomorrow I have activated Cloudflare again, to take advantage of their holding page while the domain is down (about 90 minutes). This means the traffic to the site is all going through their CDN now, until remove this later.




BDFL
49502 posts

Uber Geek
+1 received by user: 4363

Administrator
Trusted
Geekzone
Subscriber

  Reply # 763391 16-Feb-2013 12:21 Send private message

timmmay: That's an interesting way to do the avatars. It'll speed up the load of a single page for sure, but overall I suspect it will increase the number of requests to the server. If I visit a thread over and over (as I do) as new replies build up every time I visit I'll request all the avatars. If they were individual and browser cached there would be a hit the first time, but after that only the odd avatar would load. It would obviously work between threads as well. It probably doesn't make a huge difference, but there will be computational overhead as well of course.


I have switched the avatars from image sprite to individual images. Let's see how it impacts performance for the next few days.

Other elements that don't change in a page (buttons, logos, background) are still sprites.





708 posts

Ultimate Geek
+1 received by user: 21


  Reply # 763404 16-Feb-2013 12:53 Send private message

Funny enough I saw the exact same thing, either yesterday or the day before.  The page loaded EXCEPT for the box that you type in.  The status bar said waiting for some site data to load (external from geekzone) but of course I didn't write it down.  I reloaded the page and it worked.

This is from home in West Auckland, on Telecom ADSL2+.  Good sync rates etc.



6691 posts

Uber Geek
+1 received by user: 433

Trusted
Subscriber

  Reply # 763636 17-Feb-2013 00:57 Send private message

freitasm: I have switched the avatars from image sprite to individual images. Let's see how it impacts performance for the next few days.

Other elements that don't change in a page (buttons, logos, background) are still sprites.



I'd be interested in the results, working in performance. Client side caching should go up resulting in slightly fewer (cheap) hits, CPU should go down but a negligible about.  I'm going to guess an insignificant difference, in practical terms, but I suspect slightly better the new way.




Asus eee pad transformer
iPod 2G
Windows 7 PC
Lots and lots of Nikon camera gear

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Orcon Global Mode launched
Created by freitasm, last reply by tgzerozone on 28-Aug-2014 14:58 (101 replies)
Pages... 5 6 7


Advice on Residential Fence replacement and neighbour
Created by networkn, last reply by nickrout on 27-Aug-2014 19:45 (26 replies)
Pages... 2


Vodafone TV multicast settings on pfSense?
Created by kenkeniff, last reply by kenkeniff on 27-Aug-2014 10:32 (182 replies)
Pages... 11 12 13


XtraHost - Closing
Created by achieveit, last reply by quickymart on 27-Aug-2014 18:57 (19 replies)
Pages... 2


Another Gaming computer help question
Created by Lyderies, last reply by timmmay on 26-Aug-2014 18:06 (38 replies)
Pages... 2 3


Lightbox press event release
Created by freitasm, last reply by BigPipeNZ on 28-Aug-2014 13:48 (539 replies)
Pages... 34 35 36


Internet ridiculously slow! Please help!
Created by FatMarty, last reply by hio77 on 24-Aug-2014 20:48 (18 replies)
Pages... 2


Why is there no right to compensation for wrongful imprisonment in NZ?
Created by Geektastic, last reply by Geektastic on 26-Aug-2014 14:33 (71 replies)
Pages... 3 4 5



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.