Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




937 posts

Ultimate Geek
+1 received by user: 81


Topic # 62953 17-Jun-2010 23:24 Send private message

One thing that slightly annoys me when I am typing a message to submit to Geekzone forums is that Firefoxes inbuilt spellchecker does not work. Why is that?
I see it works in the quick reply but not in the full editor.
Any way to get it enabled and if not how about a spellchecker built into the forum editor?
Someone with spelling & typing as bad as me needs it desperately.

Thaks Laughing

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
I iz your trusted friend
5755 posts

Uber Geek
+1 received by user: 134

Mod Emeritus
Trusted
Subscriber

  Reply # 342823 18-Jun-2010 00:31 Send private message

You won't see Firefox/Chrome/Safari's spellchecker working in RTE (Rich Text Editor) as it is a layer of iFrame that render out in HTML format from a hidden textarea which actually holds the HTML markup.

In short, you're out of luck mate.




Internet is my backyard...

 

«Geekzone blog: Tech 'n Chips Takeaway» «Personal blog: And then...»

 

Please read the Geekzone's FUG

 


3544 posts

Uber Geek
+1 received by user: 121

Trusted

  Reply # 342824 18-Jun-2010 00:33 Send private message

chiefie: You won't see Firefox/Chrome/Safari's spellchecker working in RTE (Rich Text Editor) as it is a layer of iFrame that render out in HTML format from a hidden textarea which actually holds the HTML markup.

In short, you're out of luck mate.


Actually in Chrome the built-in spell checker does work.  This is why I love Chrome! 

7326 posts

Uber Geek
+1 received by user: 633

Subscriber

  Reply # 342851 18-Jun-2010 08:39 Send private message

Works fine in Opera 10.6 as well..




Regards,

Old3eyes


BDFL - Memuneh
57593 posts

Uber Geek
+1 received by user: 9231

Administrator
Trusted
Geekzone
Subscriber

  Reply # 342853 18-Jun-2010 08:41 Send private message

When you folks say "works" is in the rich-text editor or the Quick Reply box?




5447 posts

Uber Geek
+1 received by user: 683

Trusted
Subscriber

  Reply # 342855 18-Jun-2010 08:42 Send private message

Working in both with Safari.

2260 posts

Uber Geek

Trusted

  Reply # 342856 18-Jun-2010 08:43 Send private message

Behodar: Working in both with Safari.


Both with Chrome too, think it's definitely a Firefox only issue 




I have moved across the ditch.  Now residing in Melbourne as a VOIP/Video Technical Trainer/Engineer. 

7326 posts

Uber Geek
+1 received by user: 633

Subscriber

  Reply # 342887 18-Jun-2010 09:58 Send private message

On Both..




Regards,

Old3eyes


2233 posts

Uber Geek
+1 received by user: 430


  Reply # 342898 18-Jun-2010 10:10 Send private message

works in both with firefox, you just have to turn it on if you use compose reply.

447 posts

Ultimate Geek
+1 received by user: 1


  Reply # 342913 18-Jun-2010 10:32 Send private message

vexxxboy: works in both with firefox, you just have to turn it on if you use compose reply.


Me too.



937 posts

Ultimate Geek
+1 received by user: 81


  Reply # 342921 18-Jun-2010 10:44 Send private message

what do you mean "turn it on"?
I have the firefox spellcheck in pretty much everything except the rick text editor for the geekzone forum.



937 posts

Ultimate Geek
+1 received by user: 81


  Reply # 342936 18-Jun-2010 11:12 Send private message

Oh - I got it. If you right click from within the rich text editor there is an option to "check spelling". It just doesn't load automatically like it does in other forums / web pages etc.

760 posts

Ultimate Geek
+1 received by user: 65

Trusted
Subscriber

  Reply # 342967 18-Jun-2010 12:05 Send private message

Using Firefox when I right click the Quick Reply text box Check Spelling is always ticked. When I right click the Compose Reply text box Check Spelling is always unticked.

If Quick Reply defaults to ticked I don't see why Compose Reply can't do the same.

I have to remember to "right click and tick" every time I do a non-quick reply if I want to check the spelling.

8015 posts

Uber Geek
+1 received by user: 383

Trusted
Subscriber

  Reply # 343078 18-Jun-2010 17:23 Send private message

GZ uses the TinyMCE editor for compose reply, apparently there is a config setting (which defaults to off) to toggle the Firefox/Gekco spellchcker

http://wiki.moxiecode.com/index.php/TinyMCE:Configuration/gecko_spellcheck

The supreme bean will need to change the TinyMCE config/theme server side.


BDFL - Memuneh
57593 posts

Uber Geek
+1 received by user: 9231

Administrator
Trusted
Geekzone
Subscriber

  Reply # 343085 18-Jun-2010 17:35 Send private message

How is this for spell checking now?




8015 posts

Uber Geek
+1 received by user: 383

Trusted
Subscriber

  Reply # 343090 18-Jun-2010 17:44 Send private message

On by default now for me Wink

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic








Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site: