Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

Topic # 61904 25-May-2010 23:25 Send private message

Gave up on my idea of connecting an analog cordless phone to a Linksys PAP2T and then to an AG310, and bought a Gigaset A580IP phone instead. Spent several hours trying to connect to my 2talk and Faktortel VoIP accounts, but to no avail. The phone has been issued a local IP address from the Linksys AG310 DHCP my home network and seems to talk to the base station, but that's about it. Nothing seems to get past the base station. The phone base station is connected to an ethernet port on the AG310.

If there is someone out there who uses either of these two providers, and has a Gigaset A580IP, I would be grateful for your words of wisdom in setting this thing set up. I should point out I'm not a complete novice as I have managed to set up softphones on my PC and iPhone to connect to 2talk and Faktortel, but obviously not yet an expert on these things.

One piece of information that may be relevant: my AG310 is locked down by VFX.

Cheers,

David. 





Create new topic
19376 posts

Uber Geek
+1 received by user: 1214

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 334846 25-May-2010 23:47 Send private message

What settings and fields are you using? I assume neither line says registered?




329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

  Reply # 334848 25-May-2010 23:58 Send private message

Steve,

Connection settings for 2talk are as follows. I get "server not accessible", then later on, "registration failed".

Authentication Name: 028 XXXX XXXX
Authentication password: XXXXXX
Username: 028 XXXX XXXX
Display name: David Everett

Domain: 2talk.co.nz
Proxy server address:
Proxy server port: 5060
Registrar server:
Registrar server port: 5060
Registration refresh time: 180 sec

STUN enabled: No
STUN server:
STUN port: 3478
STUN refresh time: 240 sec
NAT refresh time: 20 sec
Outbound proxy mode: Auto
Outbound proxy: 2talk.co.nz
Outbound proxy port: 50600

If I can get 2talk working, I'll move on to greater things with Faktortel.

Cheers,

David.





19376 posts

Uber Geek
+1 received by user: 1214

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 334849 26-May-2010 00:05 Send private message

The key field you have missed is the SIP server.. This needs to go into the Registrar Server field - make this 2talk.co.nz

You don't need a outbound proxy or a Proxy Server address but setting these all to 2talk.co.nz won't do any harm



329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

  Reply # 334850 26-May-2010 00:09 Send private message

Still a "registration failed". I assume this is the Registrar server with port 5060. Tried 50600 as well but didn't work.

David.





19376 posts

Uber Geek
+1 received by user: 1214

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 334853 26-May-2010 00:13 Send private message

It is possible that 5060 is being blocked by your router because VFX is using the same port. I'm not sure what other ports 2talk use since I don't use their service. I know Faktortel support 5060-5080 from memory.

14 posts

Geek


Reply # 343576 20-Jun-2010 23:38 Send private message

Hi Dave. Did you manage to get your Siemens Gigaset S580IP working? I have recently purchased a Gigaset S685 IP Duo. Managed quite easily to get it working with 2talk and VoIPtalk (UK), but have had major difficulty getting it to work with Vfx on Asterisk. I have tried with WAG310g WAG160N and USR 9108 all to no avail. I just keep getting "Registration failed". Let me know if you managed to get it working. This is what my 2talk settings look like:
Gigaset 2talk config

297 posts

Ultimate Geek
+1 received by user: 37


  Reply # 343635 21-Jun-2010 08:54 Send private message

So DrCheese, with your current setup, your iPhone can connect to 2talk yes?
If so, we can rule out that the router is blocking things, though to be honest I'm not a big fan of that model in any way, shape or form.

If you can't get your iPhone or a Softphone to register with 2talk behind that router, then it means your router is getting likely getting in the way somewhere.

Try using a softphone like ZoIPer Classic, there's 3 fields to put in:
Server name: 2talk.co.nz
Username: Your phone number
Password: whatever your SIP Secret is
There's also display name, but it's not really relevant as 2talk override it with your phone number.
Grab the free ZoIPer classic here: http://www.zoiper.com/softphone/classic/



329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

  Reply # 343787 21-Jun-2010 15:15 Send private message

ChillingSilence: So DrCheese, with your current setup, your iPhone can connect to 2talk yes?
If so, we can rule out that the router is blocking things, though to be honest I'm not a big fan of that model in any way, shape or form.

If you can't get your iPhone or a Softphone to register with 2talk behind that router, then it means your router is getting likely getting in the way somewhere.

Try using a softphone like ZoIPer Classic, there's 3 fields to put in:
Server name: 2talk.co.nz
Username: Your phone number
Password: whatever your SIP Secret is
There's also display name, but it's not really relevant as 2talk override it with your phone number.
Grab the free ZoIPer classic here: http://www.zoiper.com/softphone/classic/


Softphones have always worked for me with my network setup to make calls using 2talk. The problem appears to be the Gigaset phone.

David.





297 posts

Ultimate Geek
+1 received by user: 37


  Reply # 343790 21-Jun-2010 15:18 Send private message

What if you set:

Domain: 2talk.co.nz
Proxy server address: 2talk.co.nz
Proxy server port: 5060
Registrar server: 2talk.co.nz

What codecs have you got the phone set to use?

You can also setup STUN:
STUN server: stun.2talk.co.nz
Port: 3478

You shouldn't need to, but just mentioning it to you for the sake of completeness :)



329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

  Reply # 345579 26-Jun-2010 18:48 Send private message

raynz and ChillingSilence:

I've given up on 2talk on my Gigaset phone. It apparently brings down all of the other registrations I've set up. I now just have Faktortel.com.au registered, which was the original purpose for buying the phone so I'm not too disappointed. Faktortel seems to maintain its registration without failing every few minutes, like 2talk was doing. I can still make calls using 2talk on a PC softphone as well as on a softphone on my iPhone using the same home LAN as the Gigaset.

For interest, my settings were as follows. I've tried several variants of this after consultation with the folks at 2talk. None of them ever worked.

Domain: 2talk.co.nz

Proxy server address: 2talk.co.nz

Proxy server port: 50600

Registrar server: 2talk.co.nz

Registrar server port: 50600

Registration refresh time: 300 sec

STUN enabled: Yes

STUN server: stun.2talk.co.nz

STUN port: 3478

STUN refresh time: 240 sec

NAT refresh time: 20 sec

Outbound proxy mode: Auto

Outbound proxy: 2talk.co.nz

Outbound proxy port: 50600


David.





65 posts

Master Geek

Subscriber

  Reply # 345587 26-Jun-2010 19:26 Send private message

I have an A580IP on 2talk, initially had problems getting it to register (which I think were more down to me being impatient) so used the 50600 port, that worked for 2 days and then I had issues with 1 way audio, changed back to port 5060 and has been fine since.

Settings:



329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

  Reply # 345590 26-Jun-2010 19:35 Send private message

lokeynz,

I've tried port 5060 as well but it still dropped the registration after a period of time (minutes to days), although I had the STUN and outbound proxy servers selected, which you apparently don't.

I'll try setting my phone exactly as you've posted above and see what happens. Do you have another VoIP provider as well? I also have VFX (WorldxChange) and Faktortel accounts. There might be a conflict with all providers using port 5060 in my case. I think my VFX setup uses port 5060.

David.







329 posts

Ultimate Geek
+1 received by user: 15

Trusted
Subscriber

  Reply # 347480 3-Jul-2010 11:55 Send private message

Finally found a solution to the problem. I originally had the Gigaset base station connected to my AG310 gateway. I also have an Apple wifi router connected to the gateway so I simply plugged the Gigaset base station into the Apple wireless router. No more problems and it handles the transfer of registration of my 2talk and Faktortel accounts seamlessly between the Gigaset and softphones, depending on which is in use.

If anyone needs further details let me know and I'll give you the configuration details. In a nutshell, I use DHCP and make sure that the SIP port numbers are all different for my two accounts plus my other VFX account. No port forwarding was necessary.

David.





Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Orcon Global Mode launched
Created by freitasm, last reply by Snackos on 27-Aug-2014 20:42 (88 replies)
Pages... 4 5 6


Advice on Residential Fence replacement and neighbour
Created by networkn, last reply by nickrout on 27-Aug-2014 19:45 (26 replies)
Pages... 2


What would show if the net went down?
Created by gnfb, last reply by oxnsox on 27-Aug-2014 19:49 (23 replies)
Pages... 2


Moving to Auckland - advise & recommendation
Created by nakedmolerat, last reply by nakedmolerat on 26-Aug-2014 22:48 (47 replies)
Pages... 2 3 4


Vodafone TV multicast settings on pfSense?
Created by kenkeniff, last reply by kenkeniff on 27-Aug-2014 10:32 (182 replies)
Pages... 11 12 13


XtraHost - Closing
Created by achieveit, last reply by quickymart on 27-Aug-2014 18:57 (19 replies)
Pages... 2


Slingshots Front Up! Are applauding or sceptical?
Created by gnfb, last reply by gnfb on 26-Aug-2014 21:49 (19 replies)
Pages... 2


Another Gaming computer help question
Created by Lyderies, last reply by timmmay on 26-Aug-2014 18:06 (38 replies)
Pages... 2 3



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.