TelstraClear offer a VDSL2 service. With this, they install a Thompson modem to terminate the VDSL circuit which they use as a bridge, with the idea of feeding Ethernet to the customer and having them establish a PPP session over the circuit back to the provider.

As you probably know, Cisco routers have built-in modems for VDSL2 (Cisco 887V) and modular routers (e.g. Cisco 2901) that can be equipped with VDSL2 interface cards (HWIC-1VDSL).

If you speak with TelstraClear and ask whether or not you have the option of terminating their circuit directly on your router, they'll do one of three things:

1) Stare blankly at your not fully understanding the question.
2) Tell you that you must use their bridging modem with the idea of mitigating the poor upload performance they suffered from with several of their clients during their initial 'pre-launch' testing.
3) Tell you that this does in-fact work, provided my feedback to them recently made it through the front lines to someone who cared enough to make it known.

I had a task to install three redundant links for a client recently, and chose to use TelstraClear's VDSL services. I also chose to go against TelstraClear's direct recommendation of bypassing their bridge, mainly because we had already ordered the VDSL HWIC cards before we were told about the expectation to use the provider supplied equipment. I'd also rather be able to see the VDSL line stats directly from the router, as the supplied Thompson bridge doesn't have any means I can tell of administrating the device (it seems they're either reflashed by TelstraClear, or configured in a way to prevent this).

I don't specifically recommend bypassing TelstraClear's method of providing connectivity, but if you choose to here is the configuration specifics I've used successfully (over all three sites). I really only post this to help anyone else in a similar situation, in an attempt to help avoid the troubles I've had with this.

------------------------------------------------------------------------------------------------------------
interface Dialer0
bandwidth 2000
bandwidth receive 10000
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username password 0
ppp ipcp dns request
no cdp enable
end

interface Ethernet0/3/0 (this will change depending on what model router is used, and what slot the card is in)
pppoe enable group global
pppoe-client dial-pool-number 1
no shut

interface vlan 1 (this will change depending on what interface faces the inside network)
ip nat inside

ip access-list standard VDSL-NAT
permit

ip nat inside source list VDSL-NAT interface Dialer0 overload
 ------------------------------------------------------------------------------------------------------------

Here is the debug from the PPP session coming up:

 ------------------------------------------------------------------------------------------------------------
Dec 20 21:05:35.985: %DIALER-6-BIND: Interface Vi2 bound to profile Di0
Dec 20 21:05:35.989: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
Dec 20 21:05:35.989: Vi2 PPP: Sending cstate UP notification
Dec 20 21:05:35.993: Vi2 PPP: Processing CstateUp message
Dec 20 21:05:36.001: PPP: Alloc Context [30CC3F3C]
Dec 20 21:05:36.001: ppp1 PPP: Phase is ESTABLISHING
Dec 20 21:05:36.001: Vi2 PPP: Using dialer call direction
Dec 20 21:05:36.001: Vi2 PPP: Treating connection as a callout
Dec 20 21:05:36.001: Vi2 PPP: Session handle[8B000001] Session id[1]
Dec 20 21:05:36.001: Vi2 LCP: Event[OPEN] State[Initial to Starting]
Dec 20 21:05:36.001: Vi2 PPP: No remote authentication for call-out
Dec 20 21:05:36.001: Vi2 LCP: O CONFREQ [Starting] id 1 len 10
Dec 20 21:05:36.001: Vi2 LCP: MagicNumber 0x03D65B6D (0x050603D65B6D)
Dec 20 21:05:36.001: Vi2 LCP: Event[UP] State[Starting to REQsent]
Dec 20 21:05:36.093: Vi2 LCP: I CONFREQ [REQsent] id 152 len 18
Dec 20 21:05:36.093: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.093: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.093: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.093: Vi2 LCP: O CONFNAK [REQsent] id 152 len 8
Dec 20 21:05:36.093: Vi2 LCP: MRU 1500 (0x010405DC)
Dec 20 21:05:36.093: Vi2 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
Dec 20 21:05:36.097: Vi2 LCP: I CONFACK [REQsent] id 1 len 10
Dec 20 21:05:36.097: Vi2 LCP: MagicNumber 0x03D65B6D (0x050603D65B6D)
Dec 20 21:05:36.097: Vi2 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
Dec 20 21:05:36.117: Vi2 LCP: I CONFREQ [ACKrcvd] id 153 len 18
Dec 20 21:05:36.117: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.117: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.117: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.117: Vi2 LCP: O CONFNAK [ACKrcvd] id 153 len 8
Dec 20 21:05:36.117: Vi2 LCP: MRU 1500 (0x010405DC)
Dec 20 21:05:36.117: Vi2 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
Dec 20 21:05:36.141: Vi2 LCP: I CONFREQ [ACKrcvd] id 154 len 18
Dec 20 21:05:36.141: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.141: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.141: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.141: Vi2 LCP: O CONFNAK [ACKrcvd] id 154 len 8
Dec 20 21:05:36.141: Vi2 LCP: MRU 1500 (0x010405DC)
Dec 20 21:05:36.141: Vi2 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
Dec 20 21:05:36.169: Vi2 LCP: I CONFREQ [ACKrcvd] id 155 len 18
Dec 20 21:05:36.169: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.169: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.169: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.169: Vi2 LCP: O CONFNAK [ACKrcvd] id 155 len 8
Dec 20 21:05:36.169: Vi2 LCP: MRU 1500 (0x010405DC)
Dec 20 21:05:36.169: Vi2 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
Dec 20 21:05:36.193: Vi2 LCP: I CONFREQ [ACKrcvd] id 156 len 18
Dec 20 21:05:36.193: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.193: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.197: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.197: Vi2 LCP: O CONFNAK [ACKrcvd] id 156 len 8
Dec 20 21:05:36.197: Vi2 LCP: MRU 1500 (0x010405DC)
Dec 20 21:05:36.197: Vi2 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
Dec 20 21:05:36.221: Vi2 LCP: I CONFREQ [ACKrcvd] id 157 len 18
Dec 20 21:05:36.221: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.221: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.221: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.221: Vi2 LCP: Sent too many CONFNAKs. Switch to CONFREJ
Dec 20 21:05:36.221: Vi2 LCP: O CONFREJ [ACKrcvd] id 157 len 8
Dec 20 21:05:36.221: Vi2 LCP: MRU 1492 (0x010405D4)
Dec 20 21:05:36.221: Vi2 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
Dec 20 21:05:36.245: Vi2 LCP: I CONFREQ [ACKrcvd] id 158 len 14
Dec 20 21:05:36.245: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.245: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.245: Vi2 LCP: O CONFACK [ACKrcvd] id 158 len 14
Dec 20 21:05:36.245: Vi2 LCP: AuthProto PAP (0x0304C023)
Dec 20 21:05:36.245: Vi2 LCP: MagicNumber 0x6D9633F4 (0x05066D9633F4)
Dec 20 21:05:36.245: Vi2 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
Dec 20 21:05:36.249: Vi2 PPP: Phase is AUTHENTICATING, by the peer
Dec 20 21:05:36.249: Vi2 PAP: Using hostname from interface PAP
Dec 20 21:05:36.249: Vi2 PAP: Using password from interface PAP
Dec 20 21:05:36.249: Vi2 PAP: O AUTH-REQ id 1 len 34 from "[email protected]
Dec 20 21:05:36.249: Vi2 LCP: State is Open
Dec 20 21:05:46.265: Vi2 AUTH: Timeout 1
Dec 20 21:05:46.265: Vi2 PAP: Using hostname from interface PAP
Dec 20 21:05:46.265: Vi2 PAP: Using password from interface PAP
Dec 20 21:05:46.265: Vi2 PAP: O AUTH-REQ id 2 len 34 from "[email protected]"
Dec 20 21:05:46.505: Vi2 PAP: I AUTH-ACK id 2 len 5
Dec 20 21:05:46.505: Vi2 PPP: Phase is FORWARDING, Attempting Forward
Dec 20 21:05:46.505: Vi2 PPP: Phase is ESTABLISHING, Finish LCP
Dec 20 21:05:46.505: Vi2 PPP: Phase is UP
Dec 20 21:05:46.505: Vi2 IPCP: Protocol configured, start CP. state[Initial]
Dec 20 21:05:46.505: Vi2 IPCP: Event[OPEN] State[Initial to Starting]
Dec 20 21:05:46.505: Vi2 IPCP: O CONFREQ [Starting] id 1 len 22
Dec 20 21:05:46.505: Vi2 IPCP: Address 0.0.0.0 (0x030600000000)
Dec 20 21:05:46.505: Vi2 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)
Dec 20 21:05:46.505: Vi2 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)
Dec 20 21:05:46.505: Vi2 IPCP: Event[UP] State[Starting to REQsent]
Dec 20 21:05:46.509: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
Dec 20 21:05:46.549: Vi2 IPCP: I CONFNAK [REQsent] id 1 len 22
Dec 20 21:05:46.549: Vi2 IPCP: Address (0x0306CB6132F0)
Dec 20 21:05:46.549: Vi2 IPCP: PrimaryDNS 203.97.78.43 (0x8106CB614E2B)
Dec 20 21:05:46.549: Vi2 IPCP: SecondaryDNS 203.97.78.44 (0x8306CB614E2C)
Dec 20 21:05:46.549: Vi2 IPCP: O CONFREQ [REQsent] id 2 len 22
Dec 20 21:05:46.549: Vi2 IPCP: Address (0x0306CB6132F0)
Dec 20 21:05:46.549: Vi2 IPCP: PrimaryDNS 203.97.78.43 (0x8106CB614E2B)
Dec 20 21:05:46.549: Vi2 IPCP: SecondaryDNS 203.97.78.44 (0x8306CB614E2C)
Dec 20 21:05:46.549: Vi2 IPCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]
Dec 20 21:05:46.577: Vi2 IPCP: I CONFACK [REQsent] id 2 len 22
Dec 20 21:05:46.577: Vi2 IPCP: Address (0x0306CB6132F0)
Dec 20 21:05:46.577: Vi2 IPCP: PrimaryDNS 203.97.78.43 (0x8106CB614E2B)
Dec 20 21:05:46.577: Vi2 IPCP: SecondaryDNS 203.97.78.44 (0x8306CB614E2C)
Dec 20 21:05:46.577: Vi2 IPCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
Dec 20 21:05:46.701: Vi2 IPCP: I CONFREQ [ACKrcvd] id 82 len 10
Dec 20 21:05:46.701: Vi2 IPCP: Address (0x0306DA653D16)
Dec 20 21:05:46.701: Vi2 IPCP: O CONFACK [ACKrcvd] id 82 len 10
Dec 20 21:05:46.701: Vi2 IPCP: Address  (0x0306DA653D16)
Dec 20 21:05:46.701: Vi2 IPCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
Dec 20 21:05:46.713: Vi2 IPCP: State is Open
Dec 20 21:05:46.713: Di0 IPCP: Install negotiated IP interface address
Dec 20 21:05:46.713: Di0 IPCP: Install route to 

 ------------------------------------------------------------------------------------------------------------

And finally the stats from the VDSL controller:

 ------------------------------------------------------------------------------------------------------------
hostname#show controller vdsl 0/3/0
Controller VDSL 0/3/0 is UP

Daemon Status: Up

XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0x93A9
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0x93A9
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FOC14387Y1J 2901/K9 15.0(1)M
Serial Number Far:
Modem Version Near: 15.0(1)M
Modem Version Far: 0x93a9

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2)
TC Mode: PTM
DELT configuration: disabled
DELT state: not running
Trellis: ON OFF
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 12.4 dB 17.8 dB
Attainable Rate: 42796 kbits/s 16092 kbits/s
Actual Power: 14.5 dBm 6.7 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 12.7 30.7 N/A 8.3 26.2 39.9 N/A
Signal Attenuation(dB): 12.7 30.7 N/A N/A 25.7 39.9 N/A
Noise Margin(dB): 12.4 12.4 N/A N/A 17.8 N/A N/A
Total FECS: 1 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0

Full inits: 0
Failed full inits: 0
Short inits: 0
Failed short inits: 0

Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)

Modem FW Version: 090929_1033-4.02L.01.AvC011b.d21j1
Modem PHY Version: AvC011b.d21j1


DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 33439 0 8413
Reed-Solomon EC: 0 67 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0 8 0 4
Actual INP: 0 4 0 4

Training Log : Stopped
Training Log Filename : flash:vdsllog.bin
 ------------------------------------------------------------------------------------------------------------