Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
Buying anything on Amazon? Please use the Geekzone Amazon aff link.




1134 posts

Uber Geek
+1 received by user: 59

Subscriber

Topic # 112002 22-Nov-2012 13:33 Send private message

I have a really weird problem. On my HP 4530s probook  laptop with i3 processor and Atheros 9000 series wlan windows 7 worked well.   I have upgraded to Windows 8 pro.

When connected to power everything works fine.  When on battery power Windows 8 connects to my modem but says no internet connection.  To connect to internet I have to plug power cord in.

Only on Windows 8. Had no problem with Windows 7.

Just to be sure when it says no internet connection, I checked on my Asus Transformer and it connects fine. As well as my Linux computer.

Only happens Windows 8 and battery power.




HTPC AMD A4-5300 cpu, Gigabyte ga2fa75m-d3h motherboard, , 4GB DDR3 ram, onboard  graphics. Hauppuage HVR 3300 tuner,  Antec 2480B case, Windows 7 home premium 64 bit using media center

Create new topic
685 posts

Ultimate Geek
+1 received by user: 37


  Reply # 721345 22-Nov-2012 14:32 Send private message

Sounds like a power saving feature. Have you checked those settings? Might be in the BIOS as well.

Probably unrelated but I have a weird issue on Win 8 whereby it doesn't connect automatically to my Wifi and tells me my (known) WiFi connection is available. I have to manually press connect even though the "connect automatically" box is checked.

253 posts

Ultimate Geek
+1 received by user: 33


  Reply # 721359 22-Nov-2012 14:52 Send private message

Hi,
I Have a 4530 with i5 with dual boot 7 & 8
I dont have any issues.
Try putting manual DNS i.e. Google 8.8.8.8 & 8.8.4.4 and see if that fix'es it.

John




I know enough to be dangerous

BDFL
50449 posts

Uber Geek
+1 received by user: 4855

Administrator
Trusted
Geekzone
Subscriber

  Reply # 721368 22-Nov-2012 15:02 Send private message

It won't be the DNS. Your wireless adapter has the wrong power settings, or the driver is old/not compatible.




2002 posts

Uber Geek
+1 received by user: 107

Trusted
Subscriber

  Reply # 721374 22-Nov-2012 15:09 Send private message

I had the same problem with my ASUS UX31e except it was the Intel Video. Every time I had the laptop on battery power and tried to watch a video via a web browser the laptop just powered down completely. It worked fine while on power.

Once I downloaded the official ASUS video driver it worked fine on both battery and power.

Maybe try the official HP driver if you haven't already?

Cheers, Matt.

PS: I wonder if something has changed in the power management of Windows 8




Nexus 5, Galaxy Tab S, HP Ultrabook, Mysky HDi, 2talk, Pebble Steel



1134 posts

Uber Geek
+1 received by user: 59

Subscriber

Reply # 721431 22-Nov-2012 16:08 Send private message

freitasm: It won't be the DNS. Your wireless adapter has the wrong power settings, or the driver is old/not compatible.
oh, sorry I should have said I downloaded the Windows 8 wireless adapter from HP and didn't help.  Will look into power saving see what I can find




HTPC AMD A4-5300 cpu, Gigabyte ga2fa75m-d3h motherboard, , 4GB DDR3 ram, onboard  graphics. Hauppuage HVR 3300 tuner,  Antec 2480B case, Windows 7 home premium 64 bit using media center

2305 posts

Uber Geek
+1 received by user: 243

Subscriber

  Reply # 721434 22-Nov-2012 16:21 Send private message

Try changing the wireless broadcast channel on your router.



1134 posts

Uber Geek
+1 received by user: 59

Subscriber

  Reply # 721503 22-Nov-2012 19:18 Send private message

freitasm: It won't be the DNS. Your wireless adapter has the wrong power settings, or the driver is old/not compatible.
hi, yeah seems to be working now (touch wood).  I never thought power settings would change that. It connected to modem fine just no internet. I changed the power setting to maximum performance and all is working well now.
Thankyou to all who suggested the power settings




HTPC AMD A4-5300 cpu, Gigabyte ga2fa75m-d3h motherboard, , 4GB DDR3 ram, onboard  graphics. Hauppuage HVR 3300 tuner,  Antec 2480B case, Windows 7 home premium 64 bit using media center

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

forgot how to unlock a car door
Created by joker97, last reply by joker97 on 18-Dec-2014 19:51 (37 replies)
Pages... 2 3


Just checking that this DIY electrical connection is not allowed?
Created by joker97, last reply by joker97 on 17-Dec-2014 22:37 (33 replies)
Pages... 2 3


Spray Foam Insulation
Created by AACTech, last reply by timmmay on 18-Dec-2014 16:19 (28 replies)
Pages... 2


Has Spark (Telecom) locked their iphone 6 ?
Created by anewguy2014, last reply by michaelmurfy on 17-Dec-2014 14:32 (25 replies)
Pages... 2


In defence of cats
Created by Rikkitic, last reply by DarthKermit on 17-Dec-2014 15:40 (68 replies)
Pages... 3 4 5


Slaughter of Innocents
Created by networkn, last reply by networkn on 18-Dec-2014 20:08 (43 replies)
Pages... 2 3


Lightbox launches on PlayStation 4
Created by freitasm, last reply by solaybro on 18-Dec-2014 17:57 (20 replies)
Pages... 2


Couriers starting to charge for redelivery
Created by mattwnz, last reply by raytaylor on 18-Dec-2014 02:27 (77 replies)
Pages... 4 5 6



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.