Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1849 posts

Uber Geek
+1 received by user: 244


Topic # 104116 15-Jun-2012 09:00 Send private message

Just wondering, how long is normal for a first ping to an address. I've read that the first one is delayed by ARP, but is this correct and what is normal for this?  See below for a few from my home network - do these look ok?

Pinging facebook.com [66.220.158.11] with 32 bytes of d
Reply from 66.220.158.11: bytes=32 time=982ms TTL=242
Reply from 66.220.158.11: bytes=32 time=219ms TTL=242
Reply from 66.220.158.11: bytes=32 time=219ms TTL=242
Reply from 66.220.158.11: bytes=32 time=218ms TTL=242

Pinging ubuntu.org [67.215.65.132] with 32 bytes of data:
Reply from 67.215.65.132: bytes=32 time=734ms TTL=53
Reply from 67.215.65.132: bytes=32 time=158ms TTL=53
Reply from 67.215.65.132: bytes=32 time=159ms TTL=53
Reply from 67.215.65.132: bytes=32 time=158ms TTL=53

Pinging yahoo.com [209.191.122.70] with 32 bytes of data:
Reply from 209.191.122.70: bytes=32 time=967ms TTL=49
Reply from 209.191.122.70: bytes=32 time=200ms TTL=48
Reply from 209.191.122.70: bytes=32 time=194ms TTL=49
Reply from 209.191.122.70: bytes=32 time=199ms TTL=48

Pinging asp.net [206.72.125.204] with 32 bytes of data:
Reply from 206.72.125.204: bytes=32 time=900ms TTL=109
Reply from 206.72.125.204: bytes=32 time=223ms TTL=109
Reply from 206.72.125.204: bytes=32 time=223ms TTL=109
Reply from 206.72.125.204: bytes=32 time=223ms TTL=109

Create new topic
19780 posts

Uber Geek
+1 received by user: 1517

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 641135 15-Jun-2012 09:05 Send private message

Are you testing via a wireless connection?




1849 posts

Uber Geek
+1 received by user: 244


  Reply # 641137 15-Jun-2012 09:08 Send private message

No, gigE straight into router (running gargoyle)

I'm also running an amahi server and using the dns function on that, so wondering if that's likely to be it.

1910 posts

Uber Geek
+1 received by user: 454

Trusted
Spark NZ

  Reply # 641156 15-Jun-2012 09:34 Send private message

Try pinging the IP address directly (not the domain name) to eliminate that as an issue.

Cheers - N



1849 posts

Uber Geek
+1 received by user: 244


  Reply # 641182 15-Jun-2012 10:21 Send private message

Good idea, will give that a try when I get home.

So I take it you think those results look unusually high for that first one, indicating a possible issue? If I repeat the ping it seems to be cached so looks fine. But if I try again a while later it takes 700 - 900+ms for that first one again.

2698 posts

Uber Geek
+1 received by user: 399


  Reply # 641189 15-Jun-2012 10:31 Send private message

I suspect the extra time for the first ping is the DNS resolution happening. When you re-ping it is already cached (for whatever the TTL is for that site), so the first doesn't take longer.

As @Talkiet says, just ping the IP number itself and that will remove the DNS lookup time from the equation.



1849 posts

Uber Geek
+1 received by user: 244


  Reply # 641561 15-Jun-2012 18:45 Send private message

Hmm, doesn't seem to be DNS:

EDIT: My setup if it matters is TP-Link modem in Half-Bridge (PPP Extension) -> TL-WR1043ND running gargoyle with an old PC running Amahi server (acting as DHCP\DNS server)


Pinging 66.220.158.11 with 32 bytes of data:
Reply from 66.220.158.11: bytes=32 time=786ms TTL=243
Reply from 66.220.158.11: bytes=32 time=229ms TTL=243
Reply from 66.220.158.11: bytes=32 time=229ms TTL=243
Reply from 66.220.158.11: bytes=32 time=229ms TTL=243

Ping statistics for 66.220.158.11:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 229ms, Maximum = 786ms, Average = 368ms

C:\Users\Simon>ping 67.215.65.132

Pinging 67.215.65.132 with 32 bytes of data:
Reply from 67.215.65.132: bytes=32 time=616ms TTL=53
Reply from 67.215.65.132: bytes=32 time=158ms TTL=53
Reply from 67.215.65.132: bytes=32 time=158ms TTL=53
Reply from 67.215.65.132: bytes=32 time=158ms TTL=53

Ping statistics for 67.215.65.132:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 158ms, Maximum = 616ms, Average = 272ms

C:\Users\Simon>ping 209.191.122.70

Pinging 209.191.122.70 with 32 bytes of data:
Reply from 209.191.122.70: bytes=32 time=981ms TTL=49
Reply from 209.191.122.70: bytes=32 time=200ms TTL=48
Reply from 209.191.122.70: bytes=32 time=199ms TTL=48
Reply from 209.191.122.70: bytes=32 time=199ms TTL=49

Ping statistics for 209.191.122.70:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 199ms, Maximum = 981ms, Average = 394ms

C:\Users\Simon>ping 206.72.125.204

Pinging 206.72.125.204 with 32 bytes of data:
Reply from 206.72.125.204: bytes=32 time=822ms TTL=109
Reply from 206.72.125.204: bytes=32 time=222ms TTL=109
Reply from 206.72.125.204: bytes=32 time=224ms TTL=109
Reply from 206.72.125.204: bytes=32 time=223ms TTL=109




313 posts

Ultimate Geek
+1 received by user: 47


  Reply # 641638 15-Jun-2012 21:28 Send private message

sidefx: My setup if it matters is TP-Link modem in Half-Bridge (PPP Extension) -> TL-WR1043ND running gargoyle with an old PC running Amahi server (acting as DHCP\DNS server)


What is the default gateway advertised by the Amahi server? If it's advertising itself it could be an ICMP redirect, but that should be pretty quick on the network you describe.
It looks like flow based switching or firewalling to me.  The first packet is being handled by a CPU intensive lookup, and the rest are treated as part of the same flow and are using the cached result.  Does your gargoyle box report it's current CPU load?



1849 posts

Uber Geek
+1 received by user: 244


  Reply # 641677 15-Jun-2012 22:51 Send private message

Hmm it's looking like either the gargoyle router or the half-bridge setup is the issue.

I tried plugging my PC straight into the modem and with a bit of tinkering got that connected to the internet, while still running in half bridge\PPP IP Extension. The TP-Link is not as easy to use in half-bridge mode with a single PC as RTA1360! - but once it did work it worked flawlessly - no delays on those first pings. I then plugged the PC back into the router, unplugged everything else including the Amahi server and turn DHCP back on on the router. Now I get the delays on that first ping again :-/ So that's just with modem -> Gargoyle Router -> single PC with nothing else on my network plugged in.

Gargoyle does report CPU, but even after a number of pings with the delays it is as follows:

CPU Load Averages:0.00 / 0.03 / 0.11 (1/5/15 minutes)

2009 posts

Uber Geek
+1 received by user: 267

Trusted
Subscriber

  Reply # 641684 15-Jun-2012 23:17 Send private message

Apart from a higher number in your ping test are you actually seeing a problem or are you just curious as to why it's happening?

Using ICMP for performance testing is not going to end well..



1849 posts

Uber Geek
+1 received by user: 244


  Reply # 641689 15-Jun-2012 23:32 Send private message

Yes, curiosity is one reason. But I'm also running a truenet probe and this (possibly) seems to be royalling screwing up the latency tests that it does because they seem to be all over the place whereas the rest of the results seem pretty much what I would expect. And of course I'm wondering if it's causing other issues that perhaps aren't as apparent.

Any suggestions for tools or methods to do a "health check" on the setup?



1849 posts

Uber Geek
+1 received by user: 244


  Reply # 641720 16-Jun-2012 09:52 Send private message

Update: I restored the original firmware onto the gargoyle router and the issue persisted, so it seems it wasn't a gargoyle specific problem, but rather something with the half-bridge setup. Must admit it was sometimes a bit of a pain getting the modem to assign ip address to router (you have to go into gargoyle and click "renew dhcp lease" at the right time or it won't work) so maybe the modem I am using is not the best for half-bridging.

I didn't originally buy it for this purpose - it is a TP-Link TD-W8960N that I had before switching to the RTA1320 + TL-WR1043ND and I was planning to sell the TD-W8960N until the RTA1320 crapped out. I then found the TD-W8960N could do half bridging\"PPP IP Extension" so started using that but it seems it isn't the best at it...

So now I'm back to using the TD-W8960N as full modem\router and everything looks fine; No delayed pings, web pages actually seem to load snappier and Diablo 3 lag which was terrible has improved remarkably...

But I now lose the gigE and gargoyle capabilities of the TL-WR1043ND which is a real bummer because gargoyle especially was really, really good. But I'm also a bit wary of buying a new modem though incase I have similar issues; and modems that can half-bridge seem a little rare, especially cheaper ones! Might have to get some replacement caps for the RTA1360 and see if I can get it back up and running....

Anyway, thanks for the help and suggestions folks! :)

61 posts

Master Geek
+1 received by user: 9


  Reply # 641963 16-Jun-2012 22:23 Send private message

I've got a DrayTek Vigor 120 modem  setup using PPPoE pass through to a TL-WR1043ND router running Gargoyle 1.5.4
This setup has always be reliable for me. My kids don't complain about online gaming lag and they are normally pretty quick to point out these things. Smile

My ping results to 67.215.65.132
Pinging 67.215.65.132 with 32 bytes of data:
Reply from 67.215.65.132: bytes=32 time=153ms TTL=53
Reply from 67.215.65.132: bytes=32 time=157ms TTL=53
Reply from 67.215.65.132: bytes=32 time=151ms TTL=53
Reply from 67.215.65.132: bytes=32 time=153ms TTL=53

Ping statistics for 67.215.65.132:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 151ms, Maximum = 157ms, Average = 153ms

Dave.

2009 posts

Uber Geek
+1 received by user: 267

Trusted
Subscriber

  Reply # 641967 16-Jun-2012 23:01 Send private message

RTA1320 + E4200 in half-bridge

Pinging 67.215.65.132 with 32 bytes of data:
Reply from 67.215.65.132: bytes=32 time=144ms TTL=49
Reply from 67.215.65.132: bytes=32 time=142ms TTL=49
Reply from 67.215.65.132: bytes=32 time=142ms TTL=49
Reply from 67.215.65.132: bytes=32 time=142ms TTL=49


Given the Irish are here for the Rugby I'll use this opportunity to offer an Irish suggestion "have you tried turning it off and on again?"
http://www.youtube.com/watch?v=nn2FB1P_Mn8

172 posts

Master Geek


  Reply # 641980 16-Jun-2012 23:31 Send private message

Vigor 120 connected to Time Capsule with Passthrough


PING 67.215.65.132 (67.215.65.132): 56 data bytes
64 bytes from 67.215.65.132: icmp_seq=0 ttl=53 time=143.890 ms
64 bytes from 67.215.65.132: icmp_seq=1 ttl=53 time=137.133 ms
64 bytes from 67.215.65.132: icmp_seq=2 ttl=53 time=136.749 ms
64 bytes from 67.215.65.132: icmp_seq=3 ttl=53 time=134.498 ms
64 bytes from 67.215.65.132: icmp_seq=4 ttl=53 time=137.177 ms
64 bytes from 67.215.65.132: icmp_seq=5 ttl=53 time=137.250 ms
64 bytes from 67.215.65.132: icmp_seq=6 ttl=53 time=138.190 ms
64 bytes from 67.215.65.132: icmp_seq=7 ttl=53 time=136.472 ms
64 bytes from 67.215.65.132: icmp_seq=8 ttl=53 time=136.656 ms
64 bytes from 67.215.65.132: icmp_seq=9 ttl=53 time=137.349 ms

--- 67.215.65.132 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 134.498/137.536/143.890/2.301 ms

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

How stable are snap IP addresses?
Created by Physn, last reply by Oriphix on 23-Oct-2014 18:09 (20 replies)
Pages... 2


Spark Socialiser
Created by freitasm, last reply by freitasm on 22-Oct-2014 18:39 (34 replies)
Pages... 2 3


$39 iPhone plan goneburger
Created by MadEngineer, last reply by Demeter on 23-Oct-2014 16:09 (16 replies)
Pages... 2


American legal jurisdiction in New Zealand
Created by ajobbins, last reply by gzt on 21-Oct-2014 14:58 (30 replies)
Pages... 2


iPad Air 2 and iPad Mini 3. Gonna get one?
Created by Dingbatt, last reply by dickytim on 23-Oct-2014 21:35 (100 replies)
Pages... 5 6 7


Snap have failed our company!
Created by dafman, last reply by kornflake on 23-Oct-2014 17:41 (37 replies)
Pages... 2 3


Thief taunts 12 year old via stolen laptop
Created by macuser, last reply by charsleysa on 22-Oct-2014 23:49 (12 replies)

Another Trade Me competitor: SellShed
Created by freitasm, last reply by freitasm on 23-Oct-2014 19:00 (44 replies)
Pages... 2 3



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.