Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
Buying anything on Amazon? Please use the Geekzone Amazon aff link.




Nate wants an iphone
3852 posts

Uber Geek
+1 received by user: 7

Mod Emeritus
Trusted
Subscriber

Topic # 20554 30-Mar-2008 12:53 Send private message

Hello all,

I thought I'd make this a seperate thread as I've resolved a lot of the issues I was having with the DVB-T broadcast. I've set up GBpvr and its working great. EPG is coming though as pictured below.


The video is working ok as well. But I'm still having audio issues.


I've heard that some channels (1 and 2) use AAC while others require the monogram codec. I've tried installing monogram but it always fails by itself, I've also tried codec packs which supposedly have them as well. So far I don't get any audio on any channel.

I've included the settings that I use for playback currently:



The question becomes, what settings do I need. Any ideas for the audio codec? Are there any install instructions for the monogram one?




webhosting |New Zealand connectionsgeekzone IRC chat
Loose lips may sink ships - Be smart - Don't post internal/commercially sensitive or confidential information!

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
3963 posts

Uber Geek
+1 received by user: 26

Trusted

  Reply # 119685 30-Mar-2008 12:59 Send private message

I have been exchanging information with sub on similar issues.  I could not play any .ts files using gbpvr until I applied a patch and turned off some setting in config.xml. Looks like you've done that.

But I cannot get any audio from a file that uses the AAC LATM codec even though Monogram is installed and registered. Check out the following thread:

http://forums.gbpvr.com/showthread.php?t=33799

From reading posts 19 and 20 it sounds like the Haali splitter might not be compatible for the Monogram codec. I also tried HDTV Pump but that just causes WMP and gbpvr when trying to play any .ts file.

Might be SOL until sub fixes it

Larry




System One: Popcorn Hour A200,  PS3 SuperSlim, NPVR running on Gigabyte Brix, Sony BDP-S390 BD player, Logitech Revue, Pioneer AVR, Panasonic 60" 3D plasma

System Two: Popcorn Hour A200 ,  Oppo BDP-80 BluRay Player with hardware mode to be region free, Vivitek HD1080P 1080P DLP projector with 100" screen. Harman Kardon HK AVR 254 7.1 receiver, Toshiba HD-A2 HD-DVD player, Roku XS media player

Check out my blog at lchiu.blogspot.com

20205 posts

Uber Geek
+1 received by user: 1754

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 119686 30-Mar-2008 13:01 Send private message

You should be need to copy the monogram aac file to a directory such as \windows\system32 and then register it. Have you done that?

The GB-PVR config.xml file contains a reference to the H.264 aucio decoder that the GUI doesn't have, check that and make sure it is set to MONOGRAM AAC Decoder



Nate wants an iphone
3852 posts

Uber Geek
+1 received by user: 7

Mod Emeritus
Trusted
Subscriber

  Reply # 119688 30-Mar-2008 13:20 Send private message

I figured out that I had to run command prompt in administrative mode to register the file. Thats installed successfully now.

I've opened up gbpvr and made a few changes there. No audio yet - but am restarting the machine anyway.

I've included part of the config.xml file - am I missing anything?

<Version>GB-PVR v1.2.9</Version>
  <!-- Decoder/render settings -->
  <HardwareDecoder>None - use software decoder</HardwareDecoder>
  <SupportedDecoders>bitcontrol® MPEG-2 Video Decoder,DScaler Mpeg2 Video Decoder,Microsoft MPEG-2 Video Decoder,CyberLink DTV Video Decoder,ATI MPEG Video Decoder,ArcSoft Video Decoder,InterVideo NonCSS Video Decoder for Hauppauge,InterVideo Video Decoder,CyberLink Video/SP Decoder (ATI),CyberLink Video/SP Decoder (PDVD7),NVIDIA Video Decoder,CyberLink Video/SP Decoder,Elecard MPEG2 Video Decoder,Elecard MPEG-2 Video Decoder,Moonlight-Elecard MPEG2 Video Decoder,MainConcept MPEG Video Decoder,MainConcept MPEG-2 Decoder,MainConcept (Hauppauge) MPEG Video Decoder,Sonic Cinemaster® DS Video Decoder,Zulu HDTV Video Decoder(BDA),Nero Video Decoder,GPL MPEG-1/2 Decoder,MPV Decoder Filter,ffdshow MPEG-4 Video Decoder,ffdshow Video Decoder,HCW MPEG-2 Video Decoder,MPEG Video Decoder</SupportedDecoders>
  <SupportedAudioDecoders>AC3Filter,CyberLink Audio Decoder(TwinHan),CyberLink Audio Decoder (PDVD7),MPEG Audio Decoder,ArcSoft Audio Decoder,NVIDIA Audio Decoder,CyberLink Audio Decoder,InterVideo Audio Decoder,InterVideo NonCSS Audio Decoder for Hauppauge,MainConcept MPEG Audio Decoder,MainConcept (Hauppauge) MPEG Audio Decoder,Sonic Cinemaster® DS Audio Decoder,Nero Digital Audio Decoder,ffdshow Audio Decoder,DScaler Audio Decoder,MPA Decoder Filter,Sonic Cinemaster® Audio Decoder 4.2</SupportedAudioDecoders>
  <SupportedDVDDecoders>Sonic Cinemaster® VideoDecoder 4.2,InterVideo Video Decoder,NVIDIA Video Decoder,CyberLink Video/SP Decoder (PDVD7),CyberLink Video/SP Decode (PDVD7.x),CyberLink Video/SP Decoder (PDVD7 UPnP),CyberLink DTV Video Decoder,CyberLink Video/SP Decoder,MainConcept MPEG Video Decoder,Sonic Cinemaster® DS Video Decoder,DScaler Mpeg2 Video Decoder,MPV Decoder Filter</SupportedDVDDecoders>
  <SupportedDVDNavigators>DVD Navigator,InterVideo Navigator,CyberLink DVD Navigator,CyberLink DVD Navigator (PDVD7),CyberLink DVD Navigator (PDVD6),NVIDIA Navigator</SupportedDVDNavigators>
  <PreferredDecoder>CyberLink Video/SP Decoder (PDVD7)</PreferredDecoder>
  <PreferredAudioRenderer>Default DirectSound Device</PreferredAudioRenderer>
  <PreferredAudioDecoder>MONOGRAM AAC Decoder</PreferredAudioDecoder>
  <PreferredDVDAudioDecoder>CyberLink Audio Decoder</PreferredDVDAudioDecoder>
  <PreferredDVDAudioRenderer>Speakers (Realtek AC'97 Audio)</PreferredDVDAudioRenderer>
  <PreferredDVDDecoder>CyberLink Video/SP Decoder (PDVD7)</PreferredDVDDecoder>
  <PreferredDVDNavigator>DVD Navigator</PreferredDVDNavigator>
  <SupportedH264Decoders>CyberLink H.264/AVC Decoder (PDVD7.x),CyberLink H.264/AVC Decoder (AzureWave),ffdshow Video Decoder,CoreAVC Video Decoder,ArcSoft Video Decoder</SupportedH264Decoders>
  <PreferredH264VideoDecoder>CyberLink H.264/AVC Decoder (PDVD7.x)</PreferredH264VideoDecoder>
  <PreferredAC3AudioDecoder>MONOGRAM AAC Decoder</PreferredAC3AudioDecoder>
  <PreferredAACAudioDecoder>MONOGRAM AAC Decoder</PreferredAACAudioDecoder>
  <PreferredAACLATMAudioDecoder>MONOGRAM AAC Decoder</PreferredAACLATMAudioDecoder>






webhosting |New Zealand connectionsgeekzone IRC chat
Loose lips may sink ships - Be smart - Don't post internal/commercially sensitive or confidential information!



Nate wants an iphone
3852 posts

Uber Geek
+1 received by user: 7

Mod Emeritus
Trusted
Subscriber

  Reply # 119689 30-Mar-2008 13:43 Send private message

Update: I can get audio if I start a recording and watch that recording even while its recording... but live tv results in no audio.




webhosting |New Zealand connectionsgeekzone IRC chat
Loose lips may sink ships - Be smart - Don't post internal/commercially sensitive or confidential information!

sub

243 posts

Master Geek


  Reply # 119693 30-Mar-2008 15:05 Send private message

cokemaster: Update: I can get audio if I start a recording and watch that recording even while its recording... but live tv results in no audio.
If you post the logs over at the GB-PVR forums I'll take a look.

At a guess though, if you had GB-PVR installed prior to the recently released v1.2.9, did you follow the instructions in the release notes with 1.2.9 to recreate your capture source and rescan for channels? This is required because new information is collected about the audio format of the AAC channels. If you hadnt done this, the information will not available, and it'll result in no audio for live tv.

3963 posts

Uber Geek
+1 received by user: 26

Trusted

  Reply # 119697 30-Mar-2008 15:32 Send private message

sbiddle: You should be need to copy the monogram aac file to a directory such as \windows\system32 and then register it. Have you done that?

The GB-PVR config.xml file contains a reference to the H.264 aucio decoder that the GUI doesn't have, check that and make sure it is set to MONOGRAM AAC Decoder


I just put the directshow filter in windows\system32 and from the command prompt did regsvr32 whatever.ax (can't remember the name)

Since there is no choice on how to use this filter (other choices for AAC LATM) I think I recall reading on the gbpvr forum that sub has not provided a drop down list to select it. If registered it will be used.

And I do have the setting for the filter in my config.xml file. I think my problem is the Haali Pump filter not possibly being compatible with the Monogram filter.




System One: Popcorn Hour A200,  PS3 SuperSlim, NPVR running on Gigabyte Brix, Sony BDP-S390 BD player, Logitech Revue, Pioneer AVR, Panasonic 60" 3D plasma

System Two: Popcorn Hour A200 ,  Oppo BDP-80 BluRay Player with hardware mode to be region free, Vivitek HD1080P 1080P DLP projector with 100" screen. Harman Kardon HK AVR 254 7.1 receiver, Toshiba HD-A2 HD-DVD player, Roku XS media player

Check out my blog at lchiu.blogspot.com

sub

243 posts

Master Geek


  Reply # 119698 30-Mar-2008 15:47 Send private message

lchiu7: I have been exchanging information with sub on similar issues.  I could not play any .ts files using gbpvr until I applied a patch and turned off some setting in config.xml. Looks like you've done that.

But I cannot get any audio from a file that uses the AAC LATM codec even though Monogram is installed and registered. Check out the following thread:

http://forums.gbpvr.com/showthread.php?t=33799

From reading posts 19 and 20 it sounds like the Haali splitter might not be compatible for the Monogram codec. I also tried HDTV Pump but that just causes WMP and gbpvr when trying to play any .ts file.
Its important to note that the our discussion about the haali spitter etc on the GB-PVRs forums (not the thread linked above) was in relation to your Telstra Clear transport stream files, which resolved an entirely different problem (audio sync issue playing transport stream files). The Haali splitter will work fine with TelstraClear MPEG2 transport stream files. It wont work with AAC LATM audio.

DVB-T with H.264 and AAC LATM audio is an entirely different kettle of fish. With the appropriate decoders installed, you should be able to get live tv with audio in GB-PVR. You can also make bit perfect recordings. There is currently an audio/video sync issue when playing back those recordings, which I'm looking into.

sub

243 posts

Master Geek


  Reply # 119699 30-Mar-2008 15:49 Send private message

lchiu7:
sbiddle: You should be need to copy the monogram aac file to a directory such as \windows\system32 and then register it. Have you done that?

The GB-PVR config.xml file contains a reference to the H.264 aucio decoder that the GUI doesn't have, check that and make sure it is set to MONOGRAM AAC Decoder


I just put the directshow filter in windows\system32 and from the command prompt did regsvr32 whatever.ax (can't remember the name)

Since there is no choice on how to use this filter (other choices for AAC LATM) I think I recall reading on the gbpvr forum that sub has not provided a drop down list to select it. If registered it will be used.

And I do have the setting for the filter in my config.xml file. I think my problem is the Haali Pump filter not possibly being compatible with the Monogram filter.
My post above will answer the question about the Haali splitter and lack of audio. You can switch back to using GB-PVR's built in TS reader filter, which does support AAC LATM, but it can have audio/video sync problems in some circumstances. I'm looking into this. This component is only a few weeks old, so still very new, and a few kinks to iron out.

If you're missing audio with live tv, then post the logs over at the GB-PVR forums and I'll take a look.

3963 posts

Uber Geek
+1 received by user: 26

Trusted

  Reply # 119701 30-Mar-2008 16:14 Send private message

sub:
lchiu7: I have been exchanging information with sub on similar issues.  I could not play any .ts files using gbpvr until I applied a patch and turned off some setting in config.xml. Looks like you've done that.

But I cannot get any audio from a file that uses the AAC LATM codec even though Monogram is installed and registered. Check out the following thread:

http://forums.gbpvr.com/showthread.php?t=33799

From reading posts 19 and 20 it sounds like the Haali splitter might not be compatible for the Monogram codec. I also tried HDTV Pump but that just causes WMP and gbpvr when trying to play any .ts file.
Its important to note that the our discussion about the haali spitter etc on the GB-PVRs forums (not the thread linked above) was in relation to your Telstra Clear transport stream files, which resolved an entirely different problem (audio sync issue playing transport stream files). The Haali splitter will work fine with TelstraClear MPEG2 transport stream files. It wont work with AAC LATM audio.

DVB-T with H.264 and AAC LATM audio is an entirely different kettle of fish. With the appropriate decoders installed, you should be able to get live tv with audio in GB-PVR. You can also make bit perfect recordings. There is currently an audio/video sync issue when playing back those recordings, which I'm looking into.


Yes it started with the TCL ts streams which you solved for me but then having done that I thought I would try the HD streams. So it sort of followed but I am guessing if I could not play regular .ts streams then audio or not I would not be able to play the HD streams. Will try out your suggestion about turning on internal support for ts streams since I decided that I didn't need the Dreambox I had borrowed and won't really be getting anymore MPEG2 ts streams unless I go for a DVB-C capture card which I presume produces the same type of files the Dreambox does.




System One: Popcorn Hour A200,  PS3 SuperSlim, NPVR running on Gigabyte Brix, Sony BDP-S390 BD player, Logitech Revue, Pioneer AVR, Panasonic 60" 3D plasma

System Two: Popcorn Hour A200 ,  Oppo BDP-80 BluRay Player with hardware mode to be region free, Vivitek HD1080P 1080P DLP projector with 100" screen. Harman Kardon HK AVR 254 7.1 receiver, Toshiba HD-A2 HD-DVD player, Roku XS media player

Check out my blog at lchiu.blogspot.com

970 posts

Ultimate Geek
+1 received by user: 20

Trusted

  Reply # 119702 30-Mar-2008 16:16 Send private message

sub: There is currently an audio/video sync issue when playing back those recordings, which I'm looking into.


Sorry to take over the thread, but does this explain why i have sync issues when i have a client setup to get live tv via "file sharing"

"Streaming" doesnt seem to work just end up with a blank screen




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

sub

243 posts

Master Geek


  Reply # 119704 30-Mar-2008 16:33 Send private message

mentalinc:
sub: There is currently an audio/video sync issue when playing back those recordings, which I'm looking into.


Sorry to take over the thread, but does this explain why i have sync issues when i have a client setup to get live tv via "file sharing"

"Streaming" doesnt seem to work just end up with a blank screen
The client/server support currently only supports .mpg files. I'm sure surprised you had any luck with .ts files.  I've never once even tried .ts files in client/server mode. It is on my list of things to look into in the future.

sub

243 posts

Master Geek


  Reply # 119705 30-Mar-2008 16:35 Send private message

lchiu7:
Yes it started with the TCL ts streams which you solved for me but then having done that I thought I would try the HD streams. So it sort of followed but I am guessing if I could not play regular .ts streams then audio or not I would not be able to play the HD streams. Will try out your suggestion about turning on internal support for ts streams since I decided that I didn't need the Dreambox I had borrowed and won't really be getting anymore MPEG2 ts streams unless I go for a DVB-C capture card which I presume produces the same type of files the Dreambox does.
Yep, no worries - I guessed this from your post here, but I wanted to make it clear why this was incorrect before everyone starts installing haali splitter etc to try to get H.264/AAC LATM working (which wouldnt work). This stuff is pretty complex, and mixing the facts up can make it more confusing for people.



Nate wants an iphone
3852 posts

Uber Geek
+1 received by user: 7

Mod Emeritus
Trusted
Subscriber

  Reply # 119706 30-Mar-2008 16:42 Send private message

sub:
cokemaster: Update: I can get audio if I start a recording and watch that recording even while its recording... but live tv results in no audio.
If you post the logs over at the GB-PVR forums I'll take a look.

At a guess though, if you had GB-PVR installed prior to the recently released v1.2.9, did you follow the instructions in the release notes with 1.2.9 to recreate your capture source and rescan for channels? This is required because new information is collected about the audio format of the AAC channels. If you hadnt done this, the information will not available, and it'll result in no audio for live tv.


Thanks - I started off with 1.2.9. Just readding sources now as a sanity check (having issues picking those channels back up) but will give it up a go...




webhosting |New Zealand connectionsgeekzone IRC chat
Loose lips may sink ships - Be smart - Don't post internal/commercially sensitive or confidential information!

sub

243 posts

Master Geek


  Reply # 119708 30-Mar-2008 17:00 Send private message

Thanks - I started off with 1.2.9. Just readding sources now as a sanity check (having issues picking those channels back up) but will give it up a go...
If you post the logs over at the GB-PVR forums, I'm happy to take a look.



Nate wants an iphone
3852 posts

Uber Geek
+1 received by user: 7

Mod Emeritus
Trusted
Subscriber

  Reply # 119713 30-Mar-2008 18:06 Send private message

I've done a full reinstall and made sure that monogram was selected. It appears to be working, despite the config looking the same.

I do get the odd time where I lose audio but changing channels appears to resolve it. I'm going to keep going and if I get any instances I'll post the logs.
Thanks sub for your pointers :)

Edit: mainly seems to be pausing, rewinding, fast forwarding.




webhosting |New Zealand connectionsgeekzone IRC chat
Loose lips may sink ships - Be smart - Don't post internal/commercially sensitive or confidential information!

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Has Spark (Telecom) locked their iphone 6 ?
Created by anewguy2014, last reply by michaelmurfy on 17-Dec-2014 14:32 (25 replies)
Pages... 2


forgot how to unlock a car door
Created by joker97, last reply by nathan on 19-Dec-2014 17:30 (45 replies)
Pages... 2 3


In defence of cats
Created by Rikkitic, last reply by DarthKermit on 17-Dec-2014 15:40 (68 replies)
Pages... 3 4 5


Slaughter of Innocents
Created by networkn, last reply by KiwiNZ on 19-Dec-2014 17:31 (62 replies)
Pages... 3 4 5


Lightbox launches on PlayStation 4
Created by freitasm, last reply by Bobdn on 19-Dec-2014 15:29 (38 replies)
Pages... 2 3


How is iParcel these days?
Created by peejayw, last reply by surfisup1000 on 18-Dec-2014 21:45 (19 replies)
Pages... 2


Spray Foam Insulation
Created by AACTech, last reply by timbosan on 19-Dec-2014 16:58 (36 replies)
Pages... 2 3


Google Chromecast now available in New Zealand
Created by freitasm, last reply by markl on 18-Dec-2014 15:36 (153 replies)
Pages... 9 10 11



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.