Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



25 posts

Geek
+1 received by user: 6

Subscriber

Topic # 111686 11-Nov-2012 21:35 Send private message

I powerup the beast, it shows the welcome screen.  Then after a few minutes it shows a blank screen.  It has been doing this more and more often.  Today, I can not get it to work.  I have powered up about 20 times.

Sometimes, moving the hdmi connector at the TV or the magicbox end makes it work.  Which is weird because the welcome screen is always shown.  So one cant blame the cable or connector.

Any ideas anyone ?

Create new topic
672 posts

Ultimate Geek
+1 received by user: 12


  Reply # 715756 12-Nov-2012 12:04 Send private message

Try plugging in with the supplied YPbPr and stereo cables instead and see what happens.



25 posts

Geek
+1 received by user: 6

Subscriber

  Reply # 715787 12-Nov-2012 12:58 Send private message

That was a great idea.  I couldnt access those sockets on the TV so I tried the composite video.  As I plugged it in, the HDMI came live.  Unfortunately, only for 3 seconds or so.

The composite video works fine though.  That leaves me with 3 options and a mystery


1.  Is it the cable ?
2.  Is it the TV socket ?
3.  Is it the magic socket ?

I had already tried it in a different hdmi socket on the TV so the TV is fine.

I will get another cable in the next day or so and see what the issue is.

Mystery, why does the welcome screen always work, if the cable or connectors are faulty ?

Just googled the hdmi pinout.  I am thinking that the hot-detect pin is faulty....

1500 posts

Uber Geek
+1 received by user: 52


  Reply # 715841 12-Nov-2012 13:43 Send private message

Bitfiddler:

Mystery, why does the welcome screen always work, if the cable or connectors are faulty ?


Maybe the Welcome screen is lower resolution and if the cable is at fault it can handle the low resolution but not when the higher resolution switches in?
Definitely worth trying another cable.

149 posts

Master Geek
+1 received by user: 1

Trusted
MagicTV

  Reply # 715893 12-Nov-2012 14:58 Send private message

Things to try:

1.

If your resolution is currently set to 1080p/50, change it to 1080i/50.

If your resolution is currently set to 1080i50, change it to 720p50.

You may just look at the Magic TV front panel to do this change if you're familiar with the settings menu enough. If not, use a composite video connection temporarily for this change.

2. Try a different HDMI cable.

3. Standby the Magic TV then power it off using the rear panel switch. Standby the TV, power it off then unplug the power cord from it and wait for several minutes. Turn them back on again.



25 posts

Geek
+1 received by user: 6

Subscriber

  Reply # 727248 5-Dec-2012 09:23 Send private message

It turned out to be the cable.  We must have damaged it when we threaded it through the conduit before the wall was built.

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Hierarchy of a mistake: Gerry Brownlee
Created by joker97, last reply by nathan on 26-Jul-2014 04:30 (68 replies)
Pages... 3 4 5


Geekzone giveaway: Thecus N2310 NAS
Created by freitasm, last reply by ottenpat on 25-Jul-2014 21:15 (89 replies)
Pages... 4 5 6


MH 17 "shot down" all dead
Created by joker97, last reply by ScuL on 24-Jul-2014 21:40 (203 replies)
Pages... 12 13 14


Is chorus going to deliberately slow adsl internet down
Created by rugrat, last reply by richms on 25-Jul-2014 20:35 (51 replies)
Pages... 2 3 4


Huge Fuss, didn't even make it a year.
Created by networkn, last reply by Glassboy on 22-Jul-2014 19:50 (121 replies)
Pages... 7 8 9


Skinny's new aggressive ad campaign
Created by Yabanize, last reply by Yabanize on 22-Jul-2014 23:35 (52 replies)
Pages... 2 3 4


Giving notice
Created by IlDuce, last reply by kharris on 24-Jul-2014 17:36 (15 replies)

Sickening floral smell in car, What next?
Created by TimA, last reply by eracode on 26-Jul-2014 02:44 (44 replies)
Pages... 2 3



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.