Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
Buying anything on Amazon? Please use the Geekzone Amazon aff link.




34 posts

Geek


Topic # 100182 4-Apr-2012 23:07 Send private message

I got my TiVo only 2 weeks ago (by signing the 12 month contract with Telecom) but a week after using it it crashed for the first time. When I turned my TV on it was just a black/grey screen. I managed to restart it and everything looked OK. But today it happened again and this time I was able to restart it but it crashed after 10 minutes and after that I wasn't able to do anything, it was just stuck on 'Welcome! Power up...' screen.
I called 0800 number and went through the process of unplugging cables restarting the unit but that worked only for 10 minutes and crashed again. They suggested to unplug all the cables and leave it for 6 hours to reset it to factory settings.
I don't think this will help. I am guessing it is a hard drive problem.
Anyone experienced the same problem? I hope they will just replace it for a new unit.

P.S. Sorry for my English, it's not my mother language.

Create new topic
2809 posts

Uber Geek
+1 received by user: 280

Moderator
Trusted
Subscriber

  Reply # 605392 4-Apr-2012 23:37 Send private message

Sounds like it needs replacing. Had the same problem when I got one for my parents. Thankfully no trouble with the three I have here though!

After the wait overnight, if it's still faulty ring them back. Hopefully they'll ship you a replacement without much of a hassle.

2809 posts

Uber Geek
+1 received by user: 280

Moderator
Trusted
Subscriber

  Reply # 605393 4-Apr-2012 23:39 Send private message

And welcome to Geekzone!

7484 posts

Uber Geek
+1 received by user: 420


  Reply # 605405 5-Apr-2012 00:08 Send private message

pegi: I got my TiVo only 2 weeks ago (by signing the 12 month contract with Telecom) but a week after using it it crashed for the first time. When I turned my TV on it was just a black/grey screen. I managed to restart it and everything looked OK. But today it happened again and this time I was able to restart it but it crashed after 10 minutes and after that I wasn't able to do anything, it was just stuck on 'Welcome! Power up...' screen.
I called 0800 number and went through the process of unplugging cables restarting the unit but that worked only for 10 minutes and crashed again. They suggested to unplug all the cables and leave it for 6 hours to reset it to factory settings.
I don't think this will help. I am guessing it is a hard drive problem.
Anyone experienced the same problem? I hope they will just replace it for a new unit.

P.S. Sorry for my English, it's not my mother language.


I had this exact problem. They will need to replace it.

18 posts

Geek


  Reply # 605787 5-Apr-2012 16:05 Send private message

I had pretty much the same problem - after mine worked fine for 5 weeks. Tried the factory reset thing they suggested and it worked ok for 2 days before the crash/restarts started again. After all that Hybrid in Australia said the unit needed to be replaced.

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

My un-consented UFB install
Created by thurthur, last reply by mdooher on 28-Nov-2014 11:54 (77 replies)
Pages... 4 5 6


Gigatown winner town and plans
Created by freitasm, last reply by Demeter on 28-Nov-2014 08:59 (76 replies)
Pages... 4 5 6


Click Monday Deals
Created by mrtoken, last reply by Krishant007 on 24-Nov-2014 17:11 (25 replies)
Pages... 2


This is the end ...
Created by joker97, last reply by tdgeek on 28-Nov-2014 10:20 (44 replies)
Pages... 2 3


Gull Employment Dispute.
Created by networkn, last reply by dickytim on 28-Nov-2014 12:40 (149 replies)
Pages... 8 9 10


Seen any good Black Friday / Cyber Monday deals?
Created by Jaxson, last reply by Jaxson on 28-Nov-2014 11:39 (18 replies)
Pages... 2


The Warehouse pulling R18 games and DVD's
Created by semigeek, last reply by Geektastic on 27-Nov-2014 18:32 (64 replies)
Pages... 3 4 5


Stuff.co.nz hacked by Syrian electronic army?
Created by surfisup1000, last reply by trig42 on 28-Nov-2014 12:22 (15 replies)


Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.