Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
Buying anything on Amazon? Please use the Geekzone Amazon aff link.




34 posts

Geek


Topic # 100182 4-Apr-2012 23:07 Send private message

I got my TiVo only 2 weeks ago (by signing the 12 month contract with Telecom) but a week after using it it crashed for the first time. When I turned my TV on it was just a black/grey screen. I managed to restart it and everything looked OK. But today it happened again and this time I was able to restart it but it crashed after 10 minutes and after that I wasn't able to do anything, it was just stuck on 'Welcome! Power up...' screen.
I called 0800 number and went through the process of unplugging cables restarting the unit but that worked only for 10 minutes and crashed again. They suggested to unplug all the cables and leave it for 6 hours to reset it to factory settings.
I don't think this will help. I am guessing it is a hard drive problem.
Anyone experienced the same problem? I hope they will just replace it for a new unit.

P.S. Sorry for my English, it's not my mother language.

Create new topic
2799 posts

Uber Geek
+1 received by user: 282

Moderator
Trusted
Subscriber

  Reply # 605392 4-Apr-2012 23:37 Send private message

Sounds like it needs replacing. Had the same problem when I got one for my parents. Thankfully no trouble with the three I have here though!

After the wait overnight, if it's still faulty ring them back. Hopefully they'll ship you a replacement without much of a hassle.

2799 posts

Uber Geek
+1 received by user: 282

Moderator
Trusted
Subscriber

  Reply # 605393 4-Apr-2012 23:39 Send private message

And welcome to Geekzone!

7594 posts

Uber Geek
+1 received by user: 433


  Reply # 605405 5-Apr-2012 00:08 Send private message

pegi: I got my TiVo only 2 weeks ago (by signing the 12 month contract with Telecom) but a week after using it it crashed for the first time. When I turned my TV on it was just a black/grey screen. I managed to restart it and everything looked OK. But today it happened again and this time I was able to restart it but it crashed after 10 minutes and after that I wasn't able to do anything, it was just stuck on 'Welcome! Power up...' screen.
I called 0800 number and went through the process of unplugging cables restarting the unit but that worked only for 10 minutes and crashed again. They suggested to unplug all the cables and leave it for 6 hours to reset it to factory settings.
I don't think this will help. I am guessing it is a hard drive problem.
Anyone experienced the same problem? I hope they will just replace it for a new unit.

P.S. Sorry for my English, it's not my mother language.


I had this exact problem. They will need to replace it.

18 posts

Geek


  Reply # 605787 5-Apr-2012 16:05 Send private message

I had pretty much the same problem - after mine worked fine for 5 weeks. Tried the factory reset thing they suggested and it worked ok for 2 days before the crash/restarts started again. After all that Hybrid in Australia said the unit needed to be replaced.

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Has Spark (Telecom) locked their iphone 6 ?
Created by anewguy2014, last reply by michaelmurfy on 17-Dec-2014 14:32 (25 replies)
Pages... 2


Police Camera Van Disguise
Created by Reanalyse, last reply by scuwp on 21-Dec-2014 12:16 (71 replies)
Pages... 3 4 5


Do I have the right to return this?
Created by corksta, last reply by alasta on 21-Dec-2014 12:59 (44 replies)
Pages... 2 3


In defence of cats
Created by Rikkitic, last reply by DarthKermit on 17-Dec-2014 15:40 (68 replies)
Pages... 3 4 5


Slaughter of Innocents
Created by networkn, last reply by networkn on 19-Dec-2014 17:46 (64 replies)
Pages... 3 4 5


Crew Drinking on Flights - Why!?
Created by networkn, last reply by gzt on 21-Dec-2014 13:38 (20 replies)
Pages... 2


Spray Foam Insulation
Created by AACTech, last reply by timbosan on 19-Dec-2014 16:58 (36 replies)
Pages... 2 3


How to upload 150GB of photos to iCloud?
Created by josephhinvest, last reply by timbosan on 17-Dec-2014 15:05 (35 replies)
Pages... 2 3



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.