Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



195 posts

Master Geek
+1 received by user: 2


Topic # 111636 9-Nov-2012 19:10 Send private message

I'm on 100/50 UFB and because i'm a business customer Orcon supplied me with a Cisco SRP521W-U.

My problem is I can't get it to route packets at anywhere near line speed.

If I direct-connect my laptop to the Chorus ONT and run DHCP on vlan 10 I get nice results (this is to prove its not my laptop at fault):


Now I connect my laptop to the SRP521 and allow it do NAT like most residential/small-business deployments are:

And we're down to under half the theoretical maximum!

Now, let's disable firewall/NAT and set it up to route my static IP range orcon have provided me (this should speed things up as the cisco barely has to look at the packet, just routing it, not keeping track of any NAT connections):

No real change!


So can anyone else who uses this Cisco SRP521W-U router tell me what sort of speeds they can achieve?
I believe this router may actually be provided by Chorus to ISPs as part of the install so it should be reasonably common.

I've upgraded the firmware to latest version, no change.
I've factory reset settings from what the ISP put in, and put back in the settings i need, no change (to be clear it was like this on the ISPs config too).

Any thoughts? Maybe this router just can't route at 100mbps?

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
BDFL
49532 posts

Uber Geek
+1 received by user: 4377

Administrator
Trusted
Geekzone
Subscriber

  Reply # 714882 9-Nov-2012 19:30 Send private message

I have Cisco SRP521W plugged to my TelstraClear cable connection. Even though I read about others getting 100 Mbps and sometimes over, my Cisco SRP never managed to go past 90 Mbps.

Still, almost double what you're getting with yours. They're different models, but who knows?

Mine is V01, Hardware version 3.0.0, running firmware 1.01.27 (007) Jun 15 2012.






195 posts

Master Geek
+1 received by user: 2


  Reply # 714884 9-Nov-2012 19:47 Send private message

My full model name (PID) is SRP521W-U-E-K9 V01

364 posts

Ultimate Geek
+1 received by user: 8

Trusted
Subscriber

  Reply # 714968 9-Nov-2012 22:31 Send private message

My (Vodafone supplied) SRP521W was able to get 92mb/s downstream and 42/mb/s upstream on UFB. That was with Vodafone.




121 posts

Master Geek


  Reply # 714988 9-Nov-2012 23:31 Send private message

What is the mtu set at? My friend has a Cisco/Linksys E4000 on 100mbit TCL cable and with the default mtu he was getting around 40mbit, but when he toned the mtu down he was able to get 80-90mbit if I remember correctly. Give that a shot and see if it helps? I think he set it to to 1492.



19418 posts

Uber Geek
+1 received by user: 1263

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 715016 10-Nov-2012 07:29 Send private message

I too have deployed a lot of SRP521W's and never come across a performance issue with them.

The issue is no doubt related to the terrible Orcon UFB performance that many other people are also experiencing.

19418 posts

Uber Geek
+1 received by user: 1263

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 715017 10-Nov-2012 07:30 Send private message

Decal: What is the mtu set at? My friend has a Cisco/Linksys E4000 on 100mbit TCL cable and with the default mtu he was getting around 40mbit, but when he toned the mtu down he was able to get 80-90mbit if I remember correctly. Give that a shot and see if it helps? I think he set it to to 1492.




MTU isn't something you touch. You set the correct MTU setting for the connection type and leave it. Setting it to something incorrect will cause all sorts of issues, and does a great job of breaking SSL connections.

For the record MTU should always be set to 1500 on TCL cable since it's a standard 1500 byte Ethernet connection.


2591 posts

Uber Geek
+1 received by user: 363


  Reply # 718069 16-Nov-2012 08:47 Send private message

I appreciate this is diverting somewhat OT, however, suspect it is related and relatively quick to answer - If not, I'll start a new topic.

How do you set the VLAN 10 tag on the SRP521?

19418 posts

Uber Geek
+1 received by user: 1263

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 718078 16-Nov-2012 08:54 Send private message

RunningMan: I appreciate this is diverting somewhat OT, however, suspect it is related and relatively quick to answer - If not, I'll start a new topic.

How do you set the VLAN 10 tag on the SRP521?


The VLAN ID field in the WAN settings.

2591 posts

Uber Geek
+1 received by user: 363


  Reply # 718097 16-Nov-2012 09:11 Send private message

sbiddle:

The VLAN ID field in the WAN settings.


Thank you!

3 posts

Wannabe Geek


  Reply # 725570 1-Dec-2012 18:33 Send private message

Hey guys

Sorry to bring up a dead thread. I have the Cisco SRP521W and am experiencing slow throughput also. It running the latest firmware from Cisco.

Setup in DHCP Vlan 10 and it was working fine. Getting 90mbps down reliably and am now only getting 30-40 mbps.

Was there ever an outcome to this? I am running a business from home and require the speeds.. Luckily for myself I have family that works for Cisco and am able to get gear that wouldnt usually be available unless you knew what you were asking for.

However I have had to revert back to the rebranded iinet router in the mean time untill i find a proper solution for this.

Please help!

19418 posts

Uber Geek
+1 received by user: 1263

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 725584 1-Dec-2012 19:22 Send private message

So swapping routers fixed it? There have been a lot of posts on here from people ciomplaining about speed issues on UFB with Orcon.

I have never seen a speed issue with the SRP521W.


3 posts

Wannabe Geek


Reply # 725586 1-Dec-2012 19:30 Send private message

The orcon router had a firmware upgrade which they said they would not support me unless im using there hardware. Which means they dont want to know me if im using something else... Im still looking for a solution to the Cisco.. any ideas at all?

19418 posts

Uber Geek
+1 received by user: 1263

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 725642 2-Dec-2012 07:49 Send private message

I don't have ans solutions because I've deployed a lot of these and never had a single issue. They're more than capable of ~80Mbps which suggests something wrong with your setup.

Have you confirmed things listed above such as MTU are correct? I also assume you're testing via Ethernet and not relying on wireless for a speedtest?




192 posts

Master Geek


  Reply # 725661 2-Dec-2012 08:58 Send private message

I have had some issues with my UFB connection running off a SRP521W.  I haven't had a chance yet to check whether it is on the ISP side or as a result of my SRP521W (I'm on Vodafone's UFB trial so they may be doing some tweaking).  

BDFL
49532 posts

Uber Geek
+1 received by user: 4377

Administrator
Trusted
Geekzone
Subscriber

  Reply # 725662 2-Dec-2012 09:00 Send private message

i am on the happy campers' side. My SRP 521W has been running for years, and never had slowdowns. It won't reach 100 Mbps but on a good day it's not below 85 - 90 Mbps (on TelstraClear cable).




 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Does NZ need better gun laws?
Created by mattwnz, last reply by hangon on 3-Sep-2014 17:54 (165 replies)
Pages... 9 10 11


Warning: Rage Ahead - Campbell Live and childhood poverty
Created by kawaii, last reply by gzt on 3-Sep-2014 19:23 (157 replies)
Pages... 9 10 11


What tyre brand/model to look at ?
Created by Mark, last reply by Oblivian on 2-Sep-2014 21:36 (35 replies)
Pages... 2 3


Judith Collins: I am resigning
Created by Presso, last reply by gzt on 2-Sep-2014 11:42 (109 replies)
Pages... 6 7 8


VideoEZY OnDemand
Created by Andib, last reply by sen8or on 3-Sep-2014 07:45 (64 replies)
Pages... 3 4 5


Cirque du Soleil Cellphone Hijack
Created by myopinion, last reply by PhantomNVD on 1-Sep-2014 18:01 (21 replies)
Pages... 2


Paying cash at retailers
Created by nate, last reply by LostBoyNZ on 3-Sep-2014 19:29 (18 replies)
Pages... 2


Orcon Global Mode launched
Created by freitasm, last reply by shk292 on 1-Sep-2014 11:32 (132 replies)
Pages... 7 8 9



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.