Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



31 posts

Geek
+1 received by user: 1


Topic # 108800 5-Sep-2012 18:47 Send private message

Hi there, and sorry if the following ia big wall of text;

I noticed my internet speed took a major dive in performance and did my own research plus logged a ticket with Telecom.  Im very close to an exchange and connect at 19Mbit on average, and performance is always been very good, a solid 1.7MB/s transfer speed.  Last month I did something like 13GB, ie, fairly light user.

Then I noticed online gaming started to lag and download speed was erractic.  Heres an interesting screen shot of my networking tab under Task Manager showing network performance during YouTube streaming speed test.




Assuming I got that image to display, you'll see almost a perfect square wave, it goes at 1.6MB/s for 20 seconds then 20KB/s for 10 seconds and so on.  Does this 24/7 regardless of the time so its not on-peak throttling.

Note during testing this is the only PC connected to the router via utp, no wireless, and tried different routers in case its internal switch was failing or something odd like that.

The Xtra helpdesk was polite and escalated the ticket to network systems who simply closed the ticket as it "working to specification". 

The gaming lag appears to come from lost packets as it hits the hard speed cut as if I leave tracerts running in a loop I can see them time out (usually where ae1-2.akbr4.global-gateway.net.nz should be).

So, does anyone else have this problem and has Telecom suddenly inforced stupid speed restrictions?  Should I open more tickets till I get something better than a "to spec" reply even thou WHAT spec is never mentioned.

Btw, downloads dont look as pretty as that square wave as they're not hitting Xtras local cache so are much slower to rise, so average performance is about half that again.  But it shows nicely whats happening....


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3 | 4


31 posts

Geek
+1 received by user: 1


  Reply # 681965 5-Sep-2012 18:55 Send private message

Just thought I'd ad a Speedtest.net screen cap while Im at it.

As you can see, always the same pattern on downloading.


7748 posts

Uber Geek
+1 received by user: 316

Trusted
Subscriber

  Reply # 682185 6-Sep-2012 10:27 Send private message

Do you get that throughput pattern when running a speedtest at
http://speedtest.telecom.co.nz/



31 posts

Geek
+1 received by user: 1


  Reply # 682235 6-Sep-2012 12:14 Send private message

I believe so, but will double check when I get home.

1912 posts

Uber Geek
+1 received by user: 456

Trusted
Spark NZ

  Reply # 682242 6-Sep-2012 12:26 Send private message

Telecom does not do any shaping (unless you exceed your monthly cap and get shaped to something approximating dialup speed - that's a WHOLE 'nother topic)

The illustration of the youtube download is very very likely to be Google themselves pacing the download (which at those speeds will be coming from a local Google Cache). Youtube usually only preloads a given amount of the file, so this stop/start behaviour is commonly seen - although not all the time. I think it depends on bitrate of the file, size of the file and perhaps even your burst download speed.

As above, try the Telecom NZ speedtest and do NOT pay any attention to high latency figures in tracerts - they are more often misleading than helpful.

Cheers - N



31 posts

Geek
+1 received by user: 1


  Reply # 682255 6-Sep-2012 12:37 Send private message

That screen cap from YouTube Speed test (ie, I expect in Xtras local cache anyways) was an example only, to capture the screen shot.  I can replicate that screen shot downloading from any file server you care to mention (but then its a sawtooth type pattern as its slow to rise, unless I hammer it with 10+ threads per file then it looks identical to the above YouTube capture).

I will post the results from the Telecom speed test tonight, but as I did that with Xtras helpdesk Im certain it was identical.

-Duane

1912 posts

Uber Geek
+1 received by user: 456

Trusted
Spark NZ

  Reply # 682266 6-Sep-2012 12:47 Send private message

OK, fair enough... Does your latency jump around much if you are not downloading? (ie. ping 8.8.8.8 gives me this)

Pinging 8.8.8.8 with 32 bytes of data:
Reply from 8.8.8.8: bytes=32 time=53ms TTL=54
Reply from 8.8.8.8: bytes=32 time=53ms TTL=54
Reply from 8.8.8.8: bytes=32 time=54ms TTL=54
Reply from 8.8.8.8: bytes=32 time=53ms TTL=54
Reply from 8.8.8.8: bytes=32 time=54ms TTL=54
Reply from 8.8.8.8: bytes=32 time=55ms TTL=54
Reply from 8.8.8.8: bytes=32 time=54ms TTL=54

Telecom definitely have not put in any traffic shaping that would do this, so it won't be that.

Good to see you tested using a wired connection and great to see you tried a different router. Do you have a second PC you could use to test as well? A friend's laptop perhaps?

Grab something like Netmeter

http://www.metal-machine.de/readerror/index.php?action=tpmod;dl=cat1

and try some more tests, along with something like a legit download of a linux ISO via bittorrent. I'm interested to know if something using a heap of threads has the same apparent issue.

Cheers - N



31 posts

Geek
+1 received by user: 1


  Reply # 682290 6-Sep-2012 12:58 Send private message

I was editing my post when you replied (see changes regarding download servers), but yes, I use DownThemAll via Firefox and typically have it set to the defaults which I think is 3 or 4 threads, at the moment Im being server-unfriendly for testing and its set to 10 threads total, 6 per file.

I like to use Revision3 (online media shows) and download several videos at once, so prior to this issue off peak it can hit and sustain 2.1MB/s  and on peak roughly the 1.7MB/s as mentioned in the 1st post (multi-threads set to defaults).

When I was running the ping and tracerts, except the ones that go missing, they are constant and pretty good.



31 posts

Geek
+1 received by user: 1


  Reply # 682326 6-Sep-2012 13:38 Send private message

Forgot to say I've tried other PCs and get the same pattern.  I will download that file when I get home.

Thanks,
-Duane



31 posts

Geek
+1 received by user: 1


  Reply # 682494 6-Sep-2012 17:54 Send private message

Just to confirm; three threads on this file;

http://videos.revision3.com/revision3/web/tekzilla/0354/tekzilla--0354--first-hdtv-spec--hd720p30.h264.mp4

Gave;




Telecom speed test finishes in about 4~5 seconds so difficult to show anything, its the blips to the right handside;


1912 posts

Uber Geek
+1 received by user: 456

Trusted
Spark NZ

  Reply # 682532 6-Sep-2012 19:56 Send private message

Duane: [snip]


Very interesting. Are you able to try a multithreaded DL of of local file (something decent sized from microsoft - so delivered by Akamai)... If it wasn't for the flat bits between the peaks then this can be explained by TCP, but those flat bits do look suspicious.

A local download will remove another element from the equation.

Also if possible, a bittorrent download would be useful to see - a much larger number of slower threads might shed more light.

Cheers - N




31 posts

Geek
+1 received by user: 1


  Reply # 682573 6-Sep-2012 22:02 Send private message

The microsoft download was Win7 SP1 at 0.8GB (http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe)

Gives a familia picture, but the lower speed troughs are 200KB/s and the highs are 2.1MB/s. 



I will move to another PC which has a torrent client installed and grab a linux distro or similar and see if theres any change.

Thanks
-Duane


1459 posts

Uber Geek
+1 received by user: 93

Trusted
Subscriber

  Reply # 682576 6-Sep-2012 22:06 Send private message

This isn't anything to do with the saw-tooth effect of TCP as outlined here perchance?

http://www.geekzone.co.nz/forums.asp?forumid=49&topicid=87219#496857 (the reply and whitepaper link specifically, but the OP in that seems to experience similar symptoms on Snap)



31 posts

Geek
+1 received by user: 1


  Reply # 682591 6-Sep-2012 22:59 Send private message

NickB800 - Thanks for the link, interesting read.

Talkiet - Torrents do indeed give a different picture.  Downloaded Ubuntu with 70 peers and got;



The 20s bursts are still faster but not nearly as pronounced as 'regular' downloading.




31 posts

Geek
+1 received by user: 1


  Reply # 682891 7-Sep-2012 17:45 Send private message

Win7 Sp1 single threaded;



Btw, the saw tooth (tcp ramp up?) on the far left is browsing this forum to use the same link.

Just A Geek
1947 posts

Uber Geek
+1 received by user: 313

Trusted
Subscriber

  Reply # 682927 7-Sep-2012 20:15 Send private message

Maybe its something to do with the router mis behaving.. have you tried a different router?

 1 | 2 | 3 | 4
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Speed limit when overtaking? Teach me please.
Created by nakedmolerat, last reply by Hobchild on 26-Oct-2014 00:11 (92 replies)
Pages... 5 6 7


Snap refuses to replace faulty gear
Created by Brendan, last reply by Brendan on 26-Oct-2014 15:47 (21 replies)
Pages... 2


House Auctions
Created by t0ny, last reply by joker97 on 26-Oct-2014 15:33 (53 replies)
Pages... 2 3 4


VDSL, which router/modem sub $200?
Created by TeaLeaf, last reply by NonprayingMantis on 25-Oct-2014 19:48 (28 replies)
Pages... 2


Neon - Sky's new streaming service
Created by JarrodM, last reply by JimmyH on 25-Oct-2014 17:37 (29 replies)
Pages... 2


5Ghz AP recommendations?
Created by ubergeeknz, last reply by sbiddle on 24-Oct-2014 12:42 (12 replies)

Snap have failed our company!
Created by dafman, last reply by kornflake on 23-Oct-2014 17:41 (37 replies)
Pages... 2 3


Thief taunts 12 year old via stolen laptop
Created by macuser, last reply by charsleysa on 22-Oct-2014 23:49 (12 replies)


Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.