Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



1679 posts

Uber Geek
+1 received by user: 223

Subscriber

Topic # 107679 16-Aug-2012 19:44 Send private message

I ported my number about 2 weeks ago from 2Talk to VFX. Got nothing bad to say about 2Talk just wanted to give VFX a go.
Anyway, porting went through sweet as and the Xnet guys are so so so good to deal with. Was really impressed with the whole process.
Chucked in the registration details in to Asterisk and assumed all is good. In my stupidity though I forgot to change the outbound route to pick the VFX trunk instead of the 2Talk trunk which still had an 028 number attached so I could make calls out no problem. The problem arose when Mum tried ringing me lol. she couldn't get through. I looked at Asterisk and realised what I had done. So have deleted the entire 2Talk trunk out of there. However, now I am just having no joy with the VFX trunk.
Below is what I have put in to the trunk settings. They are pretty much as supplied by Xnet but I must be missing something...

Trunk name: VFX

type=peer
fromuser=63564340
host=pan.wxnz.net
insecure=invite,port
canreinvite=no
nat=yes
secret=*****
username=******
context=from-trunk

User context: **username**

Reg string: as supplied

Any thoughts as to what I might be doing?

Create new topic
18554 posts

Uber Geek
+1 received by user: 731

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 673496 16-Aug-2012 21:35 Send private message

The registration string is important but since you haven't listed it we don't know if you're using the correct details.

Do you have an inbound route set? Is the call hitting your PBX or are you hearing Neil Waka?



1679 posts

Uber Geek
+1 received by user: 223

Subscriber

  Reply # 673508 16-Aug-2012 22:05 Send private message

So the registration string is:
63564340:secret:[email protected]/63564340

I have an inbound route for 063564340 set to go to my front end IVR. When I ring from a cell phone the call just drops and I don't see anything show in the asterisk debug logs. Actually as a side note, this is what I see in the log from the registration..

[2012-08-16 21:53:05] NOTICE[2647] chan_sip.c: -- Registration for '[email protected]' timed out, trying again (Attempt #261)
[2012-08-16 21:53:25] WARNING[2647] chan_sip.c: Maximum retries exceeded on transmission [email protected] for seqno 363 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions

Just checked on my firewall too and nothing is getting blocked as far as I can see. Added a pass rule just for good luck for 58.28.20.150. There is also no port forwarding for in place for 5060.

2861 posts

Uber Geek
+1 received by user: 131

Trusted
Subscriber

  Reply # 673544 17-Aug-2012 01:05 Send private message

chevrolux: So the registration string is:
63564340:secret:[email protected]/63564340

I have an inbound route for 063564340 set to go to my front end IVR. When I ring from a cell phone the call just drops and I don't see anything show in the asterisk debug logs. Actually as a side note, this is what I see in the log from the registration..

[2012-08-16 21:53:05] NOTICE[2647] chan_sip.c: -- Registration for '[email protected]' timed out, trying again (Attempt #261)
[2012-08-16 21:53:25] WARNING[2647] chan_sip.c: Maximum retries exceeded on transmission [email protected] for seqno 363 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions

Just checked on my firewall too and nothing is getting blocked as far as I can see. Added a pass rule just for good luck for 58.28.20.150. There is also no port forwarding for in place for 5060.


Your issue is probably with the CID not being picked up. I believe you need to edit the SIP file slightly for asterisk to get correct CID from VFX. Try an any/any CID/DID rule (f you are using FreePBX) and it should work.





18554 posts

Uber Geek
+1 received by user: 731

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 673552 17-Aug-2012 06:52 Send private message

chevrolux: So the registration string is:
63564340:secret:[email protected]/63564340

I have an inbound route for 063564340 set to go to my front end IVR. When I ring from a cell phone the call just drops and I don't see anything show in the asterisk debug logs. Actually as a side note, this is what I see in the log from the registration..

[2012-08-16 21:53:05] NOTICE[2647] chan_sip.c: -- Registration for '[email protected]' timed out, trying again (Attempt #261)
[2012-08-16 21:53:25] WARNING[2647] chan_sip.c: Maximum retries exceeded on transmission [email protected] for seqno 363 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions

Just checked on my firewall too and nothing is getting blocked as far as I can see. Added a pass rule just for good luck for 58.28.20.150. There is also no port forwarding for in place for 5060.


By the looks of that your box isn't even registering, what does a show peers tell you?

You also have your DID wrong for the incoming route.



1679 posts

Uber Geek
+1 received by user: 223

Subscriber

  Reply # 673618 17-Aug-2012 10:23 Send private message

show peers gives me:
VFX/username 58.28.20.150 N 5060 Unmonitored

Do I need to add register=*something* in to the trunk settings to make it register?

Does the DID from VFX not have the leading zero or something like that?

EDIT:
Just added register=*string* in to the trunk settings and I can make calls!! Originally the only place I had the register string was in the dedicated field of FreePBX.

Create new topic








Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when new jobs are posted to our jobs board:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Forms of government for New Zealand
Created by charsleysa, last reply by sir1963 on 21-Apr-2014 20:57 (127 replies)
Pages... 7 8 9


Whats the best wife friendly media centre?
Created by amorpeth, last reply by jonolynn on 19-Apr-2014 20:20 (14 replies)

Snap suffering Trans-Tasman congestion 18/04?
Created by Lias, last reply by NonprayingMantis on 19-Apr-2014 00:05 (26 replies)
Pages... 2


galaxy s4 now on 4.4.2
Created by nzrock, last reply by jeffnz on 21-Apr-2014 12:52 (62 replies)
Pages... 3 4 5


TVNZ on Demand Jailbreak Detection
Created by TranceManNZ, last reply by hio77 on 18-Apr-2014 20:25 (12 replies)

Is it legal to rip your own DVD in New Zealand?
Created by PSlover14, last reply by Geektastic on 18-Apr-2014 11:40 (25 replies)
Pages... 2


'Third world' internet shocks residents
Created by michaelmurfy, last reply by pchs on 17-Apr-2014 22:39 (85 replies)
Pages... 4 5 6


Naked Broadband, who's made the switch.
Created by Presso, last reply by Aredwood on 21-Apr-2014 17:08 (33 replies)
Pages... 2 3



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.