Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



6 posts

Wannabe Geek


Topic # 94939 22-Dec-2011 13:23 Send private message

Hello everyone,

I'd be indebted if someone could solve this mystery for me:

Just switched to Open VFX as the Linksys SPA2102 I was using expired.  No problem, a good opportunity to update my aging DSL router at the same time I think.

Installation goes OK, phone is registered and can make calls out but inbound calls just get a disconnected signal.

Checked with the helpful suppliers of the Draytek and another experienced VoIP engineer who has set up Drayteks with VFX before - both think that the settings should be fine.

Tried setting up with a 2talk account which works inbound and outbound.

Tried a replacement unit this morning, same problem.
Log file from outside shows 404 when trying to connect. (see below).

Has anyone out there got one of these boxes working with Open VFX?

All help or suggestions appreciated!

[8] 2011/12/21 14:37:46:   Call from an user 805[8] 2011/12/21 14:37:46:   To is <sip:[email protected];user=phone>, user 0, domain 1[8] 2011/12/21 14:37:46:   From user 805[8] 2011/12/21 14:37:46:   Set the To domain based on From user [email protected][8] 2011/12/21 14:37:46:   Call state for call object 3462: idle[5] 2011/12/21 14:37:46:   Dialplan "Dialplan": Match [email protected] to <sip:[email protected];user=phone> on trunk 2talk Trunk[8] 2011/12/21 14:37:46:   Play audio_moh/noise.wav[7] 2011/12/21 14:37:46:   set_codecs: for 3c5b79f48f01-n8jstih1f3d9 codecs "", codec_preference count 6[7] 2011/12/21 14:37:46:   set_codecs: for 658f8e27@pbx codecs "8 0", codec_preference count 3[8] 2011/12/21 14:37:46:   call port 177: state code from 0 to 100[8] 2011/12/21 14:37:46:   call port 176: state code from 0 to 183[7] 2011/12/21 14:37:46:   Set packet length to 20[6] 2011/12/21 14:37:46:   Codec pcmu/8000 is chosen for call id 3c5b79f48f01-n8jstih1f3d9[7] 2011/12/21 14:37:46:   Set packet length to 20[6] 2011/12/21 14:37:46:   Codec pcma/8000 is chosen for call id 658f8e27@pbx[6] 2011/12/21 14:37:46:   Sending RTP for 658f8e27@pbx to 202.180.76.164:38068, codec pcma/8000[8] 2011/12/21 14:37:46:   Call state for call object 3462: alerting[8] 2011/12/21 14:37:46:   call port 176: state code from 183 to 183[8] 2011/12/21 14:37:46:   Last message repeated 2 times[7] 2011/12/21 14:37:46:   3c5b79f48f01-n8jstih1f3d9: RTP pass-through mode[7] 2011/12/21 14:37:46:   658f8e27@pbx: RTP pass-through mode[6] 2011/12/21 14:37:46:   Different Codecs (local pcmu/8000, remote pcma/8000), callid 3c5b79f48f01-n8jstih1f3d9, falling back to transcoding[7] 2011/12/21 14:37:48:   Call 658f8e27@pbx: Clear last INVITE[5] 2011/12/21 14:37:48:   INVITE Response 404 Not Found: Terminate 658f8e27@pbx[7] 2011/12/21 14:37:48:   3c5b79f48f01-n8jstih1f3d9: Media-aware pass-through mode[8] 2011/12/21 14:37:48:   call port 176: state code from 183 to 404[8] 2011/12/21 14:37:48:   Hangup: Call 177 not found

Create new topic
3558 posts

Uber Geek
+1 received by user: 60

Trusted
WorldxChange

  Reply # 560699 22-Dec-2011 13:42 Send private message

pm your name and details to me I will take a look.....




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications

3558 posts

Uber Geek
+1 received by user: 60

Trusted
WorldxChange

  Reply # 560775 22-Dec-2011 18:19 Send private message

Okay... see the problem you have both numbers setup to use port 8060 , change the port to 5060 for line 1 and 5061 for line 2, by having both numbers registered against the same port when a call tries to go back it dosn't know which one one to process as the draytek has them both on 8060




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications



6 posts

Wannabe Geek


  Reply # 560807 22-Dec-2011 20:31 Send private message

Thanks, was trying 8060 at someone elses suggestion.
Have set back to 5060 and 5061 as per your advice, however still no joy.  Also Phone 2 no longer registers when on 5061..


Thanks again for your time
D    

3558 posts

Uber Geek
+1 received by user: 60

Trusted
WorldxChange

  Reply # 560858 23-Dec-2011 06:14 Send private message


The first line xxxx936 is looking fine , dialing this number produces ring tone from the Draytek,

Direction : RX
Remote IP/Port: 118.xxx.xxx.192/5060
Local IP/Port : 58.xxx.xxx.xxx/5060
Transport : UDP
----------------------------------------
SIP/2.0 180 Ringing
Via: SIP/2.0/UDP 58.xxx.xxx.xxx:5060;branch=z9hG4bK-218c20-4ef3636f-66f8967f-606a2f70
From: ;tag=96141c3a-13c4-4ef3636f-66f8967f-67d82db3
To: "xxxxx Vihi" ;tag=tJT-6828
Call-ID: [email protected]
CSeq: 1 INVITE
Contact:
Content-Length: 0

The second line however is not even trying to register at all at this time and stopped at 20:25 last night which I'm guessing is when you made the change ?




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications



6 posts

Wannabe Geek


  Reply # 560880 23-Dec-2011 08:58 Send private message

Weird, it wasn't working after changing the ports back last night - a Christmas miracle?
The 2nd line fails to register after changing to 5061, however it would register on 5060 or 8060. 

3558 posts

Uber Geek
+1 received by user: 60

Trusted
WorldxChange

  Reply # 560881 23-Dec-2011 09:00 Send private message

You could change the second line to 8060 and see what happens ..




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications



6 posts

Wannabe Geek


  Reply # 560887 23-Dec-2011 09:39 Send private message

That was my thought too - and problem is resolved!
Will post configuration shortly for anyone else who might run into trouble with these devices.

Thanks again for taking the time to help - I'm still not sure what solved the problem (initially I tested the device with only one account set up on 5060 and it wasn't working then) but I'm just relieved that communication has been restored Smile

D

3558 posts

Uber Geek
+1 received by user: 60

Trusted
WorldxChange

  Reply # 560896 23-Dec-2011 09:49 Send private message

yes see that is registered, pretty strange to see it not even try to register on port 5061... That should be pretty standard




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications

3558 posts

Uber Geek
+1 received by user: 60

Trusted
WorldxChange

  Reply # 560924 23-Dec-2011 10:50 Send private message

I would also change your codecs, you are presenting codecs that are not supported and the low bandwidth codec as first choice G729, change this to G711a for a better Voice quality.

m=audio 21916 RTP/AVP 18 9 96 97 2 4 8 0
a=rtpmap:18 g729/8000 --- this is current preferred codec, is a lower quality
a=rtpmap:9 g722/8000
a=rtpmap:96 iLBC/8000 ----- remove
a=rtpmap:97 iLBC/8000 ------ remove
a=rtpmap:2 g726-32/8000 -------- remove
a=rtpmap:4 g723/8000 ----------- remove
a=rtpmap:8 pcma/8000 ----- Make first choice
a=rtpmap:0 pcmu/8000 ------ Make second choice




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications



6 posts

Wannabe Geek


  Reply # 561013 23-Dec-2011 16:29 Send private message

Thanks again for your help, Maverick

Here is the current working config for anyone who is interested.
Subject to change and refinement of course!






















6 posts

Wannabe Geek


  Reply # 561015 23-Dec-2011 16:31 Send private message

































Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Speed limit when overtaking? Teach me please.
Created by nakedmolerat, last reply by joker97 on 25-Oct-2014 09:00 (75 replies)
Pages... 3 4 5


House Auctions
Created by t0ny, last reply by mattwnz on 25-Oct-2014 00:18 (36 replies)
Pages... 2 3


VDSL, which router/modem sub $200?
Created by TeaLeaf, last reply by TeaLeaf on 24-Oct-2014 23:26 (16 replies)
Pages... 2


30 too old to get into IT?
Created by Interslice, last reply by shk292 on 24-Oct-2014 20:39 (16 replies)
Pages... 2


American legal jurisdiction in New Zealand
Created by ajobbins, last reply by gzt on 21-Oct-2014 14:58 (30 replies)
Pages... 2


Neon - Sky's new streaming service
Created by JarrodM, last reply by kharris on 25-Oct-2014 09:50 (24 replies)
Pages... 2


iPad Air 2 and iPad Mini 3. Gonna get one?
Created by Dingbatt, last reply by tdgeek on 25-Oct-2014 01:10 (109 replies)
Pages... 6 7 8


5Ghz AP recommendations?
Created by ubergeeknz, last reply by sbiddle on 24-Oct-2014 12:42 (12 replies)


Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.