Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



919 posts

Ultimate Geek
+1 received by user: 30


Topic # 105977 15-Jul-2012 19:00 Send private message

Folks,

   I recently acquired a TP-Link portable wifi router, model WR703N.

After connecting to a laptop and using IP address 168.192.1.1 I was presented with the user interface in Chinese, which was no problem because web sites say this unit can be flashed with DD-WRT.

Downloaded the appropriate DD-WRT .bin file and located the interface page to carry out the re-flash .... which appeared to proceed correctly.

However, now I cannot access the router ... tried several IP addressess using a browser and Telnet.

DD-WRT is supposed to have a GUI, so any assistance gaining access would be appreciated.

Thanks,

R. 

Create new topic
BDFL
51250 posts

Uber Geek
+1 received by user: 5424

Administrator
Trusted
Geekzone
Subscriber

  Reply # 656207 15-Jul-2012 21:25 Send private message

If you run "IPCONFIG" you can see what is the default gateway IP address...





Dangerous Chocolate
103 posts

Master Geek
+1 received by user: 18

Subscriber

  Reply # 656209 15-Jul-2012 21:29 Send private message

Bother, hate it when that happens. Everything I have read indicates that the IP should be 192.168.1.1.

Are you receiving anything from DHCP, or entering the computer's IP address manually. 

This may help: http://www.dd-wrt.com/wiki/index.php/Obtaining_Router_IP

In fact the whole article http://www.dd-wrt.com/wiki/index.php/Installation has good tips if things go wrong

Good luck

65 posts

Master Geek
+1 received by user: 3


  Reply # 656211 15-Jul-2012 21:35 Send private message

Before installing DD-WRT, you say the IP address was 186.192.1.1 did you mean 192.168.1.1??
I understand DD-WRT uses 192.168.1.1 as a default. 

You need to make sure the PC trying to connect to the router is on the same subnet as the router.




919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 656212 15-Jul-2012 21:39 Send private message

Guys,

Thanks for replies, and I've been scanning the WRT site as well.

So far -

As I said, flashing seemed to go fine, the unit reboots correctly and displays function light.

I used a laptop not connected to my network, so no DHCP to interefere, and made the computer 192.168.1.2 to avoid conflict.

Default IP of router is stilli192.168.1.1, and I can PING it no problem at all.

IPCONFIG confirms router/unit address

This unit is listed as being compatible ... checked that before flashing.

Tried the 30/30/30 hard reset process


Any further ideas or siggestions most welcome,

R.



919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 656219 15-Jul-2012 21:50 Send private message

Sorry about the typos .... yes, correct IP for the unit is 192.168.1.1, and yes, subnet is 255.255.255.0

OK, I've just noticed that I have made a blunder by using the incorrect flash file from WRT !! BUGGER !!!

Any clues how to re-flash with correct file?

R.



919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 656224 15-Jul-2012 22:13 Send private message

Ding! Ding! Round two.

I can access the router via Telnet and in WRT's 'Failsafe Mode" ... so far so good.

I'm not a Linux user so not sure of the command line I should use to install the correct flash file, so any help in that regard would be appreciated.

R.

mjb

922 posts

Ultimate Geek
+1 received by user: 21

Trusted

  Reply # 656225 15-Jul-2012 22:13 Send private message

I suspect you'll need to use the device's bootloader and tftp to get the original firmware back onboard, then try again.

Take a look at http://wiki.openwrt.org/toh/tp-link/tl-wr703n#back.to.original.image




contentsofsignaturemaysettleduringshipping



919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 656234 15-Jul-2012 22:45 Send private message

Sadly, none of that makes any sense to me.

The WRT site does offer the following - "For systems without a web interface, you can flash a sysupgrade file with mtd (after downloading the file to /tmp and then "cd /tmp"):", and then gives the Command Line.

Looks good, BUT how do I get the upgrade/flash file into the router's tmp directory?

R.




919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 656418 16-Jul-2012 12:40 Send private message

C'mon all you Linux gurus ... how does this helpless Windows guy copy a file from my computer to the router? Laughing

I can access the router via Telnet, and the tmp directory where the file (on a USB drive) needs to go.

Cheers,

R.

64 posts

Master Geek
+1 received by user: 11


  Reply # 656656 16-Jul-2012 20:38 Send private message

Try using WinSCP
http://winscp.net/eng/download.php

Just not sure if it will connect while router is in Failsafe mode.

[EDIT] Fix url




919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 656751 16-Jul-2012 22:41 Send private message

I'll give WinSCP a go ... thanks for the pointer.

R.



919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 657474 18-Jul-2012 10:42 Send private message

David,

   WinSCP did the trick and I can access the router's internal files and directories now.

Next trick is to gain extra storage/RAM via an external flash drive and get the GUI working .... sheesh, to us DOS/Windows users it would be easier to learn Klingon than Linux Undecided

Any Linux people out there that can help with this "bootloader" thingy?

R.



919 posts

Ultimate Geek
+1 received by user: 30


  Reply # 667761 5-Aug-2012 12:45 Send private message

UPDATE: Used WinSCP to access router files, changed static IP address in a config file, reconnected router to network LAN router, again used WinSCP to access router's command line feature (similar to Telnet), spent three days learning Linux commands, downloaded GUI "package" and installed .... after three attempts now have graphical user interface with router ... whoooo heeee!

Made appropriate settings and now have router working as Access Point etc.

Trying to get the 3G dongle to work is next step ... looks like more package downloads (for USB support), and then amending config files to get 3G dongle dialling correctly.

I'm exhausted, so off to Australia for some sunshine tomorrow.

R.

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Customs wanting power to force travellers to handover passwords and encryption keys
Created by nedkelly, last reply by JWR on 6-Mar-2015 14:47 (32 replies)
Pages... 2 3


Galaxy s6 announcement and owners thread
Created by Shoes2468, last reply by jeffnz on 5-Mar-2015 18:33 (102 replies)
Pages... 5 6 7


Considering Snap - do you rate them?
Created by gsmithnz, last reply by deadlyllama on 5-Mar-2015 22:15 (38 replies)
Pages... 2 3


Whats your USB charging solution?
Created by macuser, last reply by Journeyman on 4-Mar-2015 17:52 (37 replies)
Pages... 2 3


Privacy concerns on returning faulty microSDXC
Created by dpw, last reply by andrewbnz on 3-Mar-2015 22:41 (34 replies)
Pages... 2 3


Recommendations for store bought gaming hard drive for $1500
Created by DebP, last reply by Lias on 6-Mar-2015 15:32 (31 replies)
Pages... 2 3


Why does Lightbox have a suicide wish?
Created by dafman, last reply by MikeAqua on 6-Mar-2015 11:44 (110 replies)
Pages... 6 7 8


Metservice website suffers under stress.
Created by surfisup1000, last reply by surfisup1000 on 6-Mar-2015 15:29 (14 replies)


Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.