If you are not aware, sec company DefenseCode has disclosed an PoCexploiting tested on Cisco Linksys WRT54GL. Versions 4.30.14, and all previous versions are still vulnerable.