Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




215 posts

Master Geek
+1 received by user: 18


Topic # 209148 14-Mar-2017 16:59 Send private message quote this post

I have recently upgraded my Netgear WNDR3700 router to an Edgerouter Lite and I have WiFi through a pair of Cambium E400 APs.  I now want to re-purpose the Netgear as a 5.0 GHz wireless bridge to a Sony stereo in our kitchen.  The stereo has 2.4 GHz WiFi built in, but we have problems with that due to the proximity of the microwave. So I want to connect it via ethernet to the Netgear, then back to the E400 via 5.0 GHz WiFi.

 

I've tried setting this up on the Netgear using both DD-WRT and Gargoyle firmware and testing with a laptop connected via ethernet to the Netgear.   But in both cases the laptop cannot get an IP from the ERL through DHCP.  I've followed the set up instructions for the bridge client and with a manual IP set on the laptop, it can connect back to the ERL no problem.  But when I set it's IP to auto, it can't connect.

 

I've searched Gargoyle and DD-WRT message boards without finding a solution.  It seems some other people have struck the same problem, but haven't appeared to solve it.  With the exact same Gargoyle or DD-WRT settings that work for some people, for others the DHCP doesn't work.  So it sort of seems it's related to something different on the main router/AP side of the set up.

 

So, I'm wondering if anyone could shed some light on why the ERL isn't successfully giving the bridged laptop an IP.  Is there maybe some way to debug DHCP?

 

The test set up is:

 

ERL-----E400 - - -(WiFi) - - -WNDR3700-----laptop


Create new topic
1179 posts

Uber Geek
+1 received by user: 56

Subscriber

  Reply # 1736469 14-Mar-2017 19:22 Send private message quote this post

so you have definatley turned off DHCP on the netgear right?

 

 




215 posts

Master Geek
+1 received by user: 18


  Reply # 1736489 14-Mar-2017 20:05 Send private message quote this post

Goosey:

 

so you have definatley turned off DHCP on the netgear right?

 

 

When it's in Client Bridge mode (in Gargoyle) that's done implicitly for you.  There's no place to switch on/off or configure DHCP.

 

 


24611 posts

Uber Geek
+1 received by user: 4564

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 1736512 14-Mar-2017 20:37 Send private message quote this post

It is working as a true L2 bridge passing the correct MAC address from behind the bridge being passed through and not the MAC address of the itself itself?




215 posts

Master Geek
+1 received by user: 18


  Reply # 1736545 14-Mar-2017 22:04 Send private message quote this post

sbiddle:

 

It is working as a true L2 bridge passing the correct MAC address from behind the bridge being passed through and not the MAC address of the itself itself?

 

 

It doesn't seem to be doing that correctly.  The ERL can't see the MAC of the laptop, but it seems to be giving an IP address to the Netgear.  So it would appear the bridge is not working correctly.  But I'm pretty sure I configured it exactly as instructed.  Also, I've tried it with both DD-WRT and Gargoyle and with both firmwares I get the same problem.  


234 posts

Master Geek
+1 received by user: 16


  Reply # 1736579 14-Mar-2017 22:27 Send private message quote this post

Is it not possible to just use a static IP if that's working? Or do you not have that option on the stereo? Does the stereo need to be in the same subnet to access services on your LAN? Or is just access to the web required? If so, could the Netgear just be run as a router so that its WAN interface is via WiFi and it'll hand out addresses to clients on its ethernet ports if you need DHCP?


521 posts

Ultimate Geek
+1 received by user: 99


  Reply # 1736598 15-Mar-2017 04:16 quote this post

I had a similar problem and resolved it by setting the DNS in the bridged router (the Netgear in your case) to point to my main router (your ERL).



215 posts

Master Geek
+1 received by user: 18


  Reply # 1736656 15-Mar-2017 09:07 Send private message quote this post

rhy7s:

 

Is it not possible to just use a static IP if that's working? Or do you not have that option on the stereo?

 

 

Yep, that's probably possible.  I really want to see if I can get the bridge working "properly", but failing that, it'll probably be good enough just to set the stereo IP manually.  It'll be the only client using the bridge.


Create new topic



Amazon prices in US$






Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:






Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.