Join us in Wellington 4th December and Auckland 27th November
Want to help us test an ads-free Geekzone? Register for webpass now

Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

83 posts

Master Geek
+1 received by user: 2

Topic # 112890 26-Dec-2012 09:41 Send private message

Okay I need to use Airplay on my TV within 4 hours from now but it is not working. I can connect my Apple TV to my home's wifi network perfectly and I updated the Apple TV software but I cannot use airplay. iTunes on my iPod Touch and iPhone and Windows PC all display the Apple TV but when I try to connect to it, it just takes about 30 seconds then the connection is lost.

I think it may have something to do with opening ports, port forwarding, ip address, DMZ on access point and router.

My home setup is wifi access point(doesn't handle dhcp) connected to dsl modem/router and the modem/router handles the DHCP. I am not using static ips, I am using dynamic.  Both ap and router have a DMZ field to enter an ip address.

My dsl/modem router ip address is
Wifi access point ip address is
AppleTV ip address(dynamic, not static) is
Wifi Ap has an option for application rules, port forwarding with port trigger,port firewall,traffic type
Router has option for single port forwarding,port range forwarding, port range triggering,

If people can list here multiple different ways for me to get it to work that would be fantastic, even if the ways may not be the most secure.

Create new topic
379 posts

Ultimate Geek
+1 received by user: 30


  Reply # 737296 26-Dec-2012 10:06 Send private message

Are you using the Music app, or the iTunes app as you state in your posting? The Music app should play through your Apple TV but the iTunes app is not designed to do this.

Other than that, I have no idea why it doesn't work.


[Edit: try File > Home Sharing > Turn on Home Sharing in iTunes and play your music through your computer to your Apple TV.]

756 posts

Ultimate Geek
+1 received by user: 42

  Reply # 737307 26-Dec-2012 10:56 Send private message

Switch off the 5Ghz channel on the router and only use 2.4 Ghz if you can.

602 posts

Ultimate Geek
+1 received by user: 6

  Reply # 737652 27-Dec-2012 11:54 Send private message

I had endless problems with Airplay, until I got an airport express router.

Try rebooting your router and all hardware. That is usually a temp fix

3269 posts

Uber Geek
+1 received by user: 644

  Reply # 737667 27-Dec-2012 12:24 Send private message

Try also activating UPnP and IGMP on the router.

Create new topic

Twitter & Pushbullet »
Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

Follow us to receive updates on your mobile device or browser via Pushbullet:

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.