Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



48 posts

Geek


Topic # 113101 6-Jan-2013 15:10 Send private message

My Asus Nexus tablet - had it since August 2012 - has the "option" to set up my home email client on it. My ISP is Clear.net.nz. I discovered after set up that I could not send any emails using that client. Clear (Telstraclear) advised me after raising a query with them that they "block" my ability to send any emails because they do not wish to clog up their servers with spam. That is their policy with any android devices and there is no way around that.

Has anyone else run into this? I have a gmail account so can use my device to send emails anyway. Other mobile devices - non android driven - are acceptable for send and receive features of one's own email client.

Would the policy of Clear change now that Vodafone own them? Have I just by my own bad luck got the wrong ISP - depite that  have been with them all along (via Paradise then to Clear). Or should I have bought a device that is non android?

What comments and/or other experiences or advice have others got for me in this scenario?

Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
15569 posts

Uber Geek
+1 received by user: 829

Trusted
Vodafone NZ
Subscriber

  Reply # 740674 6-Jan-2013 15:19 Send private message

This does not sound correct at all, Should make no difference what OS you are using,

What smtp server address are you using on the tablet email client?




BDFL
48016 posts

Uber Geek
+1 received by user: 3568

Administrator
Trusted
Geekzone
Subscriber

  Reply # 740675 6-Jan-2013 15:29 Send private message

More likely the person was clueless. You are probably trying to use their SMTP server while connected to another network, something most ISPs do anyway.






48 posts

Geek


  Reply # 740683 6-Jan-2013 16:08 Send private message

Thanks for those replies. To Vodafone Systems Engineer .........

Here's what the Clear site says of my problem --

I can receive email, but I can't send        Published 05/07/2007 02.37 PM          |           Updated 16/02/2010 10.25 AM       I can receive email, but I can't send any email. What can I do?There are several reasons why this may happen. The most common causes are listed below.
  • If you get an error Cannot find host SMTP, then you have to check the outgoing email server address in your email settings. The outgoing emailserver address is smtp.clear.net.nz.
    Click here for a list of settings in most popular email programs.
  • If you get an error 553 Relaying denied, then you have to check the outgoing email server address of the ISP your have access to.
    When you are connected to Clearnet, you have to enter the outgoing email server address of Clearnet, which is smtp.clear.net.nz.
    When you are connected to another ISP, then you have two options to solve this problem. Either you activate smtp authentication in your email program or you enter the outgoing email server address of the ISP you have access to. Check the support pages of the ISP you have access to for the outgoing email server address.
  • The ISP you are having access to is blocking port 25. If the ISP is blocking port 25, you may not be able to send email using your Clearnet account (even with smtp authentication). Some ISP's do this so that you are forced to use their email servers when sending email, as an attempt to prevent spammers to send spam through their emailservers.
  • If you are using an antivirus program and/or firewall, then disable these programs before you try to send an email. If this enables you to send out emails, then the problem is caused by your antivirus program and/or firewall. For further troubleshooting we can refer you to the manufacturer of the program.
    Click here for the contact details of most common anti virus and firewall programs.
  • Check the network status of TelstraClear for any outages
I mailed Clear - especially in regard to the blocking of Port 25 on the SMTP settings page - and asked them whether that was happening to me and whether there was any way around the matter. I was told that the policy was firm in respect of android devices/systems (at least for Clear). I asked whether there could be a dispensing of that policy just for me because i do not send spam and gave my oath that I never would do so. But that was not acceptable either. There was just no way around the matter for me. So, in my travels I have to access my emails on my own email account via the Webmail route of the Clear website. That's cumbersome. My other option was to create a gmail account - that I have done and have used. But, again, I find that cumbersome too.

I'd welcome any other ideas.








48 posts

Geek


  Reply # 740685 6-Jan-2013 16:15 Send private message

And - thanks Mauricio.

No I have not done that. I have simply gone into my email client - that I thought I had set up - and sent an email (or thought I had done so) and then waited and waited and waited for my mail to be sent. Of course it never happened. I only found out why and that Clear were blocking my outgoing emails because I was using an android device.

Returning home after that episode I researched the matter, found the explanation and corresponded with Clear (via emails) but could not convince them to not block me (despite my earnest promises to become a spammer and to choke up their server/s (as I have got better things to do!).

15569 posts

Uber Geek
+1 received by user: 829

Trusted
Vodafone NZ
Subscriber

  Reply # 740691 6-Jan-2013 16:24 Send private message

Does the email client on the tablet support smtp authentication?






48 posts

Geek


  Reply # 740729 6-Jan-2013 19:32 Send private message

Thanks John.

I take it that it does (support SMTP authentication).

That is the routine/wizard that one follows when setting up one's own email client on the device - that is there is a "page" into which fields one has to enter the "Port 25". My experience is that despite that the end of routine returns a "you have now set up your email client" message I am still unable to send emails from the tablet. On rechecking the email client set up I find that the SMTP Port has defaulted to the block Port number.

The routines that I have followed come out of the "set up Email client on android device" that can be found via the Help Tab on the Clear home page.

6204 posts

Uber Geek
+1 received by user: 216

Trusted

  Reply # 740731 6-Jan-2013 19:48 Send private message

I have seen Telstra AU appear do that to an iPad ... Ran into a tourist in DSE bemused at why his iPad can receive but not send email despite me checking his setting against the website instructions 100% match

Not sure what that underlying issue was but sounds very familiar




Apologies for poor typing standards when on Samsung Galaxy S4 LTE/iPad 2 Wifi

18589 posts

Uber Geek
+1 received by user: 741

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 740745 6-Jan-2013 20:06 Send private message

TelstraClear don't have generic "block" on SMTP from Andopd device. If they did there would be thousands on people complaining. My pick is you have something configured incorrectly on your device.

If you're trying to send mail from outside the TCL network you need to use SMTP auth or use the SMTP server of the ISP you're connecting to. The SMTP blocking in the email from TCL refers to other ISP's (such as Telecom) who block port 25 by default.


1056 posts

Uber Geek
+1 received by user: 19

Subscriber

  Reply # 740746 6-Jan-2013 20:06 Send private message

Gradine: Thanks John.

I take it that it does (support SMTP authentication).

That is the routine/wizard that one follows when setting up one's own email client on the device - that is there is a "page" into which fields one has to enter the "Port 25". My experience is that despite that the end of routine returns a "you have now set up your email client" message I am still unable to send emails from the tablet. On rechecking the email client set up I find that the SMTP Port has defaulted to the block Port number.

The routines that I have followed come out of the "set up Email client on android device" that can be found via the Help Tab on the Clear home page.


And the emails you are sending relate to which email account, a clear account?? or gmail account?? And confirm that you connect via Clear rather than a Vodafone or Telecom 3G connection.




Ross
ADSL2+ sync (Kbps): 11577/945, attenuation (dB): 33.0/16.9, Noise margin (dB): 11.5/11.5

653 posts

Ultimate Geek
+1 received by user: 20

Trusted

  Reply # 740794 6-Jan-2013 22:31

Gradine:  So, in my travels I have to access my emails on my own email account via the Webmail route of the Clear website. That's cumbersome.


Just in case it wasn't clear, the reason you are having problems is to do with how your email client is set up on your android device.

When you connect to your ISP's SMTP server (smtp,clear.net.nz) without authentication, you can only access it if you are connected via a TelstraClear ISP connection - if you are accessing it through an Xtra or Vodafone connection, for example, it won't work.  This is by design and prevents people from accessing the SMTP server outside of your ISP's control (and is probably the explanation you were given regarding sending spam).

There are a few ways around this problem:
a) Enable SMTP authentication if your ISP supports it - usually this involves a different port and requires you to enter/save your username and password details for the SMTP server

b) Use Gmail's SMTP server to send your emails (but potentially replies will get directed to your gmail account from memory) :

smtp.gmail.com
Use authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL 465
user:[email protected]
password: password

c) Stop using ISP email, and migrate your email to gmail - you won't regret it, particularly if you ever want to switch ISP







48 posts

Geek


  Reply # 742267 9-Jan-2013 14:00 Send private message

Odd "development" since I started this query.

Clear no longer has the instructions on its site for the setup of an email client on an android device. And, the explanation as to why one could not send emails via an email client on any android device that was there (too) has also disappeared.

Funny thing that should happen.

I have now separately sent a request to Clear to obtain an explanation as to why this ISP has removed its set up instructions for android devices. And I have asked what are the (correct) procedures to follow to set up one's own email client on android. Have also asked whether the change of ownership to Vodafone is the reson for the (possible) change and how long it will be before the Clear policy will be dumped and replaced with a sensible one - ie, allow one to send emails from an android device using one's own email client.

I await an answer.

This whole thing is a puzzle for the moment.

18589 posts

Uber Geek
+1 received by user: 741

Moderator
Trusted
Biddle Corp
Subscriber

  Reply # 742305 9-Jan-2013 15:02 Send private message

I just want to set one thing straight - there is no blanket restriction on sending email from Android devices. As I posted above if this was the case there would be hundreds of people on here complaining about this very issue.

Without knowing a lot more details about your setup as it stand now it's hard to comment on the exact cause but there is probably a 99% chance that you've got something set up incorrectly on your device which is causing the issue.




48 posts

Geek


  Reply # 742327 9-Jan-2013 15:30 Send private message

Thanks Steve.

I favour that you are right - but for the life of me I cannot find out what is wrong. I've followed the Clear instructions most carefully. I've rechecked the settings but the Port 25 still "reverts" to Port 587. And, in all contact with Clear about this occuring (and Clear telling all on its site that it blocks the send side of the android email client) I have obtained verbal and written confirmation as to why what is happening to me also happens to others.

I'll just with and see what comes of my query to Clear. As I said - funny thing that just on 6th (I first saw it on 8th) the setup procedures for email on android are dropped off the Clear site.

1056 posts

Uber Geek
+1 received by user: 19

Subscriber

  Reply # 742331 9-Jan-2013 15:35 Send private message

https://clearnet.custhelp.com/app/answers/detail/a_id/1593#AndroidMail





Ross
ADSL2+ sync (Kbps): 11577/945, attenuation (dB): 33.0/16.9, Noise margin (dB): 11.5/11.5

1056 posts

Uber Geek
+1 received by user: 19

Subscriber

  Reply # 742333 9-Jan-2013 15:39 Send private message

Gradine: Thanks Steve.

I favour that you are right - but for the life of me I cannot find out what is wrong. I've followed the Clear instructions most carefully. I've rechecked the settings but the Port 25 still "reverts" to Port 587. And, in all contact with Clear about this occuring (and Clear telling all on its site that it blocks the send side of the android email client) I have obtained verbal and written confirmation as to why what is happening to me also happens to others.

I'll just with and see what comes of my query to Clear. As I said - funny thing that just on 6th (I first saw it on 8th) the setup procedures for email on android are dropped off the Clear site.



port 587 is the port typically used for an authenticated SMTP connection but is set by default for SMTP on iPhones at least. Simply edit and change to 25.

EDIT: Just because the phone inserts the port number doesn't mean that the phone has a clue what port the service really runs on. Up to you to edit to correct port. That is, the phone's choice of 587 has nothing whatsoever to do with any ports being blocked.




Ross
ADSL2+ sync (Kbps): 11577/945, attenuation (dB): 33.0/16.9, Noise margin (dB): 11.5/11.5

 1 | 2
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic








Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when new jobs are posted to our jobs board:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:




News »

Trending now »
Hot discussions in our forums right now:

Telecom introduces unlimited broadband data plan
Created by freitasm, last reply by mxpress on 25-Apr-2014 17:11 (116 replies)
Pages... 6 7 8


Stonedine
Created by Lizard1977, last reply by mattwnz on 24-Apr-2014 15:45 (67 replies)
Pages... 3 4 5


Windows 8 System Mechanics
Created by eme, last reply by eme on 24-Apr-2014 21:10 (20 replies)
Pages... 2


Using my Mac to ring family in the UK
Created by Geektastic, last reply by nakedmolerat on 24-Apr-2014 11:28 (19 replies)
Pages... 2


Telecom has started metering their TiVo customers' broadband usage (WITHOUT PRENOTIFICATION)
Created by Peteriv, last reply by mattwnz on 24-Apr-2014 15:11 (74 replies)
Pages... 3 4 5


Address checker accuracy?
Created by EviLClouD, last reply by hio77 on 25-Apr-2014 18:53 (17 replies)
Pages... 2


Parallel imported product
Created by Wills1, last reply by joker97 on 23-Apr-2014 21:01 (53 replies)
Pages... 2 3 4


Forms of government for New Zealand
Created by charsleysa, last reply by KiwiNZ on 25-Apr-2014 17:42 (183 replies)
Pages... 11 12 13



Geekzone Live »
Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.