Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.



7 posts

Wannabe Geek


Topic # 110382 8-Oct-2012 17:04 Send private message

Hello and thanks for reading my post!

Currently my setup is - Wall - Modem ( Telecom TG585 v8) - Router ( DSE XH9948) - Computer.
I am trying to port forward specific ports so I could run a COD4 Server. The ports required to be opened for COD4 Servers are

20800 UDP
20810 UDP
28960 UDP

So I went into the routers page (192.168.0.2) and went into the section Forwarding and then into Virtual Servers. Over there I added the ports stated above with the Protocols being set All (UDP and TCP - just to be safe =P) and the IP Address of my computer ( 192.168.0.10), and it says Status - Enabled for all ports, but for some reason whenever I try a programme to see if my ports are enabled it says they are disabled =/

Also as I am opening these ports for COD4 , I have let COD4 , and also all the three ports through my firewall
so I know it isn't my firewall that is blocking it.

So I was wondering if anybody could help by telling what is causing the ports to be "closed".

Many Thanks!
Harsh

Create new topic
Voice Engineer @ Orcon
2111 posts

Uber Geek
+1 received by user: 514

Trusted
Orcon
Subscriber

  Reply # 698030 8-Oct-2012 17:13 Send private message

You can't really check if a UDP port is open... and your PC won't be listening on the TCP ports.  So I'm not sure how you're testing.  Best to just see if your COD4 server is operating from the outside...

2922 posts

Uber Geek
+1 received by user: 494


  Reply # 698037 8-Oct-2012 17:19 Send private message

Are both the router and modem doing NAT?



7 posts

Wannabe Geek


  Reply # 698040 8-Oct-2012 17:26 Send private message

Ahh ok, I also checked by tell my friends to join through console , they wrote /connect 122.##.###.###:28960.
But it kept going to connection timed out.



7 posts

Wannabe Geek


  Reply # 698046 8-Oct-2012 17:36 Send private message

Sorry I didn't get what you meant by Router and Modem doing Nat?

2922 posts

Uber Geek
+1 received by user: 494


  Reply # 698070 8-Oct-2012 18:30 Send private message

heybro: Sorry I didn't get what you meant by Router and Modem doing Nat?


NAT

What are the IP addresses that you use to connect to your modem and router?



7 posts

Wannabe Geek


  Reply # 698080 8-Oct-2012 18:54 Send private message

For my modem it is - http://192.168.1.254/
and for my router it is - http://192.168.0.2/

Thanks

2922 posts

Uber Geek
+1 received by user: 494


  Reply # 698082 8-Oct-2012 19:04 Send private message

OK, looks like you probably have two devices doing NAT (double NAT).

Trying to get port forwarding working through this will be problematic at the very least.

Can NAT be disabled on one of these devices (bridge mode or similar)?



7 posts

Wannabe Geek


  Reply # 698101 8-Oct-2012 19:40 Send private message

I can always connect straight to the modem , I only use router for the wireless network but I don't need that for my computer.

2922 posts

Uber Geek
+1 received by user: 494


  Reply # 698120 8-Oct-2012 20:03 Send private message

OK, if you can live without your router for now, remove it from the network.

Once you've done that, you should be able to configure the port forwarding in the modem instead.

Once you have that sorted, then look at getting wireless back on the network if you need it.



7 posts

Wannabe Geek


  Reply # 698127 8-Oct-2012 20:11 Send private message

Ok I will give that a go, Thanks! So basically I can't have my modem and my router connected at the same time? is there any through this problem?



7 posts

Wannabe Geek


  Reply # 698612 9-Oct-2012 18:01 Send private message

Ok I managed to get it working! What i was doing wrong was that even though I enabled the right ports for my modem, I was sending them the wrong IP address! I was sending the IP address for my computer, but then I sent them to the routers IP and it worked fine!
Thanks for your help!

2922 posts

Uber Geek
+1 received by user: 494


  Reply # 698655 9-Oct-2012 19:22 Send private message

Glad you got it going.

You hit one of the problems faced when trying to do double NAT.

Create new topic




Twitter »
Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





Trending now »

Hot discussions in our forums right now:

Smoke billows from Auckland mall after "explosion" - Westfield West City
Created by freitasm, last reply by hio77 on 27-Feb-2015 19:33 (41 replies)
Pages... 2 3


Why does Lightbox have a suicide wish?
Created by dafman, last reply by NonprayingMantis on 2-Mar-2015 16:04 (88 replies)
Pages... 4 5 6


Privacy concerns on returning faulty microSDXC
Created by dpw, last reply by networkn on 2-Mar-2015 15:39 (29 replies)
Pages... 2


Galaxy s6 announcement and owners thread
Created by Shoes2468, last reply by richms on 2-Mar-2015 16:26 (52 replies)
Pages... 2 3 4


HTC One M9 (2015) Announcement and Discussion
Created by Dingbatt, last reply by markl on 2-Mar-2015 17:51 (39 replies)
Pages... 2 3


Uber Taxi Rides - $10 off first ride.
Created by kiwijunglist, last reply by gzt on 1-Mar-2015 23:38 (18 replies)
Pages... 2


The Evil that is ISIS
Created by networkn, last reply by joker97 on 28-Feb-2015 22:47 (201 replies)
Pages... 12 13 14


Spark Open Term Plan Changes? (27/2)
Created by taneb1, last reply by funnyfela on 28-Feb-2015 15:03 (37 replies)
Pages... 2 3



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.