Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




76 posts

Master Geek
+1 received by user: 2


Topic # 143805 28-Apr-2014 08:52
Send private message

Got home last night and my onkyo home theatre receiver has died, no sound and network / USB isn't functioning either. A google shows it's a known fault for onkyos the hdmi board dies, there was a recall in 2012 but mine was apparently not affected (yeah right).

A check of the receipt shows I bought it in dec 2011 and the warranty for this model is 2 years. Does anyone think I have any recourse under the CGA? It's a fairly high end model (tx-nr709) which I paid $1400 for so I would have thought its service life should be more than 2 years...

I'm heading in jbhifi to see want they say today but curious to hear anyone else's opinion.

Create new topic
3218 posts

Uber Geek
+1 received by user: 392


  Reply # 1032374 28-Apr-2014 09:35
Send private message

The CGA is very much on your side unless the retailer can prove mis-use.
No doubt it will be sent to repair by the importer.
Good luck...

1736 posts

Uber Geek
+1 received by user: 896


  Reply # 1032377 28-Apr-2014 09:37
Send private message

Did you actually power it off and on again? 

My cheap amp did something similar a while back, all inputs just wouldn't work including FM. I eventually pulled the plug in disgust. Turns out I hadn't tried turning it off and on again, and being powered off overnight sorted it out. I haven't had any trouble since.




Location: Dunedin

 
 
 
 


13353 posts

Uber Geek
+1 received by user: 2249

Trusted
Subscriber

  Reply # 1032385 28-Apr-2014 09:47
One person supports this post
Send private message

5 years would be the minimum I'd expect something like that to work. A CGA claim should have no problems. Remember to go in asking for their help, not demanding anything under the CGA unless they won't help when you play nice.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer




76 posts

Master Geek
+1 received by user: 2


  Reply # 1032461 28-Apr-2014 11:22
Send private message

Thanks all, yep I unplugged it for an hour tried updating firmware, factory reset etc but no dice.

Jb were great, yep no problem as long as it hasn't been surged, abused, etc which it hasn't so should be all good.

Only downside is 6 to 8 weeks repair time as only one repairer in NZ! As it was my HT hub it means I'm running off a single hdmi cable (TV is wall mounted no ports accessible) and my old school xbox is a no go as it is component.... Just as I started playing online and bought some nice new wireless cans too... Bah!

(First world problems)

Fully Operational
3343 posts

Uber Geek
+1 received by user: 1088

Trusted
Vocus
Subscriber

  Reply # 1032475 28-Apr-2014 11:33
Send private message

shall0w: Thanks all, yep I unplugged it for an hour tried updating firmware, factory reset etc but no dice.

Jb were great, yep no problem as long as it hasn't been surged, abused, etc which it hasn't so should be all good.

Only downside is 6 to 8 weeks repair time as only one repairer in NZ! As it was my HT hub it means I'm running off a single hdmi cable (TV is wall mounted no ports accessible) and my old school xbox is a no go as it is component.... Just as I started playing online and bought some nice new wireless cans too... Bah!

(First world problems)


I got an HDMI switch going cheap if you want PM me ;) brand new, tested fine, just didn't work for my (oddball) application.



76 posts

Master Geek
+1 received by user: 2


  Reply # 1032477 28-Apr-2014 11:35
Send private message

The irony is I just sold a hdmi switch that was lying around from when I upgraded to this amp.... Thanks but my main concern is the xbox so I'm now trawling trade me for a cheap hdmi one... The mrs won't be pleased!

3218 posts

Uber Geek
+1 received by user: 392


  Reply # 1032515 28-Apr-2014 12:30
Send private message

shall0w: Thanks all, yep I unplugged it for an hour tried updating firmware, factory reset etc but no dice.

Jb were great, yep no problem as long as it hasn't been surged, abused, etc which it hasn't so should be all good.

Only downside is 6 to 8 weeks repair time as only one repairer in NZ! As it was my HT hub it means I'm running off a single hdmi cable (TV is wall mounted no ports accessible) and my old school xbox is a no go as it is component.... Just as I started playing online and bought some nice new wireless cans too... Bah!

(First world problems)


6-8 weeks has to be outside of an 'acceptable' time frame.
Surely JB Hifi will have to stump up and swap out a new amplifier for you.
Having to pay out for new gear just to 'keep going' isn't what I'd be happy with.
The lack of service agents is not your problem, that's an issue between the supplier and the retailer.

13353 posts

Uber Geek
+1 received by user: 2249

Trusted
Subscriber

  Reply # 1032516 28-Apr-2014 12:32
Send private message

A loan amp could be a mutually acceptable workaround.




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer




76 posts

Master Geek
+1 received by user: 2


  Reply # 1032542 28-Apr-2014 13:21
Send private message

Any loan amps they had are not hdmi so of no use unfortunately... I'll survive, a near new xbox elite has been procured and some long hdmi cables (kicking myself for not running more through the wall) are enroute.

The last one they sent in was 5 weeks so they were just trying to set expectations I guess...

Lucky for them I bought the new headphones as without them I'd notice the lack of an amp much more!

BTR

1372 posts

Uber Geek
+1 received by user: 364

Subscriber

  Reply # 1032611 28-Apr-2014 15:07
Send private message

Owch, I have just started setting my system up again after renovating the lounge for the last 2-3 months, forgot what it was like to have TV and home theatre. I just need to climb on the roof and terminate the new aerial cable to the antenna so I feel your pain in a similar way.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Mobile market competition issues ComCom should watch
Posted 18-Dec-2017 10:52


New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47


Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39


UAV Traffic Management Trial launching today in New Zealand
Posted 12-Dec-2017 16:06


UFB connections pass 460,000
Posted 11-Dec-2017 11:26


The Warehouse Group to adopt IBM Cloud to support digital transformation
Posted 11-Dec-2017 11:22


Dimension Data peeks into digital business 2018
Posted 11-Dec-2017 10:55


2018 Cyber Security Predictions
Posted 7-Dec-2017 14:55


Global Govtech Accelerator to drive public sector innovation in Wellington
Posted 7-Dec-2017 11:21


Stuff Pix media strategy a new direction
Posted 7-Dec-2017 09:37


Digital transformation is dead
Posted 7-Dec-2017 09:31


Fake news and cyber security
Posted 7-Dec-2017 09:27


Dimension Data New Zealand strengthens cybersecurity practice
Posted 5-Dec-2017 20:27


Epson NZ launches new Expression Premium Photo range
Posted 5-Dec-2017 20:26


Eventbrite and Twickets launch integration partnership in Australia and New Zealand
Posted 5-Dec-2017 20:23



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.