Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




122 posts

Master Geek
+1 received by user: 9


# 178960 20-Aug-2015 18:50
Send private message

I've just ported my phone number over to a VoIP provider (2talk reseller) and now get tons of calls from four digit numbers.

The numbers seem random and It's so many calls overnight that I've had to unplug the phone.

Any ideas what I can do? Never had this issue while on a standard land line.



Create new topic
19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  # 1371059 20-Aug-2015 18:57
Send private message

Who or what is on the end when you answer them?

27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1371060 20-Aug-2015 19:01
Send private message

Let me take a guess about your setup.. You have a Cisco ATA and have port 5060 forwarded on your firewall to the ATA.

Am I right? If I am I'll tell you what your problem is.



 
 
 
 


22263 posts

Uber Geek
+1 received by user: 4785

Trusted
Subscriber

  # 1371064 20-Aug-2015 19:14
Send private message

I have 8 numbers with 2talk and get no more calls than on a standard landline. Except I can block anonymous on 2talk, which if you have the phone open to the whole internet will not help you.




Richard rich.ms

200 posts

Master Geek
+1 received by user: 72


  # 1371067 20-Aug-2015 19:25
Send private message

Hey Steve, I get your reference to open SIP port from the public internet, but just wondering what made you think it was a Cisco ATA? Are they more prone to accepting unauthenticated inbound IP calls than other devices or is there some other reason for your suspicions?

 

Pete




122 posts

Master Geek
+1 received by user: 9


  # 1371069 20-Aug-2015 19:36
Send private message

No ports open, but it is an ATA (Grandstream) and the router has UPNP and SIP ALG enabled.

27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1371070 20-Aug-2015 19:36
Send private message

speed: Hey Steve, I get your reference to open SIP port from the public internet, but just wondering what made you think it was a Cisco ATA? Are they more prone to accepting unauthenticated inbound IP calls than other devices or is there some other reason for your suspicions? Pete



Cisco ATA's are by far the most common.. But I'm just interested to hear what the OP's setup is before I post any more.


27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1371072 20-Aug-2015 19:37
Send private message

ElectronicFerret: No ports open, but it is an ATA (Grandstream) and the router has UPNP and SIP ALG enabled.


So my pick would be you're exposing port 5060 to the internet and your ATA is being targeted by SIP bots.

You should go back to the reseller and ask them to securely configure your VoIP solution for you.



 
 
 
 


27989 posts

Uber Geek
+1 received by user: 7469

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1371074 20-Aug-2015 19:39
Send private message

speed: Hey Steve, I get your reference to open SIP port from the public internet, but just wondering what made you think it was a Cisco ATA? Are they more prone to accepting unauthenticated inbound IP calls than other devices or is there some other reason for your suspicions? Pete



If you want some fun have a look at the number of Cisco ATA's in Shodan that are fully exposed to the Internet. It's no wonder VoIP fraud is such a big thing...

 



122 posts

Master Geek
+1 received by user: 9


  # 1371079 20-Aug-2015 20:03
Send private message

sbiddle:
ElectronicFerret: No ports open, but it is an ATA (Grandstream) and the router has UPNP and SIP ALG enabled.

So my pick would be you're exposing port 5060 to the internet and your ATA is being targeted by SIP bots.
You should go back to the reseller and ask them to securely configure your VoIP solution for you.


So is this in the VoIP ATA, or in my ethernet router?



175 posts

Master Geek
+1 received by user: 18


  # 1371086 20-Aug-2015 20:12
Send private message

The Grandstream ATA's can do upnp and as such if your router has it enabled then port 5060 will be forwarded from the public internet to your ATA and will cause the issue you are getting.

Log in to the ATA and turn off the UPNP Nat type. either set it to use stun and set a stun server. you could also try to set it to none.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Spark Sport launches across a range of new devices
Posted 22-Jul-2019 13:19


Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.