Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




91 posts

Master Geek


# 29956 24-Jan-2009 12:35
Send private message

I have a netgear D834G version 4, flashed to the latest firmware and it's been working a charm for months...
I came home last night, and tried to connect to the internet from my Macbookpro and...  no joy.My wife's laptop connects fine, if I plug a cable directly into the router, my macbook is fine, just not on the wireless.
so I believe my problem is not with my router, but with my Macbookpro, hence I post under the mac OS forum.
I checked my ip address and it's a 169.... not the 192.168 it's suppose to be.I disabled ipv6 and tried setting a manual ip address on the correct range, no joy.
I have run Applejack and checked all file based permissions etc..I have reset the P VRAM using "Option-Command-P-R" and rebooting twice holding down these keys. - no change.
I have deleted all my network locations and the keychain entries for networks, and then re-created them all - no joy.
I've run out of ideas?
ideas anyone.

Create new topic
1275 posts

Uber Geek

Trusted

  # 191865 24-Jan-2009 20:50
Send private message

hi,sure looks like you've tried almost everything, perhaps create a new user account?failing that can you boot from another system or from installers and see if it connects?
cheers,Joseph

1937 posts

Uber Geek
Inactive user


  # 191891 25-Jan-2009 00:09
Send private message

I have a MacBook and an iBook and the "self-assigned IP" intermittent problem drives us NUTS.

It's definitely the biggest "just doesn't work" aspect of my Mac experience.

Google "OS X self-assigned IP" and you will see just how widespread and difficult to fix a problem this is.

I'm just assuming that you have the same problem, but there are many different reasons it might be happening.

For me it was simply using the "Locations" aspect of the Network Preferences - as soon as I put in a new location that required a proxy server, I could kiss goodbye to my home network being auto-detected and connected to.

In terms of fixing it - go to your keychain (Spotlight search for it) and select the WiFi password in the keychain - go to the permissions tab (I think) and change it to "allow all programs to access this" rather than "ask" or whatever the other option is.

Then delete the .plist files (airport and network prefs) from the library folder (again I don't know the exact location so use Google or Spotlight), and then reboot.

For me I have to get the Mac to "forget" the network, and then rejoin manually and supply password, to get it to work again.

Oh yeah - I presume you have your Firewall turned on as I do. Because I think that is one of the causes of this problem. Even though I always "allow" when the Firewall asks, for some reason it still seems to cause the problem you've described.

Sorry there is no easy answer. I've wasted hours and days over it. Good luck.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29


Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24


Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59


Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07


Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02


Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41


Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36


2degrees Reaches Milestone of 100,000 Broadband Customers
Posted 1-Oct-2019 09:17


Nokia 1 Plus available in New Zealand from 2nd October
Posted 30-Sep-2019 17:46


Ola integrates Apple Pay as payment method in New Zealand
Posted 25-Sep-2019 09:51


Facebook Portal to land in New Zealand
Posted 19-Sep-2019 18:35


Amazon Studios announces New Zealand as location for its upcoming series based on The Lord of the Rings
Posted 18-Sep-2019 17:24


The Warehouse chooses Elasticsearch service
Posted 18-Sep-2019 13:55


Voyager upgrades core network to 100Gbit
Posted 18-Sep-2019 13:52


Streaming service Acorn TV launches in New Zealand with selection with British shows
Posted 18-Sep-2019 08:55



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.