Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

108 posts

Master Geek

#32977 27-Apr-2009 22:14
Send private message


Now I'll just explain that I am actually a PC technician trying to help out a mate on his Mac so my knowledge of Mac's isn't great but I'm hoping for help.

The problem is that he cannot get an internet connection wirelessly through his macbook and his base station.

His internet connects to a switch and from the switch is an ethernet cable to his base station. The light on the base station is green. His macbook shows status 'connected' to the base station but no internet!?

The IP address he gets is - is this normal for Mac's ?

NOTE: he can get an internet connection when connected through ethernet cable from the switch to the macbook.

Do we need to log into the base station and configure an ip or some other setting?
I assumed connecting an ethernet cable from the switch into the base station would just do the job automatically with no config required.

Thanks to anyone that can shed some light.


Create new topic


923 posts

Ultimate Geek


  #210080 28-Apr-2009 09:10
Send private message

That's a zeroconf IP address - assigned automatically by the PC when you haven't given it one, and there's no DHCP server to give one out.

What is this 'base station' ? is it an airport? If so, try removing the ethernet cable from the WAN port of the airport, and just putting it into one of the 4 LAN ports. From memory, they bridge by default.

If it's an airport express, whip out the airport config utility and set it up so that it's in 'bridge' mode.

Make sure you have security of some description configured - WPA2 if you can.


108 posts

Master Geek

  #210149 28-Apr-2009 12:24
Send private message

Hi, yes it is an airport, he was calling it a base station.

My mates airport only has 1 ethernet input so I do not have any others to choose from.

It has worked in the past from his old router to his airport and then he gets wireless internet from that to his macbook.
Just not sure why it isn't working now.

It might be the Airport express, I'll have a look for the bridge mode you mentioned.

As for secuirty, not a problem, he's on a rural property with nobody in range.

Cheers and I'll try your suggestions but prob wont be able to until the weekend.




923 posts

Ultimate Geek


  #210152 28-Apr-2009 12:30
Send private message

If it has one ethernet port, it's an express, unless it's a really old one. Seems like the macbook isn't getting an IP from the DHCP server on his router.. that's either because the airport is in 'share an IP' mode, or that even the airport isn't getting an IP. check that the airport has an IP in the range served by the router.

Can't tell you much more without some more information - screenshots of the current config from airport utility will help, and output of 'ifconfig' on the macbook (I presume it's running OS X, open and run 'ifconfig')


108 posts

Master Geek

  #210156 28-Apr-2009 12:36
Send private message

Thanks mate, yeah I know it's a bit hard. I'm trying to do it remotely over the phone with him and he doesn't know too much.
Thanks for the ifconfig - I was wondering how to get that info on a mac
Next time I see him, as he only just bought the switch, I will log in to the switch and make sure dhcp is set etc.


36 posts


  #218854 28-May-2009 17:18
Send private message

Configuring an Airport on a Mac is by running the "AirPort Utility" which lives in the /Applications/Utilities folder. It should find any Airport it can see on a working network interface on the Mac. There is a "Wizard" style of step through available to setup stuff. This should all work unless he previously used the Airport with a different Mac, set a password and doesn't remember it.

165 posts

Master Geek

  #219881 30-May-2009 16:56
Send private message

I'm trying to do something similar with a late model airport express. Am using an Orcon Homehub (Siemens SX763) on which I have internet connection - connected to Airport Express via ethernet cable. DHCP and NAT functions disabled on Siemens and enabled on Airport Express as I want the Apple NAT-PMP functions. I intend then to connect my iMac and Macbook via wireless network from Airport Express. =

However I've had no joy getting an internet connection into the Airport Express. I have also tried running the Siemens in bridge mode ("Bridge MER") - no joy here either. The Orcon connection is obviously PPPoA and when in bridge mode, the only selection I can see is PPPoE. It does give me some login options but no joy. I don't understand PPPoA vs PPPoE well enough to know if this bit's causing me trouble.

Any ideas? My main reason is to use NAT-PMP on the Airport Express to get Back To My Mac running.



Professional yak shaver
1599 posts

Uber Geek

Lifetime subscriber

  #221636 4-Jun-2009 14:55
Send private message

I have a Dynalink RTA1320 set to half-bridge mode with Orcon+ at home, connected to an Airport Extreme. In half-bridge mode, the username and password is set in the Dynalink, and the AE sees the connection as an Always On connection.

Works flawlessly, and this way I'm only doing one NAT for every packet, which speeds things up a little bit. Haven't used Back to my Mac with it, but for me VNC works fine (SSH as well).

"Roads? Where we're going, we don't need roads." - Doc Emmet Brown

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Withings launches three new devices to help monitor heart health from home
Posted 13-Feb-2020 20:05

Auckland start-up Yourcar matches new car buyers with dealerships
Posted 13-Feb-2020 18:05

School gardens go high tech to teach kids the importance of technology
Posted 13-Feb-2020 11:10

Malwarebytes finds Mac threats outpace Windows for the first time
Posted 13-Feb-2020 08:01

Amazon launches Echo Show 8 in Australia and New Zealand
Posted 8-Feb-2020 20:36

Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24

Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26

New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25

N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22

Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45

Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30

JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59

Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34

NZ Police releases public app
Posted 8-Jan-2020 11:43

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.