Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




15 posts

Geek


# 85043 12-Jun-2011 13:37
Send private message

Hi guys,

I've recently bought a new Sandy Bridge MacBook Pro, and Apple has started to use the 64-bit kernel as default. I found that my Telecom T-Stick (the ZTE MF626) doesn't work anymore on the new machine, and searched high and low for a solution. I'm rather disappointed that ZTE still hasn't released 64-bit drivers one year on, and unfortunately the various guides and solutions floating around no longer work because the URLs posted are out of date, and the download links have either expired or been removed due to legal reasons.

At the moment, when I plug in the T-Stick, Telecom's connection manager will start up, but doesn't recognise that there's a SIM card inserted, and therefore cannot connect to the 3G network. The LED on the stick lights up blue though. The T-Stick still works on another XP machine, and worked under Leopard on my old 2007 MacBook, so it's not a hardware fault.
ZTEUSBModem also doesn't show up under Network in System Preferences, so I can't even use OS X's dialer..

So I'm wondering, has anyone ever managed to get the T-Stick to work under 64-bit Snow Leopard? If so, would they be kind enough to post the kernel extensions they used? If there is no solution to be had, I guess I'll have to head back to a 32-bit kernel. But I'd rather stay with 64-bit, since it is the default from the factory...

Thanks in advance!

Edit: Forgot to post specs: Apple MBP 15" 2.0, running 10.6.7 (which is on the install disc, not updated post-install through Software Update).

Create new topic
1044 posts

Uber Geek

Trusted

  # 480442 12-Jun-2011 21:39
Send private message

Sirius: Hi guys,

I've recently bought a new Sandy Bridge MacBook Pro, and Apple has started to use the 64-bit kernel as default. I found that my Telecom T-Stick (the ZTE MF626) doesn't work anymore on the new machine, and searched high and low for a solution. I'm rather disappointed that ZTE still hasn't released 64-bit drivers one year on, and unfortunately the various guides and solutions floating around no longer work because the URLs posted are out of date, and the download links have either expired or been removed due to legal reasons.

At the moment, when I plug in the T-Stick, Telecom's connection manager will start up, but doesn't recognise that there's a SIM card inserted, and therefore cannot connect to the 3G network. The LED on the stick lights up blue though. The T-Stick still works on another XP machine, and worked under Leopard on my old 2007 MacBook, so it's not a hardware fault.
ZTEUSBModem also doesn't show up under Network in System Preferences, so I can't even use OS X's dialer..

So I'm wondering, has anyone ever managed to get the T-Stick to work under 64-bit Snow Leopard? If so, would they be kind enough to post the kernel extensions they used? If there is no solution to be had, I guess I'll have to head back to a 32-bit kernel. But I'd rather stay with 64-bit, since it is the default from the factory...

Thanks in advance!

Edit: Forgot to post specs: Apple MBP 15" 2.0, running 10.6.7 (which is on the install disc, not updated post-install through Software Update).


Not familiar with the ZTE MF626 so can't help with kext updates but booting in 32bit mode in SL is a reasonable workaround until you find a proper resolution. If you're not sure how, just hold down the numeric keys '3' and '2' when booting. Or if you'd like a pref pane that lets you reboot into 32 bit, try this.

If you already knew that, my apologies.

HTH.

Cheers,
R2D2







Galaxy S has gone to its new owner. HTC Sensation has gone to its new
owner. Galaxy S3 has gone to its new owner. Now using Galaxy Note 3. Skipping Note 4 I think...



15 posts

Geek


  # 480595 13-Jun-2011 12:38
Send private message

Thanks R2, I was aware of holding down 3-2 at start up, but the PrefPane would come in handy!

If other people know how to get 64-bit working, though, please let me know!

 
 
 
 


1448 posts

Uber Geek

Subscriber

  # 480825 14-Jun-2011 01:04
Send private message

Sirius: Thanks R2, I was aware of holding down 3-2 at start up, but the PrefPane would come in handy!

If other people know how to get 64-bit working, though, please let me know!


ZTE has to provide 64bit drivers which they don't - the only thing I can suggest is to get a Sierra Wireless card - they cost a little more but in terms of long term support you know that'll work in Mac OS X now and into the future. 




Laptop: MacBook Pro (15-inch, 2017)
Desktop: iMac (27-inch, 2017)
Smartphone: iPhone XS Max 256GB 'Space Grey'
Additional devices: Unifi Security Gateway, Unifi Switch, Unifi AP AC HD, Unifi Cloud Key, Apple Watch 4 44mm
Services: YouTube Premium, Wordpress, Skinny Mobile and Broadband

 


1075 posts

Uber Geek

Subscriber

  # 481381 15-Jun-2011 11:08
Send private message

Hi,

I believe you might have a couple of options:

Boot your mac into the 32Bit kernel (performance hit)
I believe you can still run apps in 32 Bit mode including preference pane stuff, right click get info on the app and one of the options at the bottom is run in 32 bit mode (this may be predicated on a 32bit kernel?).


http://www.zte.com.au/telstra/Product_Downloads/MF626_downloads.htm

The latest drivers I have found are here, I use the built in network preferences to dial).

This works fine on my white macbook, running 10.6.7 32bit kernel with 64bit apps.

I remember this was a big issue when SL came out (I was in the UK at the time)... none of the modem drivers would work with the apps.

Oh btw I use the mf627 (rebranded 3 mobile version).

Jon



15 posts

Geek


  # 481676 16-Jun-2011 00:50
Send private message

kawaii:
Guess I'll look into it.. but I got the T-Stick essentially for free on one of their promotions.. so not sure if I can swallow the full price of a Sierra :P

jonherries:
Looks like it can still only work on 32bit (according to the system requirements on that page).. guess 32bit is the answer for now!
Actually, the MF668 and 633 seem to support 64bit.. might give those a try and see if those drivers would work with the 626..

1075 posts

Uber Geek

Subscriber

  # 481696 16-Jun-2011 07:57
Send private message

It is only gonna cost you a couple of hours so you might as well.



15 posts

Geek


  # 483213 20-Jun-2011 14:56
Send private message

Tried the modem under 32-bit kernel mode, and it still wasn't working. I'm also getting a lot of repeated messages in the Console about Mac_SwapperDaemon (the daemon that unmounts the installer and launches the connection manager when you plug in the modem)... which I've solved (I think) by removing ZTE's kernel extensions, preference files, and the Mac_SwapperDaemon program, then deleting the boot/kext caches and reinstalling Telecom's connection manager from scratch. Think I messed up something while randomly installing all the drivers Sealed.

Going to put this 'project' on hold for now, and will try again when I have sorted out my backup system and second hard drive in the next few weeks.

Thanks for everyone's help! 

 
 
 
 


1075 posts

Uber Geek

Subscriber

  # 485356 24-Jun-2011 11:07
Send private message

You can just install the drivers and not the connection manager, which is where I had all my issues.

Just use the Network interface preference pane to to do the dialler, I seem to recall the swapper daemon being an issue I was facing as well. The only thing missing is a credit/data tracker which you can use a ios app or there is a connection traffic tracker for os x somewhere on the internet.

I am at work so not sure what the dialler string is but can check when I get home (I think I also saved the site that explained it).

Jon

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22


Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29


Catalyst Cloud becomes a Kubernetes Certified Service Provider (KCSP)
Posted 23-Aug-2019 08:21


New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01


Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46


Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.