Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




256 posts

Ultimate Geek
+1 received by user: 43


# 10723 6-Dec-2006 21:55
Send private message

Hi and thanks for any help.

I know Barf knows a little about this and maybe others. Here is my issue:



I am now using a Dynalink ADSL1320 Modem Router and have it configured to use the IP 10.1.1.1 with an IP range of 10.1.1.2 - 10.1.1.254

DHCP is on
NAT is on

This in turn sends an IP address of 10.1.1.11 to my Linksys BEFSR41v4 Router/Switch.
It is in Default mode

Status is:
Login Type: DHCP
Internet IP Address: 10.1.1.11
Subnet Mask: 255.255.255.0
Default Gateway: 10.1.1.1
Static DNS1: 10.1.1.1
Static DNS2: 0.0.0.0
Static DNS3: 0.0.0.0
MTU: 1500

DHCP is on
NAT is on

I have three computers on the network and all are taking IP's automatically.

All works fine in this config except I cannot use FTP. It hangs on list.

My server in the states returns this error:

[L] Listening on PORT: 1952, Waiting for connection.
[L] PORT 192,168,1,103,7,160
[L] 500 I won't open a connection to 10.1.1.11 (only to 121.72.129.12)
[L] List Error


I have tried the half bridge bridge mode and while it says connected I cannot connect to the internet.
I am on TCL and I am aware that the gateway 218.101.61.98 is on a different IP range than the WAN address 121.72.129.12 (dynamic)it gives out.(bizarre really).

Now all I want is to be able to connect to my FTP's.

Hope all this info is all you need to understand my network and the probblems.

Look forward to some help whuile I still have a little hair left!



View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
3539 posts

Uber Geek
+1 received by user: 125

Trusted

  # 54851 6-Dec-2006 22:00
Send private message

CJMchch,

Your current config. has two lots of NAT between you and the internet, which is never a good thing...

Is there any reason you cannot disable NAT on one or other of those devices?

The second NAT translation may be what is causing FTP to fail, or it could be something else, but you may be able to get around it using PASSIVE FTP Transfers.  I have found that worked through various firewalls where normal FTP failed.

Just my 2c worth, I hope it helps.

Cheers,
Grant.

643 posts

Ultimate Geek


  # 54866 6-Dec-2006 22:36

The easiest way to get your FTP working would be to disable the DHCP server in the Linksys and plug the dynalink into one of it's LAN ports (I assume it is plugged into the WAN port now?). Let me know if that helps please.

The best setup requires an ADSL modem which supports 'PPP half bridge' but I'm not sure if the RTA1320 does that.

Do you know if your Dynalink modem-router configured to use PPPoA or PPPoE?




Sniffing the glue holding the Internet together

 
 
 
 


643 posts

Ultimate Geek


  # 54868 6-Dec-2006 22:53

Just read the manual for your router, I'll paste the instructions for the half bridge mode - they call it PPPoA 'ip extension'
1. Start up your browser and type 192.168.1.1 as the address to enter this ADSL web-based
manager.
2. Go to Advanced - Internet - Connections. And click Add.
3. Type in the VCI and VPI value. Then click the Next button. eg:
VPI – 0
VCI – 100
4. On the Configure Internet Connection -Connection Type page, select the PPP over ATM
(PPPoA) then click the Next button.
5. In the WAN IP Settings page, select Obtain an IP address automatically, uncheck Enable
NAT box and check PPP IP extension then click Next.
6. In the PPP Username and Password page, enter the PPP username and password that you got
from your ISP. Select Dial on Demand and type in the number for inactivity timeout. The
default is 20. Or select Always on. Then click Next.
7. In the Configure LAN side Settings page, type in the IP address and subnet mask for your
LAN. And click Next. eg:
Primary IP address:192.168.1.1
Subnet Mask:255.255.255.0
8. Check the network information. Make sure the settings match the settings provided by ISP.
Click Finish.

Set your Linksys' WAN port to DHCP client mode and (re-)enable it's LAN DHCP server. Connect the Dynalink to the WAN port and your Internet IP will be assigned to that instead of an RFC1918 (LAN) address. This eliminates the double-NAT scenario nicely and make the Linksys your firewall/gateway but you'll probably still need to use passive FTP transfers as Grant suggested.

[edit :] re step 7 make sure that IP is on a different subnet (192.168.x) than your LAN




Sniffing the glue holding the Internet together

836 posts

Ultimate Geek

Trusted

  # 54871 6-Dec-2006 23:26
Send private message

The other alternative is to setup a DMZ to your second router from your ADSL router.

Whatever route you take you will need to use passive mode unless you setup a DMZ on the second router to a specific host ip you wish to use for FTP connections due, this is due to the nature of how FTP connections are initiated as the RFC for FTP was way before people thought of doing NAT. If Passive mode is not supported by the remote server then you will need to look at setting up a DMZ temporarily or permanently

For further information of Passive mode see http://slacksite.com/other/ftp.html

1828 posts

Uber Geek
+1 received by user: 215
Inactive user


# 54881 7-Dec-2006 04:20
Send private message

Why not just ditch the router and use an ethernet switch intead seeing as how the RTA1320 can serve upto 128 different addresses at a time this will eliminate the double nat and 3 way ips

643 posts

Ultimate Geek


  # 54891 7-Dec-2006 09:26

Athlonite: Why not just ditch the router and use an ethernet switch intead seeing as how the RTA1320 can serve upto 128 different addresses at a time this will eliminate the double nat and 3 way ips

this is equivalent to my first suggestion




Sniffing the glue holding the Internet together



256 posts

Ultimate Geek
+1 received by user: 43


  # 54964 7-Dec-2006 22:20
Send private message

Thanks for the great responses!

First up, it's a no go on the half bridge mode, I think the reason being my Linksys is looking for a gateway consistent with the IP but that is not the case seen as I am with TCL.

Applied the 'switch only' method by turning off DHCP on the Linksys and plugged the modem router into my LAN rather than the WAN port.

I have access to the internet but the FTP still hangs on LIST and reports from my server are the same, Won't connect to 10.1.1.11 will only connect to 121........(my WAN addy)

Not sure what I can do here. Frustrating to say the least

 
 
 
 


643 posts

Ultimate Geek


  # 54968 7-Dec-2006 23:30

which ftp client are you using?
i reccomend trying filezilla




Sniffing the glue holding the Internet together



256 posts

Ultimate Geek
+1 received by user: 43


  # 54970 8-Dec-2006 07:53
Send private message

I am using FlashFXP.

I'll give your suggestion a try tonight when I get home and will let you know.

Thanks

Ben

317 posts

Ultimate Geek

Trusted
Vend

  # 54992 8-Dec-2006 13:55
Send private message

Yeah TCL uses a crazy IP setup with the default gateway being on a different subnet to the ADSL IPs.
For some reason my setup 'just works' with half-bridge turned on on TCL (see here for setup instructions), but I understand some people have trouble.

You may be able to set up a manual route entry in your BEFSR41v4 that tells it how to get to the TCL default gateway (via the RTA1320). 

Otherwise yeah, forwarding the 1320's DHCP to the network might be the easiest option.

836 posts

Ultimate Geek

Trusted

  # 54997 8-Dec-2006 14:32
Send private message

With a PPP ADSL setup you are going to be assigned a /32 subnet anyhow so there is no way the gateway could be in the same subnet.

643 posts

Ultimate Geek


  # 55013 8-Dec-2006 15:44

Ben: For some reason my setup 'just works' with half-bridge turned on

it works because the modem's DHCP server sets your default gateway correctly. I don't think a manual route is really necessary. If it doesn't work it's not TCL's fault it would be a half bridge that doesn't hand out the correct default gateway.




Sniffing the glue holding the Internet together

Ben

317 posts

Ultimate Geek

Trusted
Vend

  # 55016 8-Dec-2006 16:08
Send private message

barf:
it works because the modem's DHCP server sets your default gateway correctly. I don't think a manual route is really necessary. If it doesn't work it's not TCL's fault it would be a half bridge that doesn't hand out the correct default gateway.


Negative.  I'm running half-bridge mode with NAT and DHCP turned off on the modem.
I'm randomly guessing that ARP is doing the trick somewhere?

643 posts

Ultimate Geek


  # 55020 8-Dec-2006 16:36

PPP half bridge uses DHCP. I wouldn't expect it to work with DHCP turned off.




Sniffing the glue holding the Internet together

Ben

317 posts

Ultimate Geek

Trusted
Vend

  # 55023 8-Dec-2006 16:56
Send private message

Hmmmm... I thought it duplicated the routers MAC addresses to the modem's outside interface and then blindly forwarded packets?

Although having said that, the modem router *does* get an IP addy from the modem prior to the PPP connection coming up, so the modem must be doing DHCP.  My bad.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Switch your broadband provider now - compare prices


Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18


E-scooter share scheme launches in Wellington
Posted 17-Jun-2019 12:34


Anyone can broadcast with Kordia Pop Up TV
Posted 13-Jun-2019 10:51


Volvo and Uber present production vehicle ready for self-driving
Posted 13-Jun-2019 10:47


100,000 customers connected to fibre broadband network through Enable
Posted 13-Jun-2019 10:35


5G uptake even faster than expected
Posted 12-Jun-2019 10:01


Xbox showcases 60 anticipated games
Posted 10-Jun-2019 20:24


Trend Micro Turns Public Hotspots into Secure Networks with WiFi Protection for Mobile Devices
Posted 5-Jun-2019 13:24


Bold UK spinoff for beauty software company Flossie
Posted 2-Jun-2019 14:10


Amazon Introduces Echo Show 5
Posted 1-Jun-2019 15:32


Epson launches new 4K Pro-UHD projector technology
Posted 1-Jun-2019 15:26


Lenovo and Qualcomm unveil first 5G PC called Project Limitless
Posted 28-May-2019 20:23


Intel introduces new 10th Gen Intel Core Processors and Project Athena
Posted 28-May-2019 19:28



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.