greetings all,

My Spark Technicolor TG582n modem showing some weirdness.

1. It does not ask for a password, even after a factory reset, on wireless or cable.

I tried to put in a new password but it asked for the old one, which I assumed to be the stock standard as given online by Spark. No go.

2. The firewall is disabled - annnnd, ok, weird again, just checked it, and now it no longer says that "details cannot be edited" but instead showing me the three standard options. Weirdness upon weirdness ... been disabled for months with options to configure greyed out and unconfigureable. 

More weirdness ... now it DOES ask for a password.

Sorry if this sounds like a nonevent, but am puzzled why the modem would let me in without a login and have firewall disabled, even after a factory reset. Then, after a few hours, suddenly allow me to change the firewall settings and require a login.

The firewall problem has been around for weeks, but the no login / login only today. Tried to get help from Spark but never got back to me. Maybe they just did. 

thanks,

jas

ps: sorry did not take screengrabs. shoulda.