Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

View this topic in a long page with up to 500 replies per page Create new topic
1 | ... | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 
100 posts

Master Geek

  # 2319565 18-Sep-2019 07:19
Send private message quote this post

@No4 The only difference between the settings you have listed and mine are that I'm using 1500/1492 MTU size instead of 1508/1500. I'm only running IPV4 so, as per the comments from @fe31nz above, it isn't an issue, however his comments suggest either should work on the Edgerouter. I'm getting full speed (950Mbps/450Mbps) from my fibre so pretty happy.




14 posts


  # 2320066 19-Sep-2019 07:56
One person supports this post
Send private message quote this post

Found the problem - it was more hardware related I think, although I did correct the location of the ipv6 firewall.


Turns out the ethernet cable to the old laptop (running Mint) was dodgy so it had connected via wireless instead. So very old laptop plus wireless at reasonable range was the issue for speedtest.  Once I changed the cable, speeds were 80/9 or so, compared to 100/18 for my standard windows 8 pc on the HG659 (I'm only on basic fibre which is 100/20).  I then tried my work laptop on the ERX/UAP Lite and got 100/19 wired and 80/18 wireless, so any limitations are not in the config.


On to the next step of commissioning - checking voip.  Almost there.


41 posts


  # 2327299 30-Sep-2019 20:39
Send private message quote this post

Hello friends,




I am having some (quite odd) problems with my ipsec/L2TP vpn on my ERX (firmware version 1.10).




I have been through literally every post on the topic on the Ubiquiti forums, and I'm wondering if I need to upgrade to 2.x firmware for this to work.




Firstly, the relevant part of my config:




ipsec {
     auto-firewall-nat-exclude enable
     ipsec-interfaces {
         interface eth0
     nat-networks {
         allowed-network {
     nat-traversal enable
 l2tp {
     remote-access {
         authentication {
             local-users {
                 username <redacted> {
                     password <redacted>
             mode local
         client-ip-pool {
         dns-servers {
         ipsec-settings {
             authentication {
                 mode pre-shared-secret
                 pre-shared-secret <redacted>
             ike-lifetime 3600
         mtu 1492




I am able to connect to the vpn from my Mac, inside my WLAN, when specifying outside-address to be my external ip (set via a cronjob, as is outside-nexthop).




I am unable to connect from my iphone inside my WLAN.




I am unable to connect when I replace outside-address with (This is the recommended solution from the Ubiquiti forums).




I am unable to connect using my dynamic dns (which resolves correctly with nslookup).




I have tried various combinations of specifying/removing nat-traversal, nat-networks, ipsec-interfaces, auto-firewall-nat-exclude.






Any suggestions at all, from anyone, or do I just have to try the 2.x firmware?




As always, many thanks for your help!



100 posts

Master Geek

  # 2328765 3-Oct-2019 09:04
Send private message quote this post



Your config looks pretty good based on my limited knowledge but you don't mention  updating your firewall rules as well to allow L2TP/IPSec traffic through? I found the article below and some of it's links quite useful when setting up something similar.



41 posts


  # 2331561 6-Oct-2019 21:00
Send private message quote this post

Hey, thanks for the link. That article is where I started my long trudge through the Ubiquiti forums.




Firewall should be fine, but I'll nuke it anyway and start from scratch.




It's a funny old problem.

739 posts

Ultimate Geek

  # 2333186 9-Oct-2019 09:02
Send private message quote this post

Bit of a basic question here sorry - setting up an ER-X for a Vodafone connection (will be bridged VDSL). Just sorting out firewall & want to setup upnp2 as well- should the WAN interface be set to eth0 or eth0.10?


I know on a pppoe connection with vlan10 the WAN interface needs to be set to pppoe0, but am not sure with a DHCP/IPoE connection. Thanks. 

1 | ... | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 
View this topic in a long page with up to 500 replies per page Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08

Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55

Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19

Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48

CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42

Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41

Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30

BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14

Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24

2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35

New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13

OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32

Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27

D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07

LG Electronics begins distributing the G8X THINQ
Posted 24-Oct-2019 10:58

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.