Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

333 posts

Ultimate Geek

# 223509 3-Oct-2017 10:29
Send private message



I got Vodafone FibreX put on and initially had trouble accessing overseas content via my Samsung SmartTV (BBC iplayer, ITV) after swapping over to my TP-Link Archer C7 router. It would usually take several attempts to successfully launch video via the iPlayer. When I swapped back to the Vodafone HG659 router the BBC iplayer worked well.


When I set up the Archer C7 router I downloaded a BETA firmware that would enable VLAN tagging ID values of 10. Without this the Archer C7 would not work with FibreX as the VLAN tagging ID values of the former firmware had a minimum of 16.


It seemed to me that this BETA firmware may have been the problem with poor perfomance. Some weeks went by and TP-Link released a new firmware for Australia & New Zealand.


My Archer C7 is hardware Version 2, and I tried the new firmware Archer C7_V2_160712_AU&NZ (Firmware Version 3.15.1 Build 16712 Rel.57168n)


Although I was successful in connecting the Archer C7 with The BETA firmware to Vodafone FibreX, I have not been able to connect to FibreX using Firmware 160712 (which is supposedly optimized for Fibre Optic and FibreX).


I have talked to Vodafone Tech support  and my settings sound correct to them.


As my FibreX account has a static ip, I have the following settings:


WAN Connection Type: Static IP


IP Address: 203.XXX.XXX.1 (Confirmed Correct by Vodafone)


Subnet Mask:


Default Gateway: same as IP Address


MTU Size (in bytes): 1500


Primary DNS:


Secondary DNS:


VLAN page


IGMP Proxy: Enable


Mode: NZ UFB


VLAN TAG for Internet Service: Enable


Internet VLAN ID: 10


Internet VLAN Pri: 0




I tried enabling and disabling IPv6 Support, but that made no difference: 0 packets received.


I'm hoping somebody out there has the Archer C7 on firmware 160712 working happily with Vodafone FibreX and tell me where I am going wrong.


Many thanks,







Create new topic

333 posts

Ultimate Geek

  # 1877081 4-Oct-2017 10:40
Send private message

I've made some progress with the Archer C7 and Vodafone FibreX, but I am perplexed and would like an explanation if some one out there has one.


The Archer C7, with WAN and VLAN correctly configured for Vodafone FibreX, does not receive any packets from the FibreX modem.


The FibreX Modem has two WAN ethernet ports. If I connect the Vodafone router to the second WAN port on the modem and then copy its Mac address to the WAN MAC address of the Archer C7, bingo, the Archer C7 gets an internet connection. If I turn off the Vodafone router I lose the Archer's internet connection.


I would like to have only the Archer router connected as the WiFi is far better, but it seems it will not work without the Vodafone router connected to the modem.


Anyway around this?





1375 posts

Uber Geek

  # 1877108 4-Oct-2017 11:04
Send private message

Is there is DHCP / automatic IP option on the Archer C7 instead of static IP?


333 posts

Ultimate Geek

  # 1877114 4-Oct-2017 11:09
Send private message

Problem solved. Even though I have a static IP with Vodafone I needed to select Dynamic IP in my router. Hope this helps someone else.

333 posts

Ultimate Geek

  # 1877196 4-Oct-2017 13:23
Send private message

yitz: Is there is DHCP / automatic IP option on the Archer C7 instead of static IP?


You were correct: Static Ip was the wrong choice. Thanks for your input.

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22

Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29

Catalyst Cloud becomes a Kubernetes Certified Service Provider (KCSP)
Posted 23-Aug-2019 08:21

New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01

Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46

Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29

Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41

Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26

University of Waikato launches space for esports
Posted 19-Aug-2019 20:20

D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14

Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47

Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41

Epson launches portable laser projector
Posted 12-Aug-2019 20:27

Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20

Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.