Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




10 posts

Wannabe Geek


#258580 10-Oct-2019 17:53
Send private message

Yesterday I tried to set up a pfsense box on my spark fibre connection (WAN as PPPoE on vlan 10). Everything else was disconnected except a linux laptop connected to the pfsense GUI (static IPv4 LAN). I could see my public IP address, ping Google's 8.8.8.8 etc. but from the laptop itself 8.8.8.8 was unreachable (laptop could ping its own ip address given by dhcp).

 

 

I gave up, shut down the pfsense router & returned to using the previous setup (Spark's HG659b). This morning I tried again, same problem, still couldn't figure it out. Then after an hour mucking around pinging & ponging & looking (but not changing) stuff in both pfsense gui & my laptop's terminal it all came right without rebooting or changing any settings. I reconnected my switch, wifi etc. & all seems well. But it bothers me that I have no idea what happened (maybe I'm blind & changed something inadvertently). I'm very much an amateur, but presumably PPPoE discovery & recognising the router's MAC address had already taken place, so why the delay? This was a pretty vanilla setup, firewall was default allowing stuff out originating on the LAN, DNS Server settings were as per the old router, DHCP was always enabled & there was only the laptop & pfsense router at my end. So my question is, for those who know much more than me, is this likely to be something at Spark's end that was so slow, or my pfsense box (its not virtualized, amd64, Intel Pro/1000 nic etc.)?

 

 

Without wishing to recreate whatever mess I was in, can anyone tell me what sort of steps I (or anyone else in a similar position) should have done to isolate the problem?

 


Create new topic
515 posts

Ultimate Geek


  #2335259 10-Oct-2019 23:18
Send private message

Presumably the pfSense box is able to do packet captures (using Wireshark?).  So I would just capture the packets and see what is happening.




10 posts

Wannabe Geek


  #2335331 11-Oct-2019 07:09
Send private message

Thanks, I didnt have Wireshark on the laptop at the time but pfsense has packet capture which I tried, As its a raw dump at my level of expertise I couldnt make much sense of what was happening. I think you've hit the nail on the head though, I should have downloaded the capture to wireshark to investigate further. I'm finding Hansteen's The Book of PF (its online but I'm too new to post a link) a good read. Also I found I was using time1.telecom.co.nz as my timeserver, which seems old. I switched this to nz.pool.ntp.org but I couldnt find reference on Spark's website as to which ntp servers customer's should use.

 
 
 
 


2995 posts

Uber Geek

Trusted
Lifetime subscriber

  #2335495 11-Oct-2019 12:14
Send private message

The time1.telecom.co.nz is configured in the Spark supplied HG659's to set the router time. Personally I wouldn't use them and just go to nz.pool.ntp.org.

 

In theory there should be nothing stopping you using pfsense to bring up the PPPoE session on VLAN10. I've done it many times on Linux and it should just work. You don't need a username and password for PPPoE but sometimes it helps the PPPoE client if you specify it "username" and "password" work fine.





and


'That VDSL Cat'
11899 posts

Uber Geek

Trusted
Spark
Subscriber

  #2335501 11-Oct-2019 12:38
Send private message

I'll grab you a screenshot from my pfsense box. we dont block it..





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Huawei introduces the P40 Series of Android-based smartphones
Posted 31-Mar-2020 17:03


Samsung Galaxy Z Flip now available for pre-order in New Zealand
Posted 31-Mar-2020 16:39


New online learning platform for kids stuck at home during COVID-19 lockdown
Posted 26-Mar-2020 21:35


New 5G Nokia smartphone unveiled as portfolio expands
Posted 26-Mar-2020 17:11


D-Link ANZ launches wireless AC1200 4G LTE router
Posted 26-Mar-2020 16:32


Ring introduces two new video doorbells and new pre-roll technology
Posted 17-Mar-2020 16:59


OPPO uncovers flagship Find X2 Pro smartphone
Posted 17-Mar-2020 16:54


D-Link COVR-2202 mesh Wi-Fi system now protected by McAfee
Posted 17-Mar-2020 16:00


Spark Sport opens its platform up to all New Zealanders at no charge
Posted 17-Mar-2020 10:04


Spark launches 5G Starter Fund
Posted 8-Mar-2020 19:19


TRENDnet launches high-performance WiFi Mesh Router System
Posted 5-Mar-2020 08:48


Sony boosts full-frame lens line-up with introduction of FE 20mm F1.8 G large-aperture ultra-wide-angle prime Lens
Posted 5-Mar-2020 08:44


Vector and Spark teamed up on smart metering initiative
Posted 5-Mar-2020 08:42


Schneider Electric launches new PDL Pro Series designed specifically for the commercial building market
Posted 5-Mar-2020 08:39


Kiwi app Pedigree DentaStix Studios uses pet images to counter impact of negative social media Content
Posted 5-Mar-2020 08:32



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.