Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


10 posts

Wannabe Geek


Topic # 401 9-Aug-2003 11:18
Send private message

Background:


I have a Belkin 54g router, a Cisco 350 (128bit) card and an Enterasys
(64bit) card all with the latest firmware; both run just fine at full
speed/good signal. These are being used in a couple of laptops daily, and also
work with my 5450 in a dual-pc sleeve. I have run WEP PSK-128 just fine
on the 5450 with the Cisco card, but normally use WEP PSK-64 to cater for
both.

However, the 5450 runs like a dog, and is almost unusable! Signal
strength is around 45% right next to the AP antenna! It is extremely
slow, I suspect it is running out of buffers or doing lots of retransmits.
If I turn WEP off, it is better, but I do not want to operate in this mode for
security reasons.


Solution:


The problem with the 5450 was related to the MTU size on the WLAN not
being defined in CE. I have searched other forums, and there are LOTS of
people having this kind of problem, with varying symptoms such as:


* WLAN slow/not working/dropping out

* WEP apparently not working

* DHCP problems

* browsing problems

* ActiveSync problems (over WLAN)

* iPAQ very slow, poor response to user input when WLAN on


What all of these have in common is that IP is being used, and the heavy
fragmentation/ retransmission on the WLAN loses packets, causes protocol
time-outs, overloads the processor and so kills overall performance.
According to MSDN, the CE driver is supposed to supply a suitable default
MTU size, but this one obviously does not get it right. My fix is to
explicitly put one there:


Regedit: HKLM/Comm/vnetusba1/Parms/Tcpip

New Key(dword): MTU

Value: 160 (decimal)


This seems to completely fix the problem for me; my 5450 now runs and
behaves like I expected from the start. Browsing actually works now.


A sample performance check from toast.net shows 170Kb/s download over the
WLAN, which is about what I would expect for the device. If I turn on
power management for the wireless card, throughput drops by around 20%
(but the battery probably lasts longer).


For reference, I have all the latest ROM & firmware, my versions are:


CE 3.0 ROM 1.11.19 ENG 05/24/03


WLAN firmware 0.100.5.39 driver 3.2.2.84 software 4.0.1.36



This is the FIRST TIME it has ever worked properly for me since I had the
5450! I am sure this is not an isolated problem, give it a try and you
will probably notice an improvement.


The MTU size of 160 seems to be optimal in my case. Some tweaking may
produce a slight improvement, but 128 works and going up to 224 kills it,
so I am happy with that for the moment. There are other IP-related
parameters which may help general performance, but MTU is the one that
stops it.


Enjoy!


Create new topic


10 posts

Wannabe Geek


Reply # 1032 12-Aug-2003 11:58
Send private message

Just for clarification, the fix I posted is intended as a work-around only, to specifically address a problem with the HP WLAN driver in the 5450 under CE 2002.


The MTU work-around makes the 5450 usable, but I do not regard this as an optimal solution -- HP needs to fix it properly.


I understand that the problem does not exist in the WM2003 driver , so maybe that is going to be the ultimate solution. Don't hold your breath :-(


1 post

Wannabe Geek


Reply # 2978 22-Jan-2004 05:31
Send private message

This fix worked for me - I have Ipaq 5550 and Belkin Adsl Gateway Router. I have not yet experimented with other MTUs and since the performance with this setting at MTU=160 is very good I do not see much value in trying. Adding this value has turned browsing from a joke into a reality.

Thanks

1 post

Wannabe Geek


Reply # 6862 26-Jun-2004 07:17
Send private message

I have these same problems but I am not familiar with editing the regestry. I would be very grateful if you can go through the procedure step by step.

Many thanks

Dave UK

1 post

Wannabe Geek


Reply # 11368 29-Dec-2004 11:02
Send private message

Try this :)
Download on site http://www.bitsinside.com/pocket_pc_registry_editor.php
registry editor ...
And go open regedit :
HKEY_LOCAL_MACHINE -> Comm -> vnetusba1 -> Parms -> Tcpip
Now in the left corner use Edit -> New Value -> DWORD and
Value Name: MTU
Value: 160

Thats all.
Enjoy


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.