Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


16 posts


#90274 18-Sep-2011 15:45
Send private message

Hi all, been struggling with this for a few months now, wondering if anyone could suggest what might be causing this?   I've got about 300GB to get off it, and at 100Mb it's slow going!

The issue is my Elitebook 8530p (approx 2 yrs old) will not connect at gigabit speed. Running Win7 x64, latest windows updates, latest bios, latest nic drivers from intel (tried from hp site too).

The nic is an Intel 82567LM (Gigabit Network Connection).

Whenever it's set to Auto Negotiate on a gigabit network, it connects at 100/Full.

If I set it to Gigabit/Full it reports no network cable connected.

My desktop (atheros card) and another laptop (Intel 82579LM) using the same cable and same switch port connect at gigabit with no trouble.

Cables I'm testing with are cat5e. Have tried direct connection between laptops, as well as with the switch, symptoms remain the same.

I have the intel proset features installed and run the diag tests on the properties of the nic, comes back with no issues.

Checked all the advanced properties compared the laptop which works fine - all the same.

I have checked through the bios in case there was a limit set there - can't see anything.

I do have vmware workstation installed, which of course hooks into the network stack but I can't think that it would be the cause.

One strange thing I have come across is that if I go to safe mode with networking, I can't get to the properties of the nic - device manager freezes when I try.

My next step is to reinstall windows, or can someone suggest a (linux?) OS on a cd that I can boot and easily check how the card is behaving?

Create new topic
1990 posts

Uber Geek


  #523241 19-Sep-2011 20:42
Send private message

Are you using the same cable that tested ok on the other gigabit links? It does sound like the NIC might be running the gigabit stuff properly, or not connecting all 4 pairs. Or perhaps its set to a different frame size?

Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^

22999 posts

Uber Geek


  #523246 19-Sep-2011 20:51
Send private message

Have seen this before on a friends computer. Not sure if it was software or hardware because it broke before we bothered to troubleshoot it.

One thing to watch out is that some gig nics will work at gig on a crossover cable, some will only do 100 meg. Check you have no crossover cables around the place.




16 posts


  #523299 19-Sep-2011 22:51
Send private message

Thanks guys. Yes using the same cables that tested ok on other gb nics.

I suspect it's not connecting on all 4 pairs. The pins all look straight, but maybe they're dirty. I'll need to try cleaning them.

Definitely no crossovers in the mix (although I tried with and without one - I suspect my crossover is only 100Mb so it's not a viable test anyway)

If it's not dirty pins, the card could be half dead? - is that a possiblity?


16 posts


  #523766 20-Sep-2011 21:14
Send private message

Gave the pins a clean with IPA - still the same.

I guess it's half dead? Are there any network port diagnosis tools readily available that could tell me if it's connecting with some pairs and not others?

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Withings launches three new devices to help monitor heart health from home
Posted 13-Feb-2020 20:05

Auckland start-up Yourcar matches new car buyers with dealerships
Posted 13-Feb-2020 18:05

School gardens go high tech to teach kids the importance of technology
Posted 13-Feb-2020 11:10

Malwarebytes finds Mac threats outpace Windows for the first time
Posted 13-Feb-2020 08:01

Amazon launches Echo Show 8 in Australia and New Zealand
Posted 8-Feb-2020 20:36

Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24

Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26

New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25

N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22

Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45

Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30

JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59

Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34

NZ Police releases public app
Posted 8-Jan-2020 11:43

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.