Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




235 posts

Master Geek


#96846 4-Feb-2012 21:37
Send private message

I don't understand how that iMessage works.
when i was using the 021 Voda number i managed to use iMessage that able to verifying my 021 number.

sometime i took the sim out & changed to 027 XT number but can't use iMessage, it try to verify the 021 voda number not the 027 number. Strange... I did turn off the iMessage before taking out the 021 sim. 
Also tried Reset the Network Settings but not work still the same problem.
 
hope you guys can teach me if you manage to get iMessage work using different networks. 

using 4s n ios 5.0.1.       

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
418 posts

Ultimate Geek

Trusted

  #577373 4-Feb-2012 22:50
Send private message

Hi - AFAIK you should be able to swap sim cards & still use iMessage - it uses mobile data to send the message, not cellular data. There are reports of iMessage 'sticking' to phones after the sim cards have been swapped - I believe it might help to 'toggle' the iMessage button on & off & it should then activate iMessage on the phone.




Cheers,
Mike

Photographer/Videographer clickmedia.nz


20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577379 4-Feb-2012 23:46
Send private message

Is 3G working? Not that obvious if you are home and not making/receiving a call and are on wifi.

Clearly, nothing is wrong as such as you can use iMessage on any network, but the link between the carrier info (built into iOS5), and the actual sim and network in use is broken for you.

When you setup an iOS5 device, or upgrade to iOS5, the carrier update is delivered via iTunes I believe. Try syncing to see if that helps. Or sync with no sim, then sync with the sim to push the carrier update.

 
 
 
 


3211 posts

Uber Geek

Trusted

  #577380 4-Feb-2012 23:50
Send private message

As I understand it each time you change the sim it sends a text to a UK number and bonds imessage to that number, unsure what happens to your other number when its sim is not in use



235 posts

Master Geek


  #577382 5-Feb-2012 00:15
Send private message

clicknz: Hi - AFAIK you should be able to swap sim cards & still use iMessage - it uses mobile data to send the message, not cellular data. There are reports of iMessage 'sticking' to phones after the sim cards have been swapped - I believe it might help to 'toggle' the iMessage button on & off & it should then activate iMessage on the phone.


yup had tried insert the 027 sim
Settings > Message > turn off/on iMessage.. still wont verify the 027 and the 021 number was on Received at verifying....

also tried Settings > Message > Turn Off iMessage
General > Reset > Reset Network Settings
Turn off iPhone > Turn on
Settings > Message > Turn on iMessage
still not recognize the 027 number, and the 021 number still there.


tdgeek: Is 3G working? Not that obvious if you are home and not making/receiving a call and are on wifi. Clearly, nothing is wrong as such as you can use iMessage on any network, but the link between the carrier info (built into iOS5), and the actual sim and network in use is broken for you. When you setup an iOS5 device, or upgrade to iOS5, the carrier update is delivered via iTunes I believe. Try syncing to see if that helps. Or sync with no sim, then sync with the sim to push the carrier update.


Yes the 027 - 3G is working, able to use safari, surf the web.
already done the carrier update when insert the 027 sim.    
also tried the sync.. still not working.

DjShadow: As I understand it each time you change the sim it sends a text to a UK number and bonds imessage to that number, unsure what happens to your other number when its sim is not in use


well i used the 021 during day n 027 at night lol so clearly both working.
just the iMessage for 027 is not working can't activate.. keep on trying to verify the 021 number when had the 027 sim on.    
   

   
     
  

20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577385 5-Feb-2012 01:39
Send private message

Two suggestions via Google

Oddly I notice that imessage is not working on my iPad2. Not tried since got 4S, and have JB'ed 4S too.

1. Make sure that your Apple ID is in iMessage settings in the Recieve At setting

2.
How to resolve this problem:

Turn off and on (restart) your iOS device (press and hold the Sleep/Wake button for a few seconds, then slide the slider.)

If restarting doesn?t fix it:

It has been reported that changing your DNS settings fixes this issue. To change DNS servers, follow these instructions for iOS devices (iPhone, iPod touch, iPad):
01.Tap Settings
02.Tap Wi-Fi on the left-hand side
03.Tap the blue arrow next to your current Wi-Fi network
04.Tap the ?DNS? field and enter the DNS servers; 8.8.8.8 (Google?s Public DNS).

Change the DNS back tothe routers gateway after its working.

20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577389 5-Feb-2012 02:03
Send private message

Bit of info from me, with my issue, which may give you some clues.


Ok, I tried to fix my iPad2 iMessage issue, which is, messages sent on my 4S to my iPad are green, so sent as text. Not recieved by iPad2 as that cannot recieve texts. messages sent from iPad2 to 4S are blue, but not recieved by iPad2.

Now, this all worked fine, to the point that each time i turned the iPad2 on, I get all these iMessages.

Points that have changed are:

1. I bought an iPad2 which I restored from iPad1, it worked then as I got all my iMessages there as well.
2. I upgraded iPad2 ro iOS5, and I notices that the iPad2 settings and iTunes do not show the iPad2 cell number. I am sure this is part of the issue.
3. Facetime works the same as iMessage. I cannot Facetime my iPad2 as "Facetime is not available for Tonys iPad2" I can Facetime my 4S, presumably as my 4S has a cell number.
4. I jailbreaked the 4S recently, iPad2 is not JB'ed. Unsure if issue existed before then 

The key issue for me is that the iOS5 iPad2 has no cell number in Settings or iTunes so I am sure this is the issue. I will try to test the iPad2 to another users iPhone later



235 posts

Master Geek


  #577422 5-Feb-2012 08:39
Send private message

tdgeek: Two suggestions via Google

Oddly I notice that imessage is not working on my iPad2. Not tried since got 4S, and have JB'ed 4S too.

1. Make sure that your Apple ID is in iMessage settings in the Recieve At setting

2.
How to resolve this problem:

Turn off and on (restart) your iOS device (press and hold the Sleep/Wake button for a few seconds, then slide the slider.)

If restarting doesn?t fix it:

It has been reported that changing your DNS settings fixes this issue. To change DNS servers, follow these instructions for iOS devices (iPhone, iPod touch, iPad):
01.Tap Settings
02.Tap Wi-Fi on the left-hand side
03.Tap the blue arrow next to your current Wi-Fi network
04.Tap the ?DNS? field and enter the DNS servers; 8.8.8.8 (Google?s Public DNS).

Change the DNS back tothe routers gateway after its working.



Yes it's my Apple ID.
did google n found this solution too but still isn't working.
seem to be a lot people having the same issue with FaceTime & iMessage.
this is how it looks like when on Telecom...lol
 
  

 
 
 
 


20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577451 5-Feb-2012 10:08
Send private message

Do you have just on iDevice on iOS5?

20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577453 5-Feb-2012 10:13
Send private message

In iMessage settings is the Recieve At and Caller ID both the Telecom 027 number?

20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577462 5-Feb-2012 10:28
Send private message

Another

To change the defult phone number in iMessage, you need to:


Insert the new sim.
Go to Settings > Messages>Turn off iMessage.
Go to General > Reset > Reset Network Settings.
Once the iPhone is open,
Go to Settings > Messages>Turn ON iMessage.
This will recognize the new sim and have it verified.



235 posts

Master Geek


  #577668 5-Feb-2012 21:52
Send private message

tdgeek: In iMessage settings is the Recieve At and Caller ID both the Telecom 027 number?


No if im on the Voda 021 number it is just the email & the 021 number. i post some screenshot.

tdgeek: Another To change the defult phone number in iMessage, you need to: Insert the new sim. Go to Settings > Messages>Turn off iMessage. Go to General > Reset > Reset Network Settings. Once the iPhone is open, Go to Settings > Messages>Turn ON iMessage. This will recognize the new sim and have it verified.


dont it too still not work.

This is how voda 021 number sim look like Received 2 Addressess (Email & the 021 number)



& this is what Telecom 027 number sim when i turn on the iMessage  look like





anyway no jailbreak before.

20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #577789 6-Feb-2012 10:42
Send private message

The email addresses are the same, or different?

If the same, add a different email address and see how that goes. This is to update the association betwwen the email address and the one cell number.



235 posts

Master Geek


  #577833 6-Feb-2012 13:01
Send private message

tdgeek: The email addresses are the same, or different?

If the same, add a different email address and see how that goes. This is to update the association betwwen the email address and the one cell number.



ok, done add a different email... same still trying to verify that 021 number while im on 027...

ive done everything from restore the iphone n set up as new using the 027 sim.. still in iMessage.. trying verifying the 021...       



235 posts

Master Geek


  #579481 9-Feb-2012 22:04
Send private message

I wonder does the Apple ID have to be 1 ID for 1 number only?? is that why i can't get activated?
anyone had one Apple ID tried with two different numbers before? 

20563 posts

Uber Geek

Trusted
Lifetime subscriber

  #579499 9-Feb-2012 22:41
Send private message

Your one Apple ID can and should cover all of your iDevices. For me, the Apple ID is my Xtra email address. I have issues with my 4S and iPad2 as the iPad2 has my Xtra email address as my Receive At, so when my 4S Facetimes or iMessages the iPad2, its busy. Makes sense as the 4S has to use the email address to communicate to the iPad2 exactly as if you called your phone from your phone, its busy.

This was never an issue before iOS5 as the iPad2 had the cell number, so I need to use a different email address in the iPad2. Nothing to do with Apple ID, just that my Recieve At happens to be the same email address.

I can only see that in your iPhone Messages setting, that the Receive At has to have the correct phone number, I assume yours has the 027 and you cannot change that as I assume it is from the sim. Under Caller ID, you have the phone number and email address, mine has the +64 27 xxx xxxx ticked.

I am unsure what the issue is for you.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

OPPO Find X2 Lite brings flagship features to mid-range 5G smartphone
Posted 29-May-2020 12:52


Sony introduces the digital camera ZV-1 for content creators
Posted 27-May-2020 12:47


Samsung Announces 2020 QLED TV Range
Posted 20-May-2020 16:29


D-Link A/NZ launches AI-Powered body temperature measuring system
Posted 20-May-2020 16:22


NortonLifeLock Online Banking Protection now available for New Zealand banks
Posted 20-May-2020 16:14


SD Express delivers new gigabyte speeds for SD memory cards
Posted 20-May-2020 15:00


D-Link A/NZ launches Nuclias cloud managed network solution hosted in Australia
Posted 11-May-2020 17:53


Logitech introduces new video streaming solution for home studios
Posted 11-May-2020 17:48


Next generation Volvo cars to be powered by Luminar LiDAR technology
Posted 7-May-2020 13:56


D-Link A/NZ launches Wi-Fi Certified EasyMesh system
Posted 7-May-2020 13:51


Spark teams up with Microsoft to bring Xbox All Access to New Zealand
Posted 7-May-2020 13:01


Microsoft plans to establish its first datacenter region in New Zealand
Posted 6-May-2020 11:35


Genesis School-gen has joined forces with Mind Lab Kids
Posted 1-May-2020 12:53


Malwarebytes expands into privacy with fast, frictionless VPN
Posted 30-Apr-2020 16:06


Kordia to donate TV airtime on Channel 200 to community groups
Posted 30-Apr-2020 16:00



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.