Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




227 posts

Master Geek


# 133541 25-Oct-2013 17:21

I just noticed that there's a new firmware upgrade for the T1020 on the DishTV website.

firmware v1.31 17 October 2013

Has anyone done the upgrade and if so, how did it go and what's new?

I have the 4am s/w upgrade set to "on" in the System Settings menu but it hasn't upgraded via OTA and when I clicked the "s/w upgrade via OTA" button in the Installation menu, nothing happens.

Create new topic
4438 posts

Uber Geek

Trusted
Subscriber

  # 921901 25-Oct-2013 22:28
Send private message

My S7070r prompted me to run a firmware update a couple of weeks ago and since then it has been plagued with problems, the worst being where it freezes up and continues to play the ongoing broadcast but refuses to respond to any remote control or front panel inputs.

I emailed Dish TV a couple of nights ago but they are yet to respond.

If your unit is working okay at the moment then I would recommend avoiding taking a gamble on the upgrade, but if you do go ahead then I would be interested to know whether it causes you the same problems.



227 posts

Master Geek


  # 921906 25-Oct-2013 22:47

alasta: My S7070r prompted me to run a firmware update a couple of weeks ago and since then it has been plagued with problems, the worst being where it freezes up and continues to play the ongoing broadcast but refuses to respond to any remote control or front panel inputs.

I emailed Dish TV a couple of nights ago but they are yet to respond.

If your unit is working okay at the moment then I would recommend avoiding taking a gamble on the upgrade, but if you do go ahead then I would be interested to know whether it causes you the same problems.


Thanks, yeah I think I'll leave it for now. My box performs pretty well with just the odd glitch.

I signed up via the DishTV website to be notified when new firmware was released but heard nothing from them - strange!

 
 
 
 




227 posts

Master Geek


  # 923436 29-Oct-2013 10:43

Okay heard back from DishTV and the firmware upgrade has to do with how the unit handles the ext hdd.

I was sort of hoping it had more to do with how the unit handles ad skipping..... hah! I'm kidding!



227 posts

Master Geek


  # 923703 29-Oct-2013 17:57

alasta: but if you do go ahead then I would be interested to know whether it causes you the same problems.


Ended up flashing the firmware this afternoon and so far so good. Visually nothing much has changed, they've just added their contact details in the main menu screen under the heading Technical Support.

The guide seems to appear a lot quicker when you press the button, we used to have to press the button 3 or 4 times but now it appears almost instantaneously.

Playback of recorded programs seems smoother but who knows! might be imagining it. So no crashes or anything out of the ordinary thus far, fingers crossed.



4438 posts

Uber Geek

Trusted
Subscriber

  # 923855 29-Oct-2013 22:25
Send private message

Thanks for the feedback. I'm still having problems with mine locking up, and tonight it suddenly decided to check for firmware updates (there were none) while I was in the middle of watching the news which I'm sure is not supposed to happen as it's designed to do this in the early hours of the morning when the unit is not in use.

I've just tried a factory reset to see if that helps. If not then I'll have to call Dish TV as they still haven't responded to the email that I sent several days ago.



227 posts

Master Geek


  # 923893 29-Oct-2013 23:42

I think you get a quicker reply from DishTV when you ask a question via their website.

If you go to the S7070r page and click on the "Data" tab there's a button labeled "Ask a question about this product"

8894 posts

Uber Geek


  # 929144 7-Nov-2013 22:00
Send private message

alasta: Thanks for the feedback. I'm still having problems with mine locking up, and tonight it suddenly decided to check for firmware updates (there were none) while I was in the middle of watching the news which I'm sure is not supposed to happen as it's designed to do this in the early hours of the morning when the unit is not in use.

I've just tried a factory reset to see if that helps. If not then I'll have to call Dish TV as they still haven't responded to the email that I sent several days ago.


Any further news on this?
I read elsewhere that they released a faulty firmware via OTA.
Problem with my s7070r is that after firmware update, it was sometimes locking-up/losing signal (when another box was working fine and with good signal from same dish/LNB via splitter - swap things over to be sure that it's not the signal/tv/cables - it is the DishTV box kaput).
Now the damned thing has lost video out - the image will flash on screen for about a half second - then it just goes black.  So the advice  on DishTV site about a "hard reset" to fix the other problems isn't much use - as I can't see the flaming menu!



 
 
 
 


4438 posts

Uber Geek

Trusted
Subscriber

  # 929198 8-Nov-2013 00:03
Send private message

Fred99: Any further news on this?
I read elsewhere that they released a faulty firmware via OTA.
Problem with my s7070r is that after firmware update, it was sometimes locking-up/losing signal (when another box was working fine and with good signal from same dish/LNB via splitter - swap things over to be sure that it's not the signal/tv/cables - it is the DishTV box kaput).
Now the damned thing has lost video out - the image will flash on screen for about a half second - then it just goes black.  So the advice  on DishTV site about a "hard reset" to fix the other problems isn't much use - as I can't see the flaming menu!


Eventually they came back to me and said that they were not aware of any problems with the firmware and they provided a procedure for an EPROM reset. This turned out to be ineffective at resolving the problem.

Last night I tried reloading the firmware via USB. I'm hoping that the OTA firmware update I did last month might have run amuck due to a signal glitch or something and a reload via USB might fix it. I haven't used the device since last night and the problem was highly intermittent so it will be a few days before I will know whether this has fixed it. If not then I'll go back to Dish TV again and see what the next options are.

It sounds like your problem is worse than mine. The fault with my device seems to be limited to random lockups where the remote and front panel buttons fail to respond, and also a strange behaviour where every night the standby LED goes out and the external hard drive powers up.

655 posts

Ultimate Geek


  # 929222 8-Nov-2013 07:46
Send private message

running clean as with no issues here :)

8894 posts

Uber Geek


  # 929263 8-Nov-2013 09:58
Send private message

alasta:

It sounds like your problem is worse than mine. The fault with my device seems to be limited to random lockups where the remote and front panel buttons fail to respond, and also a strange behaviour where every night the standby LED goes out and the external hard drive powers up.


I forgot to try S video or component video out - which worked, so I was able to do a factory reset.  Firmware version is A3U_1C_0125 (9 Oct 2013) which seems to be the latest.  I did a check on availability of an OTA u/g, and nothing available.
The HDMI out seems to be borked - it could be coincidence that it happened at the same time as the firmware related problems.



4438 posts

Uber Geek

Trusted
Subscriber

  # 929281 8-Nov-2013 10:43
Send private message

Fred99:
alasta:

It sounds like your problem is worse than mine. The fault with my device seems to be limited to random lockups where the remote and front panel buttons fail to respond, and also a strange behaviour where every night the standby LED goes out and the external hard drive powers up.


I forgot to try S video or component video out - which worked, so I was able to do a factory reset.  Firmware version is A3U_1C_0125 (9 Oct 2013) which seems to be the latest.  I did a check on availability of an OTA u/g, and nothing available.
The HDMI out seems to be borked - it could be coincidence that it happened at the same time as the firmware related problems.


I was also thinking that maybe I hard a hardware fault it's a coincidence that my problems started after the firmware update! Maybe it's a case of the firmware update triggering a hardware failure.

Even if you have the latest firmware I would still recommend doing a reload via USB. As I said above I can't yet confirm that this is effective, but it's worth a try.

58 posts

Master Geek


# 929871 9-Nov-2013 10:25
Send private message

alasta: My S7070r prompted me to run a firmware update a couple of weeks ago and since then it has been plagued with problems, the worst being where it freezes up and continues to play the ongoing broadcast but refuses to respond to any remote control or front panel inputs. 
 

It's not just your S7070r acting up since the firmware upgrade. Ours is doing exactly the same things - refusing to respond to any remote control input sometimes, but playing the current channel fine. I suspect it's something to do with initialising an external hard drive, as the problems don't seem to occur once it's ready to display recorded programmes. We've also had the OTA update pop up at odd times of the day.

I know that even before the firmware update, our S7070r would get a bit flaky once there were more than about 300 recorded programmes on the hard drive. I went to archive any keepers on to our PC and discovered that some previous firmware update had changed the file format of recorded programmes so that they would no longer play through VLC player (I think Freeview might have demanded this change).

I eventually found that the open-source Avidemux will restore the missing time codes to recorded videos - hope that is helpful to someone else.

Mark


8894 posts

Uber Geek


  # 934899 16-Nov-2013 14:18
Send private message

I finally got around to re-installing firmware via USB on my S7070R.
Good news and bad news - the HDMI output now works, so there must have been some glitch with the way the OTA update loaded. Bad news is that the damned thing locks up and loses signal worse than ever. Another 1/2 hour wasted by getting my signal strength meter out, checking the dish alignment, checking that the other sat box works (it does), swapping cables from the splitter etc to make sure the problem wasn't me.
I should just take the thing outside and belt the blardy thing a few times with a 10lb sledgehammer, and buy another one "some decent brand". Question then - what is a "decent brand".

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Samsung Galaxy Fold now available in New Zealand
Posted 6-Dec-2019 00:01


NZ company oDocs awarded US$ 100,000 Dubai World Expo grant
Posted 5-Dec-2019 16:00


New Zealand Rugby Selects AWS-Powered Analytics for Deeper Game Insights
Posted 5-Dec-2019 11:33


IMAGR and Farro bring checkout-less supermarket shopping to New Zealand
Posted 5-Dec-2019 09:07


Wellington Airport becomes first 5G connected airport in the country
Posted 3-Dec-2019 08:42


MetService secures Al Jazeera as a new weather client
Posted 28-Nov-2019 09:40


NZ a top 10 connected nation with stage one of ultra-fast broadband roll-out completed
Posted 24-Nov-2019 14:15


Microsoft Translator understands te reo Māori
Posted 22-Nov-2019 08:46


Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.