Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




510 posts

Ultimate Geek


#151879 8-Sep-2014 17:08
Send private message

Not sure if this sits in this cat. but here goes.

Just playing with a Raspberry Pi as a web server.
Raspbian , lighttpd , MySQL, php etc installed and working fine.

I cant access it via the web. I believe I have done all the checks I can think of, but no joy.
I can access the web server across the internal network and its fully functional.

I have a dynamic dns service via no-ip that forwards to the dynamic IP using DNS Host (A) . I have also tried port 80 forwarding to 8080

It is then accessed via Router, port forwarded to internal static IP address and Port 80

I have tested that the Port 80 is open (Im assuming for that internal IP?) and that it works with both dynamic dns service name and with the IP address of my router.
All tests here suggest the IP and port are accessible.

I have tested the lighttpd on 80 and 8080, both with the same result.

Any words of wisdom?





Create new topic
15682 posts

Uber Geek

Trusted
Subscriber

  #1124558 8-Sep-2014 17:24
Send private message

Port 80 will need to be forwarded from your router's public IP to the R Pi.



510 posts

Ultimate Geek


  #1124633 8-Sep-2014 19:02
Send private message

I think I have?


 
 
 
 


582 posts

Ultimate Geek

Subscriber

  #1124676 8-Sep-2014 20:37
Send private message

Try setting up the lighttpd server to listen to something like port 81 or some other port, just not port 80. Then forward that port.
Some routers just don't like, or have problems, port forwarding port 80.



510 posts

Ultimate Geek


  #1125119 9-Sep-2014 15:50
Send private message

Unfortunately no.....
I thought it would be relatively easy, but although internet port tools show its open, its not happening

Using either port 80/81, the tool shows its open. When the pi is turned off, it shows as blocked (or unreachable)
It leads me to believe its a pi issue.

Obviously when the pi is working, I can still access it with the local IP, so it is serving the pages.

375 posts

Ultimate Geek


  #1125168 9-Sep-2014 16:30
Send private message

What is server.bind set to?



510 posts

Ultimate Geek


  #1125173 9-Sep-2014 16:49
Send private message

Sorry for my newbness - how do I check that?

375 posts

Ultimate Geek


  #1125191 9-Sep-2014 17:11
Send private message

Should be in /etc/lighttpd/lighttpd.conf

 
 
 
 




510 posts

Ultimate Geek


  #1125248 9-Sep-2014 19:05
Send private message

Theres nothing in there - what should I be trying?

375 posts

Ultimate Geek


  #1125331 9-Sep-2014 20:25
Send private message

Hmm, if it was empty I would have assumed it would be available on all interfaces at port 3000...



510 posts

Ultimate Geek


  #1125335 9-Sep-2014 20:31
Send private message

Trying Apache now as well, but similar issues. Arrggh....

582 posts

Ultimate Geek

Subscriber

  #1125343 9-Sep-2014 21:00
Send private message

Does Raspbian have a firewall?
If so is it set to only allow access from local network?

375 posts

Ultimate Geek


  #1125353 9-Sep-2014 21:20
Send private message

Do you have any other OSes around that you could temporarily test port 80 redirects to? e.g. SimpleServer:WWW on Windows.



510 posts

Ultimate Geek


  #1125563 10-Sep-2014 09:01
Send private message

Right. It seems I cant access it from behind the same router. If I use 3G, I get the site up and running.
So yes it is working, but means Ill need to test it on localhost.....



Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Withings launches three new devices to help monitor heart health from home
Posted 13-Feb-2020 20:05


Auckland start-up Yourcar matches new car buyers with dealerships
Posted 13-Feb-2020 18:05


School gardens go high tech to teach kids the importance of technology
Posted 13-Feb-2020 11:10


Malwarebytes finds Mac threats outpace Windows for the first time
Posted 13-Feb-2020 08:01


Amazon launches Echo Show 8 in Australia and New Zealand
Posted 8-Feb-2020 20:36


Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24


Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26


New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25


N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22


Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42


Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.