Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


chimera

448 posts

Ultimate Geek


#259750 19-Oct-2019 15:54
Send private message

I have an Ender 5 and run it with Octoprint (web GUI via Raspberry Pi) 

 

I've added a relay to the printer, which sits between the PSU and the mainboard. There is a plugin to Octoprint called 'PSU control' which allows turning the printer on and off via a GPIO pin.  I had to build a small circuit board with transistor to get this going consistently (as per this: https://gpailler.github.io/2018-03-02-octoprint-psucontrol/) but anyhow, it all works ok.

 

As well as feeding the main board, I also have the relay feeding a buck converter, dropping the voltage to 5V which the output then runs to some LED lights on the printer (so when the printer turns on, the lights turn on, printer off, turns lights off)  Fairly straight forward.

 

However, the issue I have is the USB connection (that sits between RPi and mainboard) is back feeding voltage to the relay and causing the LED lights to get about ~3V, so when turning the printer off, the LED lights get dimmer but don't actually turn off.  I have tested putting a diode (IN5822) between the relay and the mainboard. This fixes the issue, however I'm concerned about the voltage drop over the diode will effect the mainboard (goes from 24V to about 23.4V)

 

Do you think this 0.6V drop would cause an issue with the mainboard (being "under voltage") Is there any other solution that could work better??? (I have also tested cutting the + wire in USB cable between Rpi and printer, but this does not resolve - in fact, from Octoprint I can't connect too it with this wire cut)

 

 





 

 


Create new topic
richms
26750 posts

Uber Geek

Trusted
Subscriber

  #2340685 19-Oct-2019 17:55
Send private message

Have you tried a data only USB cable to stop the backfeed? My old ultimaker needed one because the USB power would keep some of it alive and the lights on when powered off. I made one with 2 USB breakouts and only wiring the ground, D+ and D- between them. Otherwise carefully slice open a USB cable and cut the power wire.





Richard rich.ms

 
 
 

Trade NZ and US shares and funds with Sharesies (affiliate link).
Rust
90 posts

Master Geek

ID Verified

  #2340728 19-Oct-2019 18:01
Send private message

Could you isolate the mainboard and LED circuits from each other using a double-pole relay, or second relay?


frankv
5668 posts

Uber Geek

Lifetime subscriber

  #2340754 19-Oct-2019 19:10
Send private message

chimera:

 

I have tested putting a diode (IN5822) between the relay and the mainboard. This fixes the issue, however I'm concerned about the voltage drop over the diode will effect the mainboard (goes from 24V to about 23.4V)

 

Do you think this 0.6V drop would cause an issue with the mainboard (being "under voltage") Is there any other solution that could work better???

 

 

No, it won't have any effect. The 24V is converted to 5V (or 3.3V) for the actual controller logic supply. If you want to be really picky, there will be a slight (probably unnoticeable) increase in heating time, imperceptibly slower fan speeds, and a slight reduction in torque on the steppers. If you're running PID heater control, it's probably worth recalibrating that.

 

If you're worried, maybe you can run your LEDs directly from your RPi. Use a RPi GPIO pin to a relay (or a MOSFET or transistor) to switch the 5V supply from the RPi to the LEDs. Assuming the 5V supply to your RPi has enough current to also run the LEDs.

 

 




chimera

448 posts

Ultimate Geek


  #2341297 21-Oct-2019 11:58
Send private message

frankv:

 

chimera:

 

I have tested putting a diode (IN5822) between the relay and the mainboard. This fixes the issue, however I'm concerned about the voltage drop over the diode will effect the mainboard (goes from 24V to about 23.4V)

 

Do you think this 0.6V drop would cause an issue with the mainboard (being "under voltage") Is there any other solution that could work better???

 

 

No, it won't have any effect. The 24V is converted to 5V (or 3.3V) for the actual controller logic supply. If you want to be really picky, there will be a slight (probably unnoticeable) increase in heating time, imperceptibly slower fan speeds, and a slight reduction in torque on the steppers. If you're running PID heater control, it's probably worth recalibrating that.

 

If you're worried, maybe you can run your LEDs directly from your RPi. Use a RPi GPIO pin to a relay (or a MOSFET or transistor) to switch the 5V supply from the RPi to the LEDs. Assuming the 5V supply to your RPi has enough current to also run the LEDs.

 

 

Doesn't seem to like it much at all with the diode in place.  Whenever heating the nozzle and bed, the printer turns off or halts with error. Tried doing PID tuning, as per https://reprap.org/wiki/PID_Tuning but either it didn't work, or I got totally lost. 

 

Going to remove the diode and test again. May have to revert to using MOSFET via RPi GPIO method. 

 

EDIT: Ooops, my bad - maybe the fact that my soldering job is crap... will use alternate connection method me thinks... :-)





 

 


chimera

448 posts

Ultimate Geek


  #2341298 21-Oct-2019 11:59
Send private message

richms:

 

Have you tried a data only USB cable to stop the backfeed? My old ultimaker needed one because the USB power would keep some of it alive and the lights on when powered off. I made one with 2 USB breakouts and only wiring the ground, D+ and D- between them. Otherwise carefully slice open a USB cable and cut the power wire.

 

 

Thanks Rich, will try this approach too...





 

 


Decal
211 posts

Master Geek

ID Verified

  #2341339 21-Oct-2019 12:43
Send private message

Isnt there a jumper on the ender motherboard that you can remove to stop it taking power from the usb port?


chimera

448 posts

Ultimate Geek


  #2341454 21-Oct-2019 17:19
Send private message

Decal:

 

Isnt there a jumper on the ender motherboard that you can remove to stop it taking power from the usb port?

 

 

Not that I can see. Only pins are at the top for flashing a bootloader/firmware.

 

 

 





 

 


Create new topic





News and reviews »

One New Zealand Extends 3G Switch-off Date
Posted 11-Apr-2024 08:56


Amazon Echo Hub Review
Posted 10-Apr-2024 18:57


Epson Launches New Versatile A4 Desktop Scanners
Posted 10-Apr-2024 15:31


Motorola Mobility Launches New Android Phones in New Zealand
Posted 10-Apr-2024 14:59


Logitech G Unveils the PRO X 60 Gaming Keyboard
Posted 9-Apr-2024 19:01


Logitech Unveils Signature Slim Keyboard and Combo
Posted 9-Apr-2024 13:33


ExpressVPN Launches Aircove Go Portable Router With Built-in VPN
Posted 26-Mar-2024 21:25


Shure MoveMic Review
Posted 25-Mar-2024 12:47


reMarkable 2 Launches at JB Hi-Fi New Zealand
Posted 20-Mar-2024 08:36


Samsung Galaxy S24 Ultra review
Posted 19-Mar-2024 11:37


Google Nest Wifi Pro Review
Posted 16-Mar-2024 11:28


Samsung Galaxy A55 5G and Galaxy A35 5G
Posted 12-Mar-2024 12:41


Cricut EasyPress Mini Zen Blue launches at Spotlight New Zealand
Posted 12-Mar-2024 12:32


Logitech Introduces MX Brio Webcam
Posted 12-Mar-2024 12:24


HP Unveils Broadest Consumer Portfolio of AI-Enhanced Laptops
Posted 3-Mar-2024 18:09









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.







Backblaze unlimited backup