Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


59 posts

Master Geek


Topic # 160013 20-Dec-2014 07:14
Send private message

I'm in the unfortunate position where I'll need to run the OpenTV & Freesat collections seperately as my FP3 dual (OpenTV & FreeSat) collection ended with error 13.
I need clarification of the Release Notes 4.2.txt.

Request 1:
It says that...

 

"...so either the OpenTV data will have the correct area/region or the FreeSat data will but not both."

The only way that I can set the area and region (for my Freesat collection - Tried setting my OpenTV collection Country to "--Undefined--" but wasn't allowed to save it) is to actually set the Country to undefined. i.e. There is no option in area or reqion to select "undefined".
Is it okay to do this? I seem to be retrieving EPG data but haven't tested uploading into MediaPortal yet. (...but have just noticed that I'm getting TV Series Lookup errors for ITV but I'll report on those later)

i.e. My config is as follows...

Collection 1: This is for Freesat and has Country=Area=Region="--Undefined--"
Output to file called TVGuideFreesat.xml

Collection 2: This is for OpenTV and has Country="United Kingdom", Area="England" & Region="BBC England - ITV East and Midlands"
Output to file called TVGuideOpenTV.xml
Merge with Freesat collection file TVGuideFreesat.xml

Request 2: My other query is on the value of Area in my OpenTV collection. It's currently set to "England" but noticed that optional values also include "England HD". Does it make any difference which one I use?

Thanks

Create new topic

SJB

1165 posts

Uber Geek
+1 received by user: 276

Trusted
Lifetime subscriber

  Reply # 1200936 20-Dec-2014 08:31
Send private message

FreeSat doesn't need a country so undefined is fine.

OpenTV has different Huffman translation tables depending on the country so that's why a country selection is mandatory.

I'd assume HD was the one to choose in case there were any HD only channels that you can receive. I just tried collections of both and the HD version produced one more channel.



59 posts

Master Geek


  Reply # 1200943 20-Dec-2014 08:45
Send private message

Thanks SJB.
Looks like my EPG collections and xfer into MP are okay. I'll confirm if the TV Series Lookup errors re-occure.
Regards, Rob

SJB

1165 posts

Uber Geek
+1 received by user: 276

Trusted
Lifetime subscriber

  Reply # 1200991 20-Dec-2014 11:05
Send private message

You will see a few intermittent internet errors with lookups.

I think they are down to the servers the databases use so there is no fix possible from my end. Ignore them.

SJB

1165 posts

Uber Geek
+1 received by user: 276

Trusted
Lifetime subscriber

  Reply # 1201199 20-Dec-2014 19:03
Send private message

BTW V4.2 FP3 should be able to do Sky and FreeSat in a single run.

If it doesn't post the log.



59 posts

Master Geek


  Reply # 1201330 21-Dec-2014 06:27
Send private message

I re-ran the combined (single run) for OpenTV & FreeSat at about 1600hrs this afternoon.
The first run ran successfully (exit code 0) but didn't have MediaPortal running.
Re-ran with same config data (but with MP running) and it failed with exit code 13
Re-ran again with MP still running and it completed successfully with exit code 0.
...so no idea what's causing these inconsistent results. Initially, I thought it could be a problem with MP using one of the 2 TV channels but can't consistently reproduce  this scenario. I've attached a link to the log to see if you have any ideas as to what's causing this issue.

The other query I have is the difference in the size of xml files generated by combined (single run) vs those generated by seperated runs. I've provided links to all the files but would appreciate an explanation as to what's happening so that I can make an informed choice as to whether to stick with the seperate or single runs. For now, I'll stay with the seperate runs to avoid the exit code 13 problem, but I'll have 2 config files to maintain. Files...
TVGuideCombined.xml is 5600kb (Combined run for OpenTV & FreeSat)
TVGuideFreesat.xml is 5600kb (Run 1 of 2 for seperate run)
TVGuide.xml is 8656kb (Run 2 of 2 for seperate run - merged with run 1 file).
Let me know if any problems with above file links.
Thanks

SJB

1165 posts

Uber Geek
+1 received by user: 276

Trusted
Lifetime subscriber

  Reply # 1207738 3-Jan-2015 17:21
Send private message

I wonder if your intermittent results are caused by MP taking control of the tuner EPGC is using.

The TBS tuner is one of those that allows programs to just acquire and start using a tuner even when it is use by another program. That might explain why the log shows EPGC successfully getting the station data but then not getting the EPG data.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.