Hi all,

After some advice.

I am helping my local school rollout BYOD for a couple of classes. We've had a great range of devices, most of which have worked seamlessly on the network.... The Chromebooks being the only exception.

Bit of background on the network configuration:

We have five VLANs configured on a Cisco 3560G switch, acting as the hub for the network. All the edge switches connect to this and it handles all the VLAN tagging and routing.

VLAN10 - Fixed devices and existing Wireless devices (
VLAN15 - Old IP Range ( - This will disappear in time
VLAN20 - New Servers and printers (
VLAN30 - New Staff wireless devices ( - Not currently in use
VLAN40 - New Student wireless devices ( - Not currently in use
VLAN50 - New Guest wireless devices ( - Not currently in use

We are in the middle of a upgrade so currently we are only using VLAN 10 and 15. The AD server sits in the VLAN15 network and handles DHCP, DNS etc. There is no security on any of the VLANs so they can communicate between them happily.

We have VLAN'd the devices so in the very near future we can keep the student devices away from the staff and also apply different rules on the soon to be installed firewall.

So now the issue...

When we connect devices (iPads, OS X, Win 7 & 8) to the wireless (VLAN10) they get the correct IP from the DHCP server (in VLAN15) and can browse the Internet all fine... Apart from the Chromebooks.

They get the correct IP Address and I can ping them from a laptop in the same VLAN... However they can't get any further than the default gateway of the VLAN, in this case So no DNS and they can't see the internet router. We have tried setting the IP Address manually and still can't get anything past the gateway!! And to make things stranger they were working fine last week and there has been no changes to the base configuration on the Cisco.

We have reset the DNS cache as this seems to be the biggest issue I have found on Google but this hasn't made any difference.

Does anyone have any suggestions on where to start? Does the Chrome OS support VLANs?

Really hit a brick wall...