Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




5 posts

Wannabe Geek


Topic # 240870 30-Sep-2018 19:26
Send private message quote this post

Hi All,

 

Does anyone knows how to configure a Cisco 867VAE to my Skinny Broadband VDSL2 - i have  managed to have my vdsl connection but i cannot see any internet pages through it, any help would be appreciated?

 

 

 

Thanks

 

Barry

 

 

 

Here is the running config going on in my router:

 

c860vae-advsecurityk9-mz.157-3.M2.bin

 

 

R1-C867VAE#show running-config
Building configuration...

 

Current configuration : 4151 bytes
!
version 15.7
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1-C867VAE
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$0VER$cRREqm1C6s8bxyxv64IJS/
!
no aaa new-model
wan mode dsl
clock timezone GMT 12 0
!
!
!
ip dhcp excluded-address 1.1.1.1
!
ip dhcp pool BB
import all
network 1.1.1.0 255.255.255.0
default-router 1.1.1.1
dns-server 1.1.1.1
lease 0 2
!
ip dhcp pool ccp-pool
import all
default-router 1.1.1.1
lease 0 2
!
!
!
ip domain name mydomain.com
ip cef
no ipv6 cef
!
!
flow record nbar-appmon
match ipv4 source address
match ipv4 destination address
match application name
collect interface output
collect counter bytes
collect counter packets
collect timestamp absolute first
collect timestamp absolute last
!
!
flow monitor application-mon
cache timeout active 60
record nbar-appmon
!
parameter-map type inspect global
max-incomplete low 18000
max-incomplete high 20000
nbar-classify
!
!
!
!
!
!
!
!
!
!
!
!
object-group network Others_dst_net
any
!
object-group network Others_src_net
any
!
object-group service Others_svc
ip
!
object-group network Web_dst_net
any
!
object-group network Web_src_net
any
!
object-group service Web_svc
ip
!
object-group network local_cws_net
!
object-group network local_lan_subnets
1.1.1.0 255.255.255.0
!
object-group network vpn_remote_subnets
any
!
username Admin password 7 12090404011C03162E
!
!
controller VDSL 0
!
!
class-map type inspect match-all INTERNAL_DOMAIN_FILTER
class-map type inspect match-any Others_app
match protocol https
match protocol smtp
match protocol pop3
match protocol imap
match protocol sip
match protocol ftp
match protocol dns
match protocol icmp
class-map type inspect match-any Web_app
match protocol http
class-map type inspect match-all Others
match class-map Others_app
match access-group name Others_acl
class-map type inspect match-all Web
match class-map Web_app
match access-group name Web_acl
!
policy-map type inspect LAN-WAN-POLICY
class type inspect Web
inspect
class type inspect Others
inspect
class class-default
drop log
!
zone security LAN
zone security WAN
zone security VPN
zone security DMZ
zone-pair security LAN-WAN source LAN destination WAN
service-policy type inspect LAN-WAN-POLICY
!
!
!
!
!
crypto isakmp policy 1
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
pvc 0/100
pppoe-client dial-pool-number 1
!
!
interface Ethernet0
no ip address
zone-member security DMZ
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
ip tcp adjust-mss 1412
shutdown
duplex auto
speed auto
!
interface Vlan1
ip address 1.1.1.1 255.255.255.0
ip nbar protocol-discovery
ip flow monitor application-mon input
ip flow ingress
ip flow egress
zone-member security LAN
ip tcp adjust-mss 1412
load-interval 30
!
interface Dialer0
no ip address
!
interface Dialer1
ip address negotiated
ip mtu 1452
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
dialer-group 1
ppp mtu adaptive
ppp authentication chap pap callin
ppp chap hostname ppp
ppp chap password 7 06575D72181B5F
ppp pap sent-username ppp password 7 00554155500E5D
!
ip forward-protocol nd
ip http server
ip http upload enable path flash:
ip http upload overwrite
no ip http secure-server
!
!
ip dns server
!
ip access-list extended Others_acl
permit object-group Others_svc object-group Others_src_net object-group Others_dst_net
ip access-list extended Web_acl
permit object-group Web_svc object-group Web_src_net object-group Web_dst_net
ip access-list extended nat-list
permit ip object-group local_lan_subnets any
deny ip any any
!
dialer-list 1 protocol ip permit
!
access-list 23 permit 1.1.1.0 0.0.0.255
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input none
!
scheduler allocate 60000 1000
!
end

 

 

 

 

 

 

 

 


Filter this topic showing only the reply marked as answer Create new topic
'That VDSL Cat'
9092 posts

Uber Geek
+1 received by user: 1994

Trusted
Spark
Subscriber

  Reply # 2098961 30-Sep-2018 22:03
2 people support this post
Send private message quote this post

been ages since i've read a csico conf, looks like your missing the correct vlan (10) and not binding the correct transport (PTM)

 

 

 

do note, on skinny your on your own.

 

Skinny only support the hg659, all support should be carried out with that device.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




5 posts

Wannabe Geek


  Reply # 2098963 30-Sep-2018 22:10
Send private message quote this post

As you can see i have vdsl connection:

 

 

 

Not worried about Skinny's support :), i want to have this as my main vdsl router due to security.

 

 

 


R1-C867VAE>show controllers vdsL 0
Controller VDSL 0 is UP

 

Daemon Status: NA

 

XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xB1AD
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0xB1AD
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: GMK193801HW 867VAE- 15.7(3)M
Serial Number Far: AA1318FE15R-11
Modem Version Near: 15.7(3)M
Modem Version Far: 0xB1AD

 

Modem Status: TC Sync (Showtime!)

 

DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2) Profile 17a
TC Mode: PTM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running

 

Full inits: 1
Failed full inits: 0
Short inits: 0
Failed short inits: 0

 

Firmware Source File Name
-------- ------ ----------
VDSL embedded N/A

 

Modem FW Version: 25c
Modem PHY Version: A2pv6C039t.d25c
Trellis: ON ON
SRA: disabled disabled
SRA count: 0 0
Bit swap: enabled enabled
Bit swap count: 18 2
Line Attenuation: 22.3 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 15.0 dB 6.1 dB
Attainable Rate: 41771 kbits/s 21836 kbits/s
Actual Power: 14.5 dBm 8.2 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 17.1 39.8 N/A 7.4 31.4 47.8 N/A
Signal Attenuation(dB): N/A N/A N/A 0.0 0.0 0.0 N/A
Noise Margin(dB): N/A N/A N/A N/A N/A N/A N/A
Total FECC: 0 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 1198 1198
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0

 


DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 35190 0 21836
SRA Previous Speed: 0 0 0 0
Previous Speed: 0 0 0 0
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0.00 8.00 0.00 0.00
Actual INP: 0.00 0.01 0.00 0.00

 

Training Log : Stopped
Training Log Filename : flash:vdsllog.bin

 

 

 

 


 
 
 
 


'That VDSL Cat'
9092 posts

Uber Geek
+1 received by user: 1994

Trusted
Spark
Subscriber

  Reply # 2099058 1-Oct-2018 00:32
Send private message quote this post

You have missed the actual details in my post, i recognize you have an active sync.

 

Check your using the correct vlan and PTM on the dsl interface. 





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


Mr Snotty
8089 posts

Uber Geek
+1 received by user: 4057

Moderator
Trusted
Lifetime subscriber

  Reply # 2099060 1-Oct-2018 00:56
One person supports this post
Send private message quote this post

Also don't use 1.1.1.1 (see here: https://1.1.1.1)

 

Instead, use 192.168.1.0/24 or a private addressing range: https://en.wikipedia.org/wiki/Private_network 







5 posts

Wannabe Geek


  Reply # 2100328 2-Oct-2018 20:19
Send private message quote this post

it is an internal ip address you should be able to use anything you like.

 

A

 

B

 


2096 posts

Uber Geek
+1 received by user: 358

Lifetime subscriber

  Reply # 2100330 2-Oct-2018 20:32
2 people support this post
Send private message quote this post

IETF says otherwise, and the address is neither A, B or C.

 

interface Ethernet0.10
encapsulation dot1Q 10
pppoe-client dial-pool-number 1

 

A complete example http://pingbin.com/2014/09/cisco-887va-m-vdsl2-pppoe-configuration/


'That VDSL Cat'
9092 posts

Uber Geek
+1 received by user: 1994

Trusted
Spark
Subscriber

  Reply # 2100334 2-Oct-2018 20:41
Send private message quote this post

barrynz:

 

it is an internal ip address you should be able to use anything you like.

 

 

Unfortunately, it's this sort of action that ends up with providers getting questions like X site doesn't load for me! fix it it's all your fault.

 

Ends up being the ip range the customer is using as it's not intended for Internal network usage.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


27287 posts

Uber Geek
+1 received by user: 6721

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 2100336 2-Oct-2018 20:47
Send private message quote this post

barrynz:

 

it is an internal ip address you should be able to use anything you like.

 

A

 

B

 

 

 

In correct answer.

 

Just look at Cisco who decided to use 1.1.1.1 interally on their WLC's for management and the massive implications this is now causing since they used an IP address they should have never used.

 

RFC1918 exists for a reason, and using anything else is just plain dumb. It's not if it will cause you a headache, it's when.

 

 

 

 

 

 


2096 posts

Uber Geek
+1 received by user: 358

Lifetime subscriber

  Reply # 2100340 2-Oct-2018 20:51
One person supports this post
Send private message quote this post

hio77:

 

Unfortunately, it's this sort of action that ends up with providers getting questions like X site doesn't load for me! fix it it's all your fault.

 

Ends up being the ip range the customer is using as it's not intended for Internal network usage.

 

 

Reminds me of someone who had a static address of 192.168.1.x/8 on their PC.


5199 posts

Uber Geek
+1 received by user: 1691


  Reply # 2100341 2-Oct-2018 20:52
Send private message quote this post

barrynz: [snip]

 

it is an internal ip address you should be able to use anything you like.]

 

 

Not if you want to connect it to the publicly routable internet.

 

https://www.iana.org/assignments/iana-ipv4-special-registry/iana-ipv4-special-registry.xhtml

 

Use something that is Private Use.

 

Suggest you stick with the Skinny supplied HG659 if IP address space is new to you.




5 posts

Wannabe Geek


Reply # 2101854 4-Oct-2018 22:45
Send private message quote this post

Just wanted to give you a massive thank youuuuu you are a Genius, thanks a lot, i got it working finally, however i need to hone it a bit, and i had to play with ethernet 0 interface and ethernet 0.10 until i made it operating, but your help was a massive help, thanks heaps.

 

Beauty i got my cisco router flying :).




5 posts

Wannabe Geek


  Reply # 2101858 4-Oct-2018 22:54
Send private message quote this post

Thank you all for sharing your expertise on my issues.

 

 


Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.