Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




83 posts

Master Geek


#265494 24-Jan-2020 11:49

We have a bore servicing outdoor taps/showers and cisterns at a beach house.  The old pump was replaced in 2018 with this:

 

 

It was working fine but has developed a fault where the pump runs for several minutes (much longer than it would normally take to fill the pressure vessel to the cutoff pressure).  The controller would then switch the pump off and the "fault" indication on the controller would come on.  Normal cistern/tap use would then empty the pressure tank but the controller would remain off.  Cycling the power resets the controller and it runs for one more cycle.

 

I have had a plumber looking at it.  There is water in the bore (the bore is about 4m deep, with a foot valve). We suspected the controller, so he swapped it out with another one but the behavior is the same!  Does anyone have any experience with this configuration?

 

 

 


Create new topic
310 posts

Ultimate Geek

Subscriber

  #2405757 24-Jan-2020 12:09
Send private message

Hi

 

Not familiar with the pump or controller.

 

 

 

Did the plumber check the pressure in the ballast tank, i.e they have a charge pressure of air in a bladder to absorb the differential in pressure. if the air charge has bled out,  you can't compress water. and this could be triggering the fault condition as the pressure will spike when the chamber is full of water, as opposed to slowly building as the air is compressed and displaced with water. 

 

 

 

When you turn the tap on after the pump trips does it run for a while and pressure drop off or is it more immediate (this would show state of the ballast tank)

 

 

 

Other causes relate to the motor health but if runs, and sounds normal, short of getting an electrician to check the current draw there not really serviceable.

 

 

 

I would look for a list of fault conditions on the controller if you can find a manual, 

 

 

 

Just some things to check that I would look for, if it was mine. 

 

 

 

Edit:

 

Just checked a tank that size I had lying around, On its sticker, it talks of a factory precharge on my 18L tank that is 28psi, 

 

Your label should have similar specs and there is normally an air valve on the top under the unscrewable plastic cover to recharge. 

 

 




83 posts

Master Geek


  #2405779 24-Jan-2020 12:38

Hi, Thanks for responding.

 

The pressure tank has charge.  It didn't in the early days so I'm pretty familiar with the behaviour when there is no air in the bladder.  Likewise, the foot valve seems OK.  If he unhooks the feed to the house and replaces it with a few meters of alkathene pipe, the flow of water is strong and free from splutter, etc.  The valve on the suction side shows no signs of leaking.

 

The controller is of Chinese origin.  You can find dozens of them with various badging around - e.g.: https://www.indiamart.com/proddetail/automatic-water-pump-controller-10931842991.html.  Chances of a meaningful datasheet are low, I think.

 

 


 
 
 
 


310 posts

Ultimate Geek

Subscriber

  #2405794 24-Jan-2020 13:00
Send private message

It has to be the controller, I found some pdfs on amazon on installation and faults, not of them describe a fault and the pump not starting there all about the pump not stopping.  It appears the controllers are factory set for pressure.

 

However what are the chances of the 2nd being faulty, They appear to have no motor diagnosis so it shouldn't be the motor.

 

 

 

It is odd that you mention the pump runs for longer before it stops, 

 

which could mean it's not detecting the shutdown pressure. and then faulting

 

 

 

The controller looks like the weakest link, 

 

https://images-na.ssl-images-amazon.com/images/I/91YdR2ALATL.pdf

 

https://images-na.ssl-images-amazon.com/images/I/81vUwEFPzfL.pdf

 

 

 

 

 

 

 

 

 

 

 

 


203 posts

Master Geek


  #2405798 24-Jan-2020 13:12
Send private message

Agree with  @JeremyNzl - the 2nd controller is faulty. No disrespect to your plumber, but it could be worth at least a phone call to a pump serviceman. He/she could be aware of any known issues with these (where a plumber may not).




83 posts

Master Geek


  #2406167 24-Jan-2020 17:18

Done a bit more research.  Found a few more instances of a datasheet but they all seem to be the same or close to those links provided by @JeremyNzl.  I found this video of someone troubleshooting a similar problem: https://www.youtube.com/watch?v=Fr9yh074hdc, and then a follow-up at https://www.youtube.com/watch?v=Ur34ceBAN3Y where he solves the problem, which appears to be a capacitor (likely a counterfeit one, I would guess) undergoing a significant change in value.  A few comments from others who also found replacing this capacitor fixed the issue.

 

Finally, there is this: https://www.youtube.com/watch?v=fjqezPeai0Y, a 30-minute treatment of the PCB and what it does.  Probably quite informative if you speak Italian.  The auto-translations provide a bit of humour.

 

And finally finally, a lengthy thread:  (in Dutch, but translates quite well) which is easier to follow than the Italian.

 

So my fallback is going to be to get the plumber to install a valve between the bore pump plumbing and rainwater pump plumbing (pressure sides) so that I can use rainwater to service the loos until I can repair the controller.  I won't bother with a warranty replacement for two reasons:

 

  • The supplier tends to play hardball and insist on everything being returned to them so that they can assess for themselves which bit is at fault.
  • A replacement controller will likely suffer from the same problem, seeing as it is designed in, and all.

 

 

 

 

 


466 posts

Ultimate Geek

Subscriber

  #2406504 25-Jan-2020 11:22
Send private message

It sounds like the pump pressure isn't high enough to operate the pressure switch.

 

First thing is to look at the pump curve and check the stall pressure (the pressure at zero flow). The links you gave to the controller say that this has to be at least 2.3 bar (230 kPa, 34 psi, 23m), otherwise it won't turn off.

 

If the pump curve suggests it's OK (or you can't find the curve) then you need physically test the pump. But you need a pressure gauge. Disconnect the discharge pipe and put the pressure gauge it's place. Run the pump BREIFLY at no flow and read the pressure on the gauge. If the pump pressure is low then you need to repair the pump. 

 

If it's OK then the controller isn't working the way it should.

 

A problem with the pneumatic tank will not prevent the pump switching off.





McLean


3890 posts

Uber Geek

Trusted

  #2406637 25-Jan-2020 14:18
Send private message

What about a faulty pressure switch, or is that part of the controller. Sorry don't have time look at the attached diagrams.




Sony Xperia X running Sailfish OS. https://sailfishos.org The true independent open source mobile OS 
Samsung Galaxy Tab S3
Nokia N1
Dell Inspiron 14z i5


 
 
 
 


87 posts

Master Geek


  #2406830 25-Jan-2020 20:10
Send private message

Could try disconnecting the pressure tank and run as a straight controller setup

 

The company i use for water pumps dont recommend using controllers on pressure tanks better to use a standard pressure switch.

 

I did try a tank on my controller never had tripping problems but pressure was hopeless.


Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.