Kanuka7: Has anyone managed to get Netflix working on Apple TV with Orcon's Global Mode? Any tips?


Netflix works well on my mac. On the Apple TV I changed to the US iTunes Store, and I get the Netflix app appearing on the home screen, so that part is good. But the issue is that when I go into netflix on ATV and login using my netflix account it just sits there on 'Accessing Netflix' forever. It never loads the content. I know the netflix account is ok because: 
 
1. I use it on my mac on the same home wifi
2. If I use the wrong netflix password on the apple tv it will come back straight away saying the password is wrong. But with the correct user/password it just loads forever.

Weirdly, on the first Netflix screen you can sign up for a free trial. I tried that with a new email address, and after supplying a new email & password I got straight in to Netflix. But when I exited and went in again to login with the same new details I got the endless 'Accessing Netflix' message.


...I've tried restarting the ATV and a factory reset. I've tried switching back to the NZ iTunes store then switching back to the US. I also just for fun tried using a non-dhcp ip and google's dns servers on the ATV. I've set my netflix to low quality.

Tips appreciated! 


Best tto start a new thread as this one has a very specific date and problem, neither of which relate to your question, and so you're unlikely to get the responses you need.

For reference, my ATV works fine and is streaming cartoons now as I type, but that helps you not at all as I use dns4me and am on a vodafone ads line...

Try copy paste this into the Orcon global mode thread and you'll link to all the others who are in your boat :)