Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




98 posts

Master Geek
+1 received by user: 5


# 208267 3-Feb-2017 21:11
Send private message

 

 

I cant access the web server becasue the Huawei hg659 is intercepting it.  It is set in the DMZ (weird how it uses mac not ip)

 

 

 

There is a thing called ACL but if I turn of HTTP: in there I cant access  the router web config pages.  And still cant view pages on my web server.

 

 

 

However  the web server is accessible for people outside my LAN.  Just not for us here using the lan.

 

 

 

How do I turn off the web site blocking from the lan?


Create new topic
1358 posts

Uber Geek
+1 received by user: 319


  # 1715155 3-Feb-2017 21:15
Send private message

If you wish to view the website from your LAN then you need to use the LAN IP not the WAN IP.

 

 

The HG659 does not support NAT loopback a preset of special forwarding rules so you can access port forwards on your WAN IP from within the LAN.



98 posts

Master Geek
+1 received by user: 5


  # 1715156 3-Feb-2017 21:19
Send private message

No, not a solution.  I am running 2 domains on same IP address, so to access them I need to use the domain names, not the ip address.  Basically this was sweet to do with my other router, why can't the Huawei one handle this?

 

 


 
 
 
 


27795 posts

Uber Geek
+1 received by user: 7277

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1715157 3-Feb-2017 21:19
Send private message

Are you trying to access your server using a FQDN or external IP? If so most routers don't support hairpin NAT to allow this. If you want to connect you need to use the local LAN IP to browse to it.

 

 




98 posts

Master Geek
+1 received by user: 5


  # 1715164 3-Feb-2017 21:24
Send private message

FQDN, and what do you mean routers don't support this?   My 2 prevoius crap routers from tp link worked.  IT makes no sense that I cant acces my FQDN from the lan




98 posts

Master Geek
+1 received by user: 5


  # 1715166 3-Feb-2017 21:26
Send private message

Perhaps I am not explaining this very well, it has worked for a few years, today I joined big pipe and gout their routers, now it does not work


2233 posts

Uber Geek
+1 received by user: 457

Lifetime subscriber

  # 1715172 3-Feb-2017 21:36
Send private message

Run a local DNS server to point to local address.





Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test


588 posts

Ultimate Geek
+1 received by user: 188
Inactive user


  # 1715174 3-Feb-2017 21:38
Send private message

RobBB:

 

No, not a solution.  I am running 2 domains on same IP address, so to access them I need to use the domain names, not the ip address.  Basically this was sweet to do with my other router, why can't the Huawei one handle this?

 

 

Because as @yitz has mentioned HG659 doesn't support hairpin NAT. See Hairpinning and NAT loopback.

 

You have a number of options:

 

     

  1. Use a different modem that supports hairpin NAT.
  2. Add additional LAN IPs to your host and assign a unique one to each web server; setup port forwarding on router like (mydomain.com):81 > 192.168.1.10 &  (mydomain.com):82 > 192.168.1.11
  3. Add and additional (sub)domain to your servers and setup a corresponding DNS record to point to your server LAN IP: internal.mydomain.com > A > 192.168.1.10
  4. Modify your client's host file to point to the LAN IP.
  5. As @Spyware suggests run a local DNS server..



98 posts

Master Geek
+1 received by user: 5


  # 1715175 3-Feb-2017 21:50
Send private message

Or return the modem and plug my old one in.


Mr Snotty
8619 posts

Uber Geek
+1 received by user: 4512

Moderator
Trusted
Lifetime subscriber

  # 1715180 3-Feb-2017 22:04
Send private message

Step 1) Grab a Raspberry Pi.
Step 2) Install PiHole on it.
Step 3) Disable DHCP on your router, set the PiHole to do this instead.
Step 4) Edit the /etc/ hosts (space added to prevent Cloudflare blocking me) adding to it like so:

192.168.2.2 website.nz www.website.nz website2.nz www.website2.nz

 

Step 5) ???
Step 6) Enjoy your faster DNS server complete with local hostname resolution.





1358 posts

Uber Geek
+1 received by user: 319


  # 1715181 3-Feb-2017 22:10
Send private message

If you are on ADSL I say just plug your old modem/router back in.

 

 

For higher speed broadband connections such as UFB you may need to keep the HG659 and implement one of the above solutions.

5424 posts

Uber Geek
+1 received by user: 1879


  # 1715192 3-Feb-2017 22:33
Send private message

The issue isn't the router. Bigpipe use cgnat

588 posts

Ultimate Geek
+1 received by user: 188
Inactive user


  # 1715196 3-Feb-2017 22:42
Send private message

RunningMan: The issue isn't the router. Bigpipe use cgnat

 

Good point with BigPipe OP needs to ensure he has a static IP: https://www.bigpipe.co.nz/faq/faq-about-our-plans/faq-static-ip/how-can-i-get-a-static-ip

 

 


Mr Snotty
8619 posts

Uber Geek
+1 received by user: 4512

Moderator
Trusted
Lifetime subscriber

  # 1715229 4-Feb-2017 02:22
Send private message

@RunningMan @solutionz you did read this right? :)

 

However the web server is accessible for people outside my LAN. Just not for us here using the lan





27795 posts

Uber Geek
+1 received by user: 7277

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1715234 4-Feb-2017 06:45
Send private message

RobBB:

 

FQDN, and what do you mean routers don't support this?   My 2 prevoius crap routers from tp link worked.  IT makes no sense that I cant acces my FQDN from the lan

 

 

What I meant was basically what I said - the vast majority of routers out there on the market don't support hairpin NAT so aren't going to do what you want to do. TP-Link actually make pretty rock solid routers with great xDSL performance and all their products support NAT loopback.

 

 


5424 posts

Uber Geek
+1 received by user: 1879


  # 1715248 4-Feb-2017 08:40
Send private message

michaelmurfy:

 

@RunningMan @solutionz you did read this right? :)

 

However the web server is accessible for people outside my LAN. Just not for us here using the lan

 

 

Oops - must have missed that. I blame the blurry eyes foot-in-mouth


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Video game market in New Zealand passes half billion dollar mark
Posted 24-May-2019 16:15


WLG-X festival to celebrate creativity and innovation
Posted 22-May-2019 17:53


HPE to acquire supercomputing leader Cray
Posted 20-May-2019 11:07


Techweek starting around NZ today
Posted 20-May-2019 09:52


Porirua City Council first to adopt new council software solution Datascape
Posted 15-May-2019 12:00


New survey provides insight into schools' technology challenges and plans
Posted 15-May-2019 09:30


Apple Music now available on Alexa devices in Australia and New Zealand
Posted 15-May-2019 09:11


Make a stand against cyberbullying this Pink Shirt Day
Posted 14-May-2019 20:23


Samsung first TV manufacturer to launch the Apple TV App and Airplay 2
Posted 14-May-2019 20:11


Vodafone New Zealand sold
Posted 14-May-2019 07:25


Kordia boosts cloud performance with locally-hosted Microsoft Azure ExpressRoute
Posted 8-May-2019 10:25


Microsoft Azure ExpressRoute in New Zealand opens up faster, more secure internet for Kiwi businesses
Posted 8-May-2019 09:39


Vocus Communications to deliver Microsoft Azure Cloud Solutions through Azure ExpressRoute
Posted 8-May-2019 09:25


Independent NZ feature film #statusPending to premiere during WLG-X
Posted 6-May-2019 22:13


The ultimate dog photoshoot with Nokia 9 PureView #ForgottenDogsofInstagram
Posted 6-May-2019 09:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.