Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
1 | ... | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29
509 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1795635 6-Jun-2017 22:15
Send private message

Not having any luck with my fritz 7490. Can someone post screenies of their working settings please?

7 posts

Wannabe Geek


  Reply # 1795677 7-Jun-2017 01:47
Send private message

Still no luck with LEDE, and already using the latest snapshot. Logs showing solicit, but I think no reply from server.

 

https://pastebin.com/dFMttaRL

 

I've also been playing with a Mikrotik, but still no prefix delegated.

 

I'll just have to wait I guess, this is a beta afterall :)


 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software
:)
2873 posts

Uber Geek
+1 received by user: 85

Subscriber

  Reply # 1795733 7-Jun-2017 09:02
Send private message

@treblE87:

 

Still no luck with LEDE, and already using the latest snapshot. Logs showing solicit, but I think no reply from server.

 

https://pastebin.com/dFMttaRL

 

I've also been playing with a Mikrotik, but still no prefix delegated.

 

I'll just have to wait I guess, this is a beta afterall :)

 

 

 

 

Have you got a screenshot of your current interfaces and settings? LEDE does appear to be supported, as I've tried with a couple of devices now and had no issues (outside of the one I detailed earlier) and LEDE/OpenWRT has fairly stable IPv6 connectivity these days, I would say.

 

Are you comfortable with generating your own image using the image builder? or compiling via the toolchain? If so, I'd probably recommend giving that a shot too. As depending on your storage for your device, certain options are stripped out of different routers to fit it. The WNDR3700v1 is a classic example, because it only has 8MB of storage.

 

Depends on how keen you are to get IPv6 though ;)

 

Cheers






509 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1796359 8-Jun-2017 08:56
Send private message

tanivula: Not having any luck with my fritz 7490. Can someone post screenies of their working settings please?

 

So... I have tried ticking/unticking these options (not many there) but nothing seems to work.  What am I doing wrong?

 


93 posts

Master Geek
+1 received by user: 46

Trusted
BigPipe

  Reply # 1796456 8-Jun-2017 09:56
Send private message

@tanivula Perhaps try without the require certain length for the LAN prefix option?

 

Can you PM me your account email address so I can check on our end?


509 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1796465 8-Jun-2017 10:10
Send private message

IPv6pipe:

 

@tanivula Perhaps try without the require certain length for the LAN prefix option?

 

Can you PM me your account email address so I can check on our end?

 

 

@IPv6pipe Have tried the suggested changes and restarted for good measure - unfortunately without any success. PM has been sent!


106 posts

Master Geek
+1 received by user: 31


Reply # 1797768 10-Jun-2017 17:19
Send private message

I've replaced my router and I'm now up and running on IPv6! I've retired my overpriced Netgear D6400 as I got sick of the "Genie" not allowing me to change settings like DHCP DNS options and actual IPv6 functionality.  I picked up an HG659 for cheap on TradeMe and it's working better than the Netgear for 10% of the price.

 

While it's working, I'm noticing a pause when going to new sites and initial query failures in nslookup.  I wanted to try the IPv6 DHCP settings @DarkShadow talked about but I get an error:

 

 

Cameron


106 posts

Master Geek
+1 received by user: 31


Reply # 1798280 12-Jun-2017 08:25
Send private message

caminham:

 

I've replaced my router and I'm now up and running on IPv6! I've retired my overpriced Netgear D6400 as I got sick of the "Genie" not allowing me to change settings like DHCP DNS options and actual IPv6 functionality.  I picked up an HG659 for cheap on TradeMe and it's working better than the Netgear for 10% of the price.

 

While it's working, I'm noticing a pause when going to new sites and initial query failures in nslookup.  I wanted to try the IPv6 DHCP settings @DarkShadow talked about but I get an error:

 

 

Cameron

 

 

Small update - I'm now running on IPv6 at the correct speeds. I copied the Prefix and Prefix length from the Internet Connection details and managed to apply the settings. All DHCP clients are now receiving the correct DNS Server list and resolving queries promptly.  I'm slightly concerned that if the Prefix changes at any point manual intervention will be required, but I get the impression from BigPipe's documentation that changes will be rare.


93 posts

Master Geek
+1 received by user: 46

Trusted
BigPipe

  Reply # 1798354 12-Jun-2017 10:31
Send private message

Your prefix won't change unless we need to re-provision your line on our end. Such circumstances will only generally come up if there are other changes happening on your line. Eg if you're moving house or changing plans.


470 posts

Ultimate Geek
+1 received by user: 106

Subscriber

  Reply # 1799215 13-Jun-2017 11:27
Send private message

tanivula:

 

IPv6pipe:

 

@tanivula Perhaps try without the require certain length for the LAN prefix option?

 

Can you PM me your account email address so I can check on our end?

 

 

@IPv6pipe Have tried the suggested changes and restarted for good measure - unfortunately without any success. PM has been sent!

 

 

Also not having luck on FritzBox 7490; @tanivula did you get it resolved?

 

Could not establish IPv6 Internet connection: No response from DHCPv6 server (SOL).


509 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1799225 13-Jun-2017 11:44
Send private message

solutionz:

 

 

 

Also not having luck on FritzBox 7490; @tanivula did you get it resolved?

 

Could not establish IPv6 Internet connection: No response from DHCPv6 server (SOL).

 

 

No luck here! Thats the same message I'm seeing in the log files.  

 

@jnimmo who got it working on the 7490 in the first place said IPv6 has stopped working for him. @IPv6pipe has been helpful testing his own fritzbox and sending me his config.  As of yesterday, his one works but mine doesn't with the same settings.  His test fritz is running older firmware, but apart from that I cant see any difference.

 

 


7 posts

Wannabe Geek


  Reply # 1799736 14-Jun-2017 02:50
Send private message

I've tried to *build LEDE with the latest snapshot still with no results: solicit with no reply. Settings I've tested include include PPPoE and IPoE on WAN, paired with DHCPv6 prefix delegation /60.

 

 

My current setup is now a Mikrotik 750GL with the latest RouterOS 6.39.2. IPv4 working very well, but still no reply when requesting for an ipv6 prefix delegation via DHCPv6. Router restarted several times. Screenshot attached shows my settings:

 

 

Click to see full size

 

 

I've also tried requesting for a PD with PPPoE, but no response. Router also restarted several times.

 

 

Any ideas?

441 posts

Ultimate Geek
+1 received by user: 125

Subscriber

  Reply # 1799749 14-Jun-2017 07:01
Send private message

treblE87:  My current setup is now a Mikrotik 750GL with the latest RouterOS 6.39.2. IPv4 working very well, but still no reply when requesting for an ipv6 prefix delegation via DHCPv6.

 

Turn on logging of your firewall drops on the firewall input chain and see what pops up. I don't use the GUI much and it seems to be hiding some of the detail of the firewall config. 

 

Here's my working Mikrotik input chain firewall.

 

/ipv6 firewall filter> print input
Flags: X - disabled, I - invalid, D - dynamic
0 chain=input action=accept connection-state=established in-interface=pppoe-vdsl log=no log-prefix=""

 

1 chain=input action=accept connection-state=related in-interface=pppoe-vdsl log=no log-prefix=""

 

2 chain=input action=accept protocol=udp src-address=fe80::/16 src-port=547 dst-port=546 log=no log-prefix=""

 

3 chain=input action=accept protocol=icmpv6 dst-address=ff02::1/128 icmp-options=134:0 log=no log-prefix=""

 

4 chain=input action=drop in-interface=pppoe-vdsl log=yes log-prefix=""

 

 

 

 


7 posts

Wannabe Geek


  Reply # 1801804 16-Jun-2017 01:26
Send private message

I have configured my firewall to be the same as with @hashbrown.There appears to be no dropped packets, so I'd think the firewall is working well.

 

 

Click to see full size

 

 

Export of my ipv6 settings

 

 

 

/ipv6 dhcp-server

 

add address-pool=bigpipe-ipv6 interface=ether2-master name=ipv6dhcp

 

/ipv6 dhcp-client

 

add add-default-route=yes interface=pppoe-out1 pool-name=bigpipe-ipv6

 

pool-prefix-length=60 request=prefix

 

/ipv6 firewall filter

 

add action=accept chain=input connection-state=established in-interface=

 

pppoe-out1

 

add action=accept chain=input connection-state=related in-interface=

 

pppoe-out1

 

add action=accept chain=input dst-port=546 protocol=udp src-address=fe80::/16

 

src-port=547

 

add action=accept chain=input dst-address=ff02::1/128 icmp-options=134:0

 

protocol=icmpv6

 

add action=drop chain=input in-interface=pppoe-out1 log=yes

 

add action=drop chain=input in-interface=ether1 log=yes

 

/ipv6 settings

 

set accept-redirects=no

 

 

 

I have used Mikrotik's Packet Sniffer to check the dhcpv6 transaction both using the settings above

 

 

IPoE log:

 

https://www.dropbox.com/s/y53lo05x8blylbd/PacketSniffIPoE?dl=0

 

 

PPPoE log:

 

https://www.dropbox.com/s/5tj7o41kijnnrlx/PacketSniffPPPoE?dl=0

441 posts

Ultimate Geek
+1 received by user: 125

Subscriber

  Reply # 1801819 16-Jun-2017 07:03
Send private message

Config for @treblE87.

 

Notes:

 

- Sorry, I didn't mean for you to copy the firewall config exactly from my earlier post, just amend your input chain.  You still need have config for the output and forward chains.

 

- The Mikrotik DHCP server only does prefix-delegation. You need to use SLAAC for client addressing.

 

- I'm not using IPv6 DNS in my config. I'd suggest starting out this way and integrating it later if you want.

 

Sorry, don't have time this morning to review packet captures, but here are some troubleshooting commands

 

/ipv6 dhcp-client print

 

/ipv6 pool print

 

/ipv6 address print

 

Remember to obscure your public 2403:9800:: prefix/addresses before posting any output.

 

/ipv6 dhcp-client
add interface=pppoe-vdsl pool-name=bigpipev6 use-peer-dns=no

 

/ipv6 address
add from-pool=bigpipev6 interface=ether2-master-local

 

/ipv6 firewall filter
add chain=forward connection-state=established
add chain=forward in-interface=ether2-master-local out-interface=pppoe-vdsl
add chain=forward connection-state=related
add chain=input connection-state=established in-interface=pppoe-vdsl
add chain=input connection-state=related in-interface=pppoe-vdsl
add chain=output out-interface=pppoe-vdsl
add chain=input dst-port=546 protocol=udp src-address=fe80::/16 src-port=547
add chain=input dst-address=ff02::1/128 icmp-options=134:0 protocol=icmpv6
add action=drop chain=input in-interface=pppoe-vdsl log=yes
add action=drop chain=forward in-interface=pppoe-vdsl log=yes


1 | ... | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12


Framing Facebook: It’s not about technology
Posted 14-May-2018 16:02


Vocus works with NZ Police and telcos to stop scam calls
Posted 12-May-2018 11:12


Vista Group signs Aeon Entertainment, largest cinema chain in Japan
Posted 11-May-2018 21:41


New Privacy Trust Mark certifies privacy and customer control
Posted 10-May-2018 14:16


New app FIXR connects vehicle owners to top Mechanics at best prices
Posted 10-May-2018 14:13


Nutanix Beam gives enterprises control of the cloud
Posted 10-May-2018 14:09


D-Link ANZ launches Covr Seamless Wi-Fi System
Posted 10-May-2018 14:06


Telstra, Intel and Ericsson demonstrate a 5G future for esports
Posted 10-May-2018 13:59



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.