Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
1 | ... | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29
40 posts

Geek


  # 1948372 29-Jan-2018 22:37
Send private message

For the record, I now have a working, dynamic configuration. The DHCP server is still very moody and only rarely responds to solicitations, but when it does, the following make things work. ppp0 is my PPPoE interface, and eth0 is on the LAN.

 

 

 

--[ /etc/wide-dhcpv6/dhcp6c.conf ]--------------------------------------------

 

profile default

 

{

 

request domain-name-servers;

 

 

script "/etc/wide-dhcpv6/dhcp6c-script";

 

};

 

 

interface ppp0 {

 

send ia-pd 0;

 

#send rapid-commit;

 

};

 

 

id-assoc pd 0 {

 

prefix-interface eth0 {

 

sla-id 0;

 

sla-len 4;

 

ifid 1;

 

};

 

};

 

 

--[ /etc/radvd.conf ]---------------------------------------------------------

 

interface eth0

 

{

 

AdvSendAdvert on;

 

AdvDefaultPreference high;

 

prefix ::/64

 

{

 

};

 

};

 

 

--[ cat /etc/ppp/ip-{up,down}.d/local-dhcp6c ]--------------------------------

 

#!/bin/sh

 

set -eu

 

 

case "$0" in

 

(*-down*) MODE=stop;;

 

(*) MODE=start;;

 

esac

 

 

env IFACE=$PPP_IFACE MODE=$MODE /etc/wide-dhcpv6/dhcp6c-ifupdown

 

 

case "$MODE" in

 

(start)

 

ip -6 route add default dev $PPP_IFACE

 

systemctl restart radvd.service

 

;;

 

(stop)

 

systemctl stop radvd.service

 

;;

 

esac

 

 

 


40 posts

Geek


  # 1949882 1-Feb-2018 09:44
Send private message

So this worked for a whole day, then the DSL connection dropped and since then (2 days now), the DHCPv6 client has been sending out solicitations without getting any response.

 

 

I've been given a prefix previously. However, if I now statically assign this prefix (please $DEITY forgive…) as dhcp6c had in the past, then I still don't get v6 connectivity, even though the link seems to be established:

 

 

 

root@atom:/# ping6 ff02::2%ppp0

 

PING ff02::2%ppp0(ff02::2) 56 data bytes

 

64 bytes from fe80::e2ac:f1ff:fe81:b104: icmp_seq=1 ttl=64 time=16.3 ms

 

[…]

 

^C

 

 

root@atom:/# ip -6 a

 

1: lo: mtu 65536 state UNKNOWN qlen 1

 

inet6 ::1/128 scope host

 

valid_lft forever preferred_lft forever

 

2: eth0: mtu 1500 state UP qlen 1000

 

inet6 2403:9800:c048:37d0::1/64 scope global

 

valid_lft forever preferred_lft forever

 

inet6 fe80::ba27:ebff:fe5d:5c08/64 scope link

 

valid_lft forever preferred_lft forever

 

3: eth1: mtu 1500 state UP qlen 1000

 

inet6 fe80::250:b6ff:fe17:8546/64 scope link

 

valid_lft forever preferred_lft forever

 

44: ppp0: mtu 1492 state UNKNOWN qlen 3

 

inet6 fe80::4:2:89/10 scope link

 

valid_lft forever preferred_lft forever

 

 

root@atom:/# ip -6 r

 

2403:9800:c048:37d0::/64 dev eth0 proto kernel metric 256

 

fe80::/64 dev eth1 proto kernel metric 256

 

fe80::/64 dev eth0 proto kernel metric 256

 

fe80::/10 dev ppp0 metric 1

 

fe80::/10 dev ppp0 proto kernel metric 256

 

default dev ppp0 metric 1024

 

 

root@atom:/# ping6 -nc3 debian.org

 

PING debian.org(2001:41c8:1000:21::21:4) 56 data bytes

 

 

--- debian.org ping statistics ---

 

3 packets transmitted, 0 received, 100% packet loss, time 2005ms

 

 

 

Any ideas? Ideally, the DHCP server gets fixed, but do you know of workarounds until that has happened?

 
 
 
 


jfp

7 posts

Wannabe Geek


  # 1949891 1-Feb-2018 09:57
Send private message

By assigning it statically do you mean changing radvd.conf?

 

 

 

Ie:

 

interface enp1s0
{
AdvSendAdvert on;
MinRtrAdvInterval 30;
MaxRtrAdvInterval 100;
AdvDefaultPreference low;
#A subnet from the /60 allocation
prefix BIGPIPESUBNET/64
{
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
};

 

 


40 posts

Geek


  # 1949914 1-Feb-2018 10:33
Send private message

No, radvd is a whole other beast and takes care of advertising any prefixes to the LAN (SLAAC).

 

 

Right now I am trying to get the router to be able to speak IPv6 itself, for a start.

 

 

There's a default route in place, and the router can ping6 the remote link-local IPv6 address pppd received:

 

 

 

root@atom:/# ping6 -nc1 -I ppp0 fe80::e2ac:f1ff:fe81:b104

 

PING fe80::e2ac:f1ff:fe81:b104(fe80::e2ac:f1ff:fe81:b104) from fe80::4:2:89 ppp0: 56 data bytes

 

64 bytes from fe80::e2ac:f1ff:fe81:b104: icmp_seq=1 ttl=64 time=13.5 ms

 

 

--- fe80::e2ac:f1ff:fe81:b104 ping statistics ---

 

1 packets transmitted, 1 received, 0% packet loss, time 0ms

 

rtt min/avg/max/mdev = 13.581/13.581/13.581/0.000 ms

 

 

 

So now I add a valid, global IPv6 address with the prefix that I had been assigned the last time the DHCP server replied, to either ppp0 or eth0 (either would work):

 

 

 

ip a a 2403:9800:c048:37d0::1/64 dev ppp0

 

 

 

But I cannot use that address, i.e. ping6 to the outside doesn't work (cf. the failing ping6 to debian.org quoted above).

jfp

7 posts

Wannabe Geek


  # 1949948 1-Feb-2018 10:53
Send private message

The interesting thing is that my setup works, with that radvd.conf, but the only public ipv6 addresses are on my LAN, assigned by the radvd.

 

My WAN and ppp0 only have fe80:: addresses, but the router can connect to the ipv6 internet using it's LAN ipv6 address.

 

Try manually adding a public /64 ipv6 address to you LAN and it will probably work.

 

 


40 posts

Geek


  # 1950022 1-Feb-2018 12:21
Send private message

radvd correctly advertises the prefix to the LAN, and while they can all ping the router merily, they too cannot access the outer 'Net using IPv6.

 

 

So given the situation that link-local v6 works between my PPPoE endpoint and the Bigpipe router, that their DHCP server seems wonky, and that the previously assigned prefix cannot be used as a globally-scoped address, or at least isn't being forwarded by them, I am fairly sure that I won't be able to fix this by poking at bits over here alone.

 

 

Does anyone at Bigpipe actually still follow this thread?

40 posts

Geek


  # 1950251 1-Feb-2018 17:44
Send private message
 
 
 
 


40 posts

Geek


  # 1952121 5-Feb-2018 17:16
Send private message

Something changed this morning, and now the DHCP server replies reliably to pretty much every request. Thank you @ipv6pipe for doing whatever you've been doing.

1448 posts

Uber Geek

Subscriber

  # 1953992 9-Feb-2018 02:52
Send private message

madduck: Something changed this morning, and now the DHCP server replies reliably to pretty much every request. Thank you @ipv6pipe for doing whatever you've been doing.

 

I've enabled ipv6 on my Google Wifi, I tested my connection and it appears that BigPipe has switched on ipv6 for everyone (I never opted in for the beta testing of ipv6).





Laptop: MacBook Pro (15-inch, 2017)
Desktop: iMac (27-inch, 2017)
Smartphone: iPhone XS Max 256GB 'Space Grey'
Additional devices: Unifi Security Gateway, Unifi Switch, Unifi AP AC HD, Unifi Cloud Key, Apple Watch 4 44mm
Services: YouTube Premium, Wordpress, Skinny Mobile and Broadband

 


Human
2911 posts

Uber Geek

Subscriber

  # 1986145 30-Mar-2018 17:47
Send private message

I assume IPv6 is still not production released yet? Is there an ETA on it?

 

My IPv6 has stopped working (though I believe it's possibly related to some IP changes the support team did to my connection). I've PM's the ipv6pipe account, so hopefully I'll get something from there... 






Human
2911 posts

Uber Geek

Subscriber

  # 1986867 1-Apr-2018 17:49
Send private message

Aaroona:

 

I assume IPv6 is still not production released yet? Is there an ETA on it?

 

My IPv6 has stopped working (though I believe it's possibly related to some IP changes the support team did to my connection). I've PM's the ipv6pipe account, so hopefully I'll get something from there... 

 

 

Some additional info.... It seems I am getting my /60 delegation and am getting an IPv6 address to my devices, but for whatever reason, it doesn't appear a default gateway is coming through. This is the same issue I was having with IPv4 the other day and they had to change my IP address apparently to make it work.

 

 

 

trying wget commands from my router, forcing IPv6 either comes back with destination host unreachable or no route found type errors. 






Mr Snotty
8764 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  # 1986868 1-Apr-2018 17:53
Send private message

@Aaroona Working with some routers I've got configured:

 

:~$ ping6 google.com
PING google.com(syd09s13-in-x0e.1e100.net) 56 data bytes
64 bytes from syd09s13-in-x0e.1e100.net: icmp_seq=1 ttl=54 time=35.2 ms
64 bytes from syd09s13-in-x0e.1e100.net: icmp_seq=2 ttl=54 time=34.4 ms
64 bytes from syd09s13-in-x0e.1e100.net: icmp_seq=3 ttl=54 time=34.5 ms
^C
--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 34.485/34.746/35.254/0.389 ms

 

This is a misconfiguration on your end - what router are you using?





Human
2911 posts

Uber Geek

Subscriber

  # 1986872 1-Apr-2018 17:57
Send private message

michaelmurfy:

 

@Aaroona Working with some routers I've got configured:

 

:~$ ping6 google.com
PING google.com(syd09s13-in-x0e.1e100.net) 56 data bytes
64 bytes from syd09s13-in-x0e.1e100.net: icmp_seq=1 ttl=54 time=35.2 ms
64 bytes from syd09s13-in-x0e.1e100.net: icmp_seq=2 ttl=54 time=34.4 ms
64 bytes from syd09s13-in-x0e.1e100.net: icmp_seq=3 ttl=54 time=34.5 ms
^C
--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 34.485/34.746/35.254/0.389 ms

 

This is a misconfiguration on your end - what router are you using?

 

 

 

 

The same router I've been using with IPv6 for the last year - WNDR3700 running LEDE. Only started having issues the other day when Bigpipe made changes to my account, which included messing with my Static IP and putting me behind CGNAT, then me requesting a move back, more issues, then finally resolved when they issued me a new, different static IP address. since then, IPv6 has been borked.

 

 

 

All I get when I try ping from my router: 

 


root@LEDE:~# ping6 google.co.nz
PING google.co.nz (2404:6800:4006:804::2003): 56 data bytes

 

Doesn't do a thing.
Wget from the router and RPi comes up like this at the moment;

 


root@LEDE:~# wget --inet6-only https://geekzone.co.nz
--2018-04-01 17:56:30-- https://geekzone.co.nz/
Resolving geekzone.co.nz... 2400:cb00:2048:1::6818:20e, 2400:cb00:2048:1::6818:30e
Connecting to geekzone.co.nz|2400:cb00:2048:1::6818:20e|:443... failed: Host is unreachable.
Connecting to geekzone.co.nz|2400:cb00:2048:1::6818:30e|:443... failed: Host is unreachable.

 

 

 

EDIT:

 

Some additional info:

 

 

Type: dhcpv6-pd
Prefix Delegated: 2403:XXXX:c048:300::/60
Address: 2403:XXXX:c041:ffe0:XXX:3246:XXXX:5908/128
Gateway: fe80::e2ac:f1ff:fe88:a202
DNS 1: 2403:9800:c041:1000::a
DNS 2: 2403:9800:c041:1000::b
Connected: 0h 51m 21s

 

 

I've blanked out a couple of bits to mask, but should be enough to see my point, re the gateway.






Human
2911 posts

Uber Geek

Subscriber

  # 1988314 4-Apr-2018 17:19
Send private message

Just to update. There was a provisioning issue on their side. Looks like they turned off my IPv6 when they updated my IPv4 settings for whatever reason. 
Spoke to support via online chat and it's all up and running again. A matter of seconds.

 

All working again and surfing on v6! :D






12 posts

Geek


  # 1997818 17-Apr-2018 13:39
Send private message

matisyahu:

 

I've enabled ipv6 on my Google Wifi, I tested my connection and it appears that BigPipe has switched on ipv6 for everyone (I never opted in for the beta testing of ipv6).

 

 

 

 

It does appear that they're rolling it out to a wider audience.  ipv6 is also enabled on my account and I haven't opted in for the beta testing.


1 | ... | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22


Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29


Catalyst Cloud becomes a Kubernetes Certified Service Provider (KCSP)
Posted 23-Aug-2019 08:21


New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01


Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46


Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.