Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2 posts

Wannabe Geek


Topic # 222922 4-Sep-2017 10:02
Send private message quote this post

Hi

 

I am trying to open a port to a box on the intranet. I have got a static ip and I have set port forwarding on the Huawei HG659 router. Nmap only shows the router ports open. When try to access the test webserver it just times out. Is there anything else I need to consider?

 

 

 

 

 

 


Create new topic
1367 posts

Uber Geek
+1 received by user: 149


  Reply # 1857942 4-Sep-2017 10:17
One person supports this post
Send private message quote this post

Machine firewall? Ie check the firewall on your web server.

904 posts

Ultimate Geek
+1 received by user: 175


  Reply # 1858061 4-Sep-2017 12:20
Send private message quote this post

You need to be testing from outside the NAT, if you are trying to access the server using your external IP from inside the NAT it will not work as HG659 does not loopback NAT (which your previous router may have).

 
 
 
 


212 posts

Master Geek
+1 received by user: 86

Subscriber

  Reply # 1858101 4-Sep-2017 13:33
Send private message quote this post

Port forwarding allows an outside machine to talk to an inside machine on the port you have opened.

 

It doesn't affect whether an inside machine can talk to an outside machine on that port. 

 

We may need a little bit more information on what you are trying to do.

 

If after opening the port, the outside machine still can't talk to the inside machine, check if the inside machine is running a firewall, which it should be, and does it allow traffic on the port number through.

 

Edit: Remove already answered question.




2 posts

Wannabe Geek


  Reply # 1858131 4-Sep-2017 13:59
Send private message quote this post

Thanks for all the quick replies. I will try to access from outside the network. Here is some more info:

 

nmap ivo.olu.nz

 

Starting Nmap 6.47 ( http://nmap.org ) at 2017-09-04 13:43 NZST
Nmap scan report for ivo.olu.nz (219.88.233.163)
Host is up (0.0022s latency).
Not shown: 996 filtered ports
PORT STATE SERVICE
53/tcp open domain
80/tcp open http
443/tcp open https
5060/tcp open sip

 

Nmap done: 1 IP address (1 host up) scanned in 5.39 seconds

 

Nmap correctly routes to the external ip address, the open ports belong only to the router. I am looking at port 8001.

 

There is a firewall, but it should be open in the right places, see INPUT rule with -->:

 

Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere ctstate RELATED,ESTABLISHED
fail2ban-ssh2 tcp -- anywhere anywhere multiport dports 2223
fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh
fail2ban-ssh2 tcp -- anywhere anywhere multiport dports 2223
fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh
--> ACCEPT tcp -- anywhere anywhere multiport dports ssh,http,2223,8000:http-alt
ACCEPT all -- 192.168.1.0/24 anywhere

 

Chain FORWARD (policy DROP)
target prot opt source destination
DOCKER all -- anywhere anywhere
ACCEPT all -- anywhere anywhere ctstate RELATED,ESTABLISHED

 

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

 

 


206 posts

Master Geek
+1 received by user: 39

Trusted
Emergency Management

  Reply # 1858217 4-Sep-2017 15:25
One person supports this post
Send private message quote this post

Have you told the box to accept requests with the FDQN not just the IP?

 

Also whats the platform of the web-server? The more details about the environment the easier it is for us to help. 


904 posts

Ultimate Geek
+1 received by user: 175


  Reply # 1858261 4-Sep-2017 16:14
2 people support this post
Send private message quote this post

As above you are attempting to connect to your outside NAT address 219.88.x.x (your static IP) from your LAN this will not work for port forwarded/virtual servers unless you have set specific traffic forwarding and NAT rules which is not available on the HG659. This may have worked on your previous router if NAT loopback rules were enabled.

 

 

A workaround might be to point the (FQDN) hostname to the 192.168.x.x LAN IP of the server.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Symantec protects data everywhere with Information Centric Security
Posted 21-Sep-2017 15:33


FUJIFILM introduces X-E3 mirrorless camera with wireless connectivity
Posted 18-Sep-2017 13:53


Vodafone announces new plans with bigger data bundles
Posted 15-Sep-2017 10:51


Skinny launches phone with support for te reo Maori
Posted 14-Sep-2017 08:39


If Vodafone dropping mail worries you, you’re doing online wrong
Posted 11-Sep-2017 13:54


Vodafone New Zealand deploy live 400 gigabit system
Posted 11-Sep-2017 11:07


OPPO camera phones now available at PB Tech
Posted 11-Sep-2017 09:56


Norton Wi-Fi Privacy — Easy, flawed VPN
Posted 11-Sep-2017 09:48


Lenovo reveals new ThinkPad A Series
Posted 8-Sep-2017 14:37


Huawei passes Apple for the first time to capture the second spot globally
Posted 8-Sep-2017 10:45


Vodafone initiative enhances te reo Maori pronunciation on Google Maps
Posted 8-Sep-2017 10:40


Voyager Internet expand local internet phone services company with Conversant acquisition
Posted 6-Sep-2017 18:27


NOW Expands in to Tauranga
Posted 5-Sep-2017 18:16


Windows 10 Fall Creators Update coming Oct. 17
Posted 4-Sep-2017 14:10


Garmin introduce Garmin vivoactive 3
Posted 1-Sep-2017 18:38



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.