Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




25 posts

Geek
+1 received by user: 2


# 248813 11-Apr-2019 08:41
Send private message quote this post

I use my Mikrotik RB3011UiAS to connect to BigPipe UFB.  A few months ago, I noticed that after updating my router, my internet connection did not come back after the reboot.  I contacted BigPipe who insisted that everything was 100% fine their end and that they could see me attempting to make the connection, but it was unsuccessful for reasons they couldn't explain.  They blamed my router.  It was only after powering down my ONT and waiting 10 minutes that the PPPoE connection was successful.  Ever since that day, I have been unable to disconnect and reconnect my PPPoE interface without powering down the ONT for 10 minutes.  Any hope of remotely updating the router when they release a new version of RouterOS is out the window, since I know that it won't come back online afterwards.  It's very frustrating to say the least.

 

 

 

Last night I thought I'd try the Huawei BigPipe router and see if the issue was there too. As it turns out, the Huawei was able to disconnect and reconnect at will without the need to touch the ONT at all.

 

 

 

I've used Mikrotik routers in various flavours for as long as I can remember now and I have never experienced this problem.  I find it very hard to believe that my hardware is faulty since once it is connected, everything runs like a dream and fortunately, the connection stays active for weeks or even months without the need to touch the ONT.  However I would love to get to the bottom of this, so if anyone has any ideas, I'd really like to hear them please.

 

 

 

Thanks in advance.


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3 | 4
256 posts

Ultimate Geek
+1 received by user: 27

Subscriber

  # 2214876 11-Apr-2019 10:22
Send private message quote this post

I am a novice on the Mikrotik, 

 

 

 

But the fun I have had over the last 6 years with pppoe when changing router/modems has been stress full.

 

It appears if the router/modem is changed it takes a while for the MikroTik to accept the new ?mac address or something.

 

reconnecting on the same modem generally no issues, swap a modem for troubleshooting, wait anywhere between 5mins to 4 hours to get connected again. 

 

 

 

I have no idea if this is common or if I misunderstand the MikroTik setup. 

 

 


1816 posts

Uber Geek
+1 received by user: 525


  # 2214893 11-Apr-2019 10:50
One person supports this post
Send private message quote this post

There's a bunch of stuff to check.  Hopefully you haven't turned on dial on demand?

 

Can you paste a dump of /interface export (remove passwords) here?

 

Also, check the logs and status of the PPPoE Client before and after pulling out the cable between the mikrotik and the ONT.

 

What OS and Firmware version is it currently on?  Do you recall what version you had no problems on?


 
 
 
 


703 posts

Ultimate Geek
+1 received by user: 261

Trusted
Spark NZ

  # 2214938 11-Apr-2019 12:07
Send private message quote this post

Is the Mikrotik also trying to do DHCP/ IPoE concurrently with the PPPoE?





My views are my own, and may not necessarily represent those of my employer.



25 posts

Geek
+1 received by user: 2


  # 2214981 11-Apr-2019 12:30
Send private message quote this post

MadEngineer:

 

There's a bunch of stuff to check.  Hopefully you haven't turned on dial on demand?

 

Can you paste a dump of /interface export (remove passwords) here?

 

Also, check the logs and status of the PPPoE Client before and after pulling out the cable between the mikrotik and the ONT.

 

What OS and Firmware version is it currently on?  Do you recall what version you had no problems on?

 

 

 

 

Dial on Demand is off.

 

I'm afraid I cannot recall what version I was on when this first happened.  Current version is 6.44.2.

 

I'm not actually unplugging the Ethernet cable between ONT and Mikrotik.  What I do is I power down the ONT entirely and wait up to 10 minutes.  The Mikrotik logs don't show anything useful.

 

 

00:41:56 pppoe,ppp,info BigPipe: initializing...
00:41:56 pppoe,ppp,info BigPipe: connecting...
00:42:06 pppoe,ppp,info BigPipe: terminating... - disconnected
00:42:06 pppoe,ppp,info BigPipe: disconnected
00:42:06 pppoe,ppp,info BigPipe: initializing...
00:42:06 pppoe,ppp,info BigPipe: connecting...
00:42:16 pppoe,ppp,info BigPipe: terminating... - disconnected
00:42:16 pppoe,ppp,info BigPipe: disconnected
00:42:17 pppoe,ppp,info BigPipe: initializing...
00:42:17 pppoe,ppp,info BigPipe: connecting...
00:42:27 pppoe,ppp,info BigPipe: terminating... - disconnected
00:42:27 pppoe,ppp,info BigPipe: disconnected
00:42:29 pppoe,ppp,info BigPipe: initializing...
00:42:29 pppoe,ppp,info BigPipe: connecting...
00:42:39 pppoe,ppp,info BigPipe: terminating... - disconnected
00:42:39 pppoe,ppp,info BigPipe: disconnected
00:42:42 pppoe,ppp,info BigPipe: initializing...
00:42:42 pppoe,ppp,info BigPipe: connecting...
00:42:52 pppoe,ppp,info BigPipe: terminating... - disconnected
00:42:52 pppoe,ppp,info BigPipe: disconnected
00:42:59 pppoe,ppp,info BigPipe: initializing...
00:42:59 pppoe,ppp,info BigPipe: connecting...
00:43:09 pppoe,ppp,info BigPipe: terminating... - disconnected
00:43:09 pppoe,ppp,info BigPipe: disconnected
00:43:19 pppoe,ppp,info BigPipe: initializing...
00:43:19 pppoe,ppp,info BigPipe: connecting...
00:43:29 pppoe,ppp,info BigPipe: terminating... - disconnected

 

 

 

 

Incidentally, I cannot see any PPPoE servers when I use the scan tool during this period that it won't connect.  It *feels* as though something on the BigPipe / Chorus end is either locked up, or flat-out rejecting my PPPoE request for some reason.  Perhaps the Mikrotik isn't sending the correct disconnect signal on a reboot or disable of the interface?

 

 

 

Interface export as requested:

 

 

# apr/11/2019 12:18:45 by RouterOS 6.44.2
# software id = LJMC-W4EF
#
# model = RouterBOARD 3011UiAS
# serial number = 780E066053B8
/interface bridge
add admin-mac=6C:3B:6B:FD:57:71 auto-mac=no comment=defconf fast-forward=no name=bridge
/interface ethernet
set [ find default-name=ether1 ] mtu=1508 speed=100Mbps
set [ find default-name=ether2 ] name=ether2-master speed=100Mbps
set [ find default-name=ether3 ] speed=100Mbps
set [ find default-name=ether4 ] speed=100Mbps
set [ find default-name=ether5 ] speed=100Mbps
set [ find default-name=ether6 ] name=ether6-master speed=100Mbps
set [ find default-name=ether7 ] speed=100Mbps
set [ find default-name=ether8 ] speed=100Mbps
set [ find default-name=ether9 ] speed=100Mbps
set [ find default-name=ether10 ] speed=100Mbps
set [ find default-name=sfp1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full disabled=yes
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 max-mtu=1500 name=BigPipe password=bigpipe use-peer-dns=yes user=ppp
/interface list
add exclude=dynamic name=discover
add name=mactel
add name=mac-winbox
add name=WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf interface=ether6-master
add bridge=bridge comment=defconf hw=no interface=sfp1
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
add bridge=bridge interface=ether7
add bridge=bridge interface=ether8
add bridge=bridge interface=ether9
add bridge=bridge interface=ether10
/interface detect-internet
set detect-interface-list=all
/interface list member
add interface=ether2-master list=discover
add interface=ether3 list=discover
add interface=ether4 list=discover
add interface=ether5 list=discover
add interface=sfp1 list=discover
add interface=ether6-master list=discover
add interface=ether7 list=discover
add interface=ether8 list=discover
add interface=ether9 list=discover
add interface=ether10 list=discover
add interface=bridge list=discover
add interface=BigPipe list=discover
add list=discover
add interface=bridge list=mactel
add interface=bridge list=mac-winbox
add interface=BigPipe list=WAN

 

 

 

 

 

 

cbrpilot:

 

Is the Mikrotik also trying to do DHCP/ IPoE concurrently with the PPPoE?

 

 

 

 

Good question!  I used to use IPoE until they discontinued this, but having checked now, I see that I disabled the DHCP client rule on Ether1 so I don't believe this is the culprit.

 

 

 

 


189 posts

Master Geek
+1 received by user: 9


  # 2214989 11-Apr-2019 12:50
Send private message quote this post

Also with Bigpipe and also seeing PPPoE disconnects with fully updated Mikrotik.

Problem first surfaced yesterday 5AM (10th April).

No DHCP client on WAN port Mikrotik.

Total mystery.

Edit/clarification: after an initial disconnect yesterday, Mikrotik (6.44.1) cannot establish a reconnect (PPPoE) via ONT. Result is a continual series of what look to be authentication failures from the PPPoE client on the Mikrotik.

Bigpipe/Spark say they are seeing DHCP reqs coming from the Mikrotik yet there are no DHCP clients on any Mikrotik port.



25 posts

Geek
+1 received by user: 2


  # 2215001 11-Apr-2019 13:17
Send private message quote this post

pohutukawa: Also with Bigpipe and also seeing PPPoE disconnects with fully updated Mikrotik.

Problem first surfaced yesterday 5AM (10th April).

No DHCP client on WAN port Mikrotik.

Total mystery.

 

 

 

I don't want to derail this thread, so let me just clarify that I am not seeing PPPoE disconnects in any shape or form.  The issue is PPPoE not reconnecting after a manual disconnect or reboot.


189 posts

Master Geek
+1 received by user: 9


  # 2215004 11-Apr-2019 13:23
Send private message quote this post

This is exactly what I am seeing—apologies if I gave a different impression!



25 posts

Geek
+1 received by user: 2


  # 2215006 11-Apr-2019 13:27
Send private message quote this post

pohutukawa: This is exactly what I am seeing—apologies if I gave a different impression!

 

 

 

Ah! Well in that case, welcome to my personal hell!  ;-) I'm glad to see that I'm not alone, but now concerned that this might run deeper than I thought.


189 posts

Master Geek
+1 received by user: 9


# 2215007 11-Apr-2019 13:30
Send private message quote this post

LOL.

I know of many Mikrotiks with different ISPs also on 6.44.1 and 6.44.2 that are not showing this issue and behaving normally.

Right now, the two common factors are Bigpipe and Mikrotik.

And us

703 posts

Ultimate Geek
+1 received by user: 261

Trusted
Spark NZ

  # 2215010 11-Apr-2019 13:37
2 people support this post
Send private message quote this post

I have looked into one case which came across my desk of this type of behaviour.

 

The device in question (quite likely one of the customers above, but I cannot confirm this) had a Routerboard MAC address.  So a Mikrotik router.

 

Even when the PPPoE was successfully connected, the device continuously hitting us with DHCP Discover messages.  This results in the connection basically getting blacklisted for up to 5 minutes when the PPPoE session goes down.  I.e. the MAC address in question has a bad reputation from the continual DHCP requests and this impacts when PPPoE tries to come back up.  This is what is causing the PPPoE not to come back immediately.  And this is why turning it off for 10 minutes results in service restoration.

 

Aware that you are saying that the device is not configured to do this.  But it is anyway.

 

Suggest you contact Mikrotik to see if they have any fixes for this behaviour.





My views are my own, and may not necessarily represent those of my employer.



25 posts

Geek
+1 received by user: 2


  # 2215013 11-Apr-2019 13:41
Send private message quote this post

cbrpilot:

 

I have looked into one case which came across my desk of this type of behaviour.

 

The device in question (quite likely one of the customers above, but I cannot confirm this) had a Routerboard MAC address.  So a Mikrotik router.

 

Even when the PPPoE was successfully connected, the device continuously hitting us with DHCP Discover messages.  This results in the connection basically getting blacklisted for up to 5 minutes when the PPPoE session goes down.  I.e. the MAC address in question has a bad reputation from the continual DHCP requests and this impacts when PPPoE tries to come back up.  This is what is causing the PPPoE not to come back immediately.  And this is why turning it off for 10 minutes results in service restoration.

 

Aware that you are saying that the device is not configured to do this.  But it is anyway.

 

Suggest you contact Mikrotik to see if they have any fixes for this behaviour.

 

 

 

 

Although my DHCP Client is most definitely disabled, I can't help but wonder if it is still somehow to blame.  I'll have another fiddle this evening when I get home; perhaps even just factory reset the Routerboard entirely and start again.  Thanks for sharing this, and thanks to everyone else that has chimed in thus far.

 

 

 

 


3982 posts

Uber Geek
+1 received by user: 1687

Subscriber

  # 2215014 11-Apr-2019 13:44
One person supports this post
Send private message quote this post

Torch your WAN interface (not the pppoe interface, rather the physical or VLAN interface if you are tagged) and you will see exactly what packets are heading out over it.

 

Before running Torch make sure you tick the extra options under "collect" for layer 2 info.


'That VDSL Cat'
10203 posts

Uber Geek
+1 received by user: 2449

Trusted
Spark
Subscriber

  # 2215015 11-Apr-2019 13:48
Send private message quote this post

pohutukawa: LOL.

I know of many Mikrotiks with different ISPs also on 6.44.1 and 6.44.2 that are not showing this issue and behaving normally.

Right now, the two common factors are Bigpipe and Mikrotik.

And us

 

Just gone back in my logs to when i had my RB3011 connected last weekend with 6.44.1, It is not exhibiting these issues.

 

 

 

I've got a spare routerboard or two at home, so happy to pull that out and see if the same happens on the Bigpipe line sitting in here. I fully expect it to function exactly the same though.

 

i believe it was your logs that i was just looking at. I can confirm what others have stated is what we were seeing from your connection.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


189 posts

Master Geek
+1 received by user: 9


  # 2215028 11-Apr-2019 13:56
Send private message quote this post

Thanks will investigate.



25 posts

Geek
+1 received by user: 2


  # 2215029 11-Apr-2019 13:56
Send private message quote this post

chevrolux:

 

Torch your WAN interface (not the pppoe interface, rather the physical or VLAN interface if you are tagged) and you will see exactly what packets are heading out over it.

 

Before running Torch make sure you tick the extra options under "collect" for layer 2 info.

 

 

 

 

I'll give that a shot tonight, thanks. Although I must confess, I am not sure what I'd expect to see there (or not see).


 1 | 2 | 3 | 4
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Video game market in New Zealand passes half billion dollar mark
Posted 24-May-2019 16:15


WLG-X festival to celebrate creativity and innovation
Posted 22-May-2019 17:53


HPE to acquire supercomputing leader Cray
Posted 20-May-2019 11:07


Techweek starting around NZ today
Posted 20-May-2019 09:52


Porirua City Council first to adopt new council software solution Datascape
Posted 15-May-2019 12:00


New survey provides insight into schools' technology challenges and plans
Posted 15-May-2019 09:30


Apple Music now available on Alexa devices in Australia and New Zealand
Posted 15-May-2019 09:11


Make a stand against cyberbullying this Pink Shirt Day
Posted 14-May-2019 20:23


Samsung first TV manufacturer to launch the Apple TV App and Airplay 2
Posted 14-May-2019 20:11


Vodafone New Zealand sold
Posted 14-May-2019 07:25


Kordia boosts cloud performance with locally-hosted Microsoft Azure ExpressRoute
Posted 8-May-2019 10:25


Microsoft Azure ExpressRoute in New Zealand opens up faster, more secure internet for Kiwi businesses
Posted 8-May-2019 09:39


Vocus Communications to deliver Microsoft Azure Cloud Solutions through Azure ExpressRoute
Posted 8-May-2019 09:25


Independent NZ feature film #statusPending to premiere during WLG-X
Posted 6-May-2019 22:13


The ultimate dog photoshoot with Nokia 9 PureView #ForgottenDogsofInstagram
Posted 6-May-2019 09:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.