Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




550 posts

Ultimate Geek
+1 received by user: 19


Topic # 232063 27-Mar-2018 15:12
Send private message quote this post

My CTEK Charger has this light buzzing noise even if battery is not connected. I haven't used it much at all since I bought it which was some time ago but I believe the noise has always been there. Seems to go up a little when battery connected and going through different modes it slightly changes.  Can anyone who has CTEK charger please confirm if there charger makes any noise at all with battery not connected or connected. My model is MXS 5.0


Create new topic
193 posts

Master Geek
+1 received by user: 74

Trusted

  Reply # 1984472 27-Mar-2018 19:46
Send private message quote this post

I have two - the 5.0 and a larger one.  They are virtually silent (unless one clamps it to their ear) so I get the feeling something isn't quite right in yours.  In saying that, does it work as it should?




550 posts

Ultimate Geek
+1 received by user: 19


  Reply # 1984481 27-Mar-2018 20:25
Send private message quote this post

Ge0rge:

I have two - the 5.0 and a larger one.  They are virtually silent (unless one clamps it to their ear) so I get the feeling something isn't quite right in yours.  In saying that, does it work as it should?


Well I’m not sure as I only tried it with two batteries, it completes the cycle but batteries didn’t work. Batteries could be faulty as quite old, one of them has been in an alarm box. Don’t have receipt, wonder if it’s worth pursuing under warranty.
It’s not loud but you can easily tell without getting it anywhere near your ears.

 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software
193 posts

Master Geek
+1 received by user: 74

Trusted

  Reply # 1984489 27-Mar-2018 20:37
Send private message quote this post

Hmm interesting. Mine won't complete the cycle if the battery is faulty - it will illuminate the red fault light and discontinue the charging cycle.  I've seen it twice now, and neither of the two I have would charge the poked batteries. 




550 posts

Ultimate Geek
+1 received by user: 19


  Reply # 1984491 27-Mar-2018 20:42
Send private message quote this post

Really I have a small 12V battery in my alarm which his only 2 years old but won’t work. Charged with this charger completes the cycle then plug battery back in, turn off power alarm stays in it for like 5 seconds.Anther 12 V battery I tried today, went to no.4 step rather quickly but battery is dead. Any way to test the charger if it’s doing anything? Emailed ctek about a clamp issue some time back and they said noise is normal!!

193 posts

Master Geek
+1 received by user: 74

Trusted

  Reply # 1984494 27-Mar-2018 20:45
Send private message quote this post

You could try a multi-meter during the charge cycle - measure the battery voltage before putting the charger on, then measure while it is on there - that'll tell you pretty quickly if it is doing anything.  You could also measure the amount of current being drawn by the battery when it is being charged - if it's dead flat you should see at least a few amps being pulled as the charger moves through it's cycle.




550 posts

Ultimate Geek
+1 received by user: 19


  Reply # 1984498 27-Mar-2018 20:49
Send private message quote this post

How do you measure the amount of current being drawn by battery with multimeter?

7387 posts

Uber Geek
+1 received by user: 2363

Subscriber

  Reply # 1984504 27-Mar-2018 20:56
Send private message quote this post

put the multimeter in series with the battery and charger when its being charged. it red charger lead, multi meter read lead, multi meter, multi meter, red battery terminal, then black battery terminal to black charger lead.

 

if its being use do the same as above but make sure what ever using the battery isnt using more than the rated amount on the fuse of the multi meter, normally 300ma and 10a.

 

i had one battery charge fully on the charger but when loaded ie starting the car it would show 10.5v, ie a dropped cell, but when charged it was fine at 12.5v


193 posts

Master Geek
+1 received by user: 74

Trusted

  Reply # 1984505 27-Mar-2018 21:01
Send private message quote this post

You need a multi meter that has the ability to do this by either

 

A) placing the multi meter in "A" mode and placing it in series with the charging circuit, or

 

B) using a 'clampmeter' style multimeter or attachment

 

 

 

 




550 posts

Ultimate Geek
+1 received by user: 19


  Reply # 1984657 28-Mar-2018 08:38
Send private message quote this post

Ge0rge:

 

You could try a multi-meter during the charge cycle - measure the battery voltage before putting the charger on, then measure while it is on there - that'll tell you pretty quickly if it is doing anything.  You could also measure the amount of current being drawn by the battery when it is being charged - if it's dead flat you should see at least a few amps being pulled as the charger moves through it's cycle.

 

 

Battery voltage without charger connected around 12.5 V and with charger connected little over 14V. Just noticed that when I plug the charger to mains, I get the buzzing sound but when I connect the battery it goes away to a point that I have to put it against my ear to hear the faint buzz.  Does yours make any sound when connected to mains with no battery connected to it?


7387 posts

Uber Geek
+1 received by user: 2363

Subscriber

  Reply # 1984979 28-Mar-2018 15:15
Send private message quote this post

what is the battery voltage when connected to a load?


193 posts

Master Geek
+1 received by user: 74

Trusted

  Reply # 1985192 28-Mar-2018 22:39
Send private message quote this post

I'll check tomorrow.

I doubt I would have ever noticed that - best practice is to always connect the charger to the battery before connecting to mains, and then disconnect mains before disconnecting battery.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon launches the International Shopping Experience in the Amazon Shopping App
Posted 19-Apr-2018 08:38


Spark New Zealand and TVNZ to bring coverage of Rugby World Cup 2019
Posted 16-Apr-2018 06:55


How Google can seize Microsoft Office crown
Posted 14-Apr-2018 11:08


How back office transformation drives IRD efficiency
Posted 12-Apr-2018 21:15


iPod laws in a smartphone world: will we ever get copyright right?
Posted 12-Apr-2018 21:13


Lightbox service using big data and analytics to learn more about customers
Posted 9-Apr-2018 12:11


111 mobile caller location extended to iOS
Posted 6-Apr-2018 13:50


Huawei announces the HUAWEI P20 series
Posted 29-Mar-2018 11:41


Symantec Internet Security Threat Report shows increased endpoint technology risks
Posted 26-Mar-2018 18:29


Spark switches on long-range IoT network across New Zealand
Posted 26-Mar-2018 18:22


Stuff Pix enters streaming video market
Posted 21-Mar-2018 09:18


Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47


Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25


New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48


Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.