I'm struggling with getting a Leadtek remote control to work with my HTPC (Leadtek WinFast DTV Dongle H, Remote YG04G0051, Windows 8.1). Ideally I want to use it with MediaPortal and VLC, but haven't yet got to the attempted integration stage.

Having previously tried and failed to get an Avermedia remote working well with MediaPortal, I bought this one as it apparently included an MCE remote. More fool me, I just assumed that all MCE remotes were created equal. Apparently not.

Plugging in the USB stick, Windows auto-detects it and installs apparently up-to-date drivers (the ones on the Leadtek site don't seem to be newer, at least according to Windows which refused to update the drivers as the current ones it found were up to date). It does install as a "HID Keyboard Device - WinFast DTV Dongle H", rather than a tuner card (unlike the another Avermedia USB I have though - not sure if this is significant).

The TV tuner bit seems to work fine (I can use it to view and record television using it in MediaPortal).

Some buttons on the remote seem to work fine (the arrow keys, OK, and the number keys - using notepad, these keypresses are all registered). None of the other buttons seem to do anything in MediaPortal, notepad or MCE. Extensive googling suggests that these might be "real" keystrokes, as opposed to HID commands (I may have garbled that explanation). In any event, this was enough to satisfy me that the batteries weren't flat, the batteries were in the right way round and I'd plugged everything in more-or-less where it should be.

I've tried installing various software from Leadtek's website associated with the tuner stick, including the awful PVR2 application (all buttons on the remote seemed to work fine with this). This also came with the encouragingly-named "RC Config" application, which allegedly allowed me to set up various custom keymaps that can be switched on the fly. I duly tried setting up keymaps based (1) on HID commands (play/pause etc.) and (2) MediaPortal's keystrokes (e.g. "B" to stop). No matter what I do though, I can't get the remote to switch to these alternative keymaps (whether using the software interface or the remote button combinations). For example, I mapped the stop button on the remote to the letter "B" and the mute button to the letter "M". Going in to notepad, B and M don't appear when I press them (even though the number keys and the arrow keys still appear to work).

I did then try (at different times) to turn on the MCE remote and HID remote options in MediaPortal's config, but no joy.

I've gone on to try (and fail at) Coolreciver and WinLIRC.

The HTPC was put together on a shoestring, and I do have a small bluetooth keyboard that I currently use as a remote, so I don't really want to invest in any new hardware. The remote was more to make it a bit more user friendly for my wife who seems to take using "B" to stop something playing as a personal affront. 

Apologies for the long post. Any help gratefully received.