Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 


750 posts

Ultimate Geek


  # 1072051 22-Jun-2014 13:59
Send private message

Thanks Farcus, that helped a lot. The remotes I have don't have a right click option so I plugged in an actual mouse and things became a lot more  instinctive. I removed all the Televisions and now it's re-scraping with TVDB. This didn't happen last night wiith all source present. I'll repeat all that with the Movies source.

Would it be correct to say you cannot 're-scrape' an existing source ?  Or is that what 'clean library' does ?
As for Arora, I didn't ask for it and haven't used it. The pi just installed or upgraded it  for reasons unknown!  If it locks up (and maybe it hasn't but you're can't select things like a close box with my remote), various things happen on a reboot like that.  Often it will 'do stuff' with the progress bar off-screen or not showing correctly. And it tells you off for not switching off correctly...  but what else can you do ? !

It's a little confusing for a newbie - the differences/meanings between openelec, gotham, xbmc  and whatever other names are used. 
Or what the pi is straight 'out of the box', as mine is.

1016 posts

Uber Geek


  # 1072065 22-Jun-2014 14:48
Send private message

ADKM:
Would it be correct to say you cannot 're-scrape' an existing source ?  Or is that what 'clean library' does ?


after the initial scrape - on subsequent scrapes it is only looking for new content, so the scrape occurs pretty quickly.

I have my pi set to scan for new content on boot - the setting for that is in the same place as clean library

and yes, Raspbmc can be a little daunting to set up correctly for beginners - but once you get your head around it the raspberry pi is an awesome little unit.

 
 
 
 


1016 posts

Uber Geek


  # 1072066 22-Jun-2014 14:54
Send private message

oh - about the remote you bought on Trademe . . .

does it not work at all? Does the mouse function at the top of the unit not work?

If not, I would be inclined to think it is a dud. Try plugging it into your PC and see if the moue part functions there.

I'm surprised it doesn't work for you - I just plugged the IR receiver into a usb port on the Pi and it worked right off without any changes.


1016 posts

Uber Geek


  # 1072075 22-Jun-2014 15:30
Send private message

Here's a layout of the remote and buttons that should work out of the box without any keymap configuration required.




1. Power off (raise menu)
2. Mouse navigation
3. mouse left click
4. mouse right click
5. Play / Pause (only once video has already been launched by navigation buttons at bottom of mouse).
6. previous track
7. next track
8. scan back / forward
9. stop
10. Volume up / down
11. mute
12. back / exit
13. navigate left (during playback skip back 30 secs.)
14. navigate up (during playback skip forward 10 mins)
15. enter / select
16. navigate right (during playback skip forward 30 secs.)
17. navigate down (during playback skip back 10 mins)
18. Exit / escape to main menu.





750 posts

Ultimate Geek


  # 1072076 22-Jun-2014 15:38
Send private message

The trademe remote does respond, but not as you expect. The R button which I thought might be r-click
moved the pi cursor to the top of the list of files.  The mouse L-R T-B buttons do nothing.  It's not clear to me what
should do what so maybe I've just got to learn to drive it.  The Enter button worked for me once (I tried that because the TV remote
had no Enter). Now I've both remotes and mouse responding, maybe I can do most things.

Yes, I agree its more than awesome. And this is just the media streaming part of it. I'm thinking of getting another one but
it would be for an older TV (with no HDMi or CEC remote), so holding off for now.

Just to get it right, if a file has no artwork because of a misspelled filename, I change the name on the PC, then do what exactly on the pi?
Also I notice some stuff which doesn't have artwork may pick up the wrong thing... can you exclude certain files anyhow?




1016 posts

Uber Geek


  # 1072077 22-Jun-2014 15:45
Send private message


Just to get it right, if a file has no artwork because of a misspelled filename, I change the name on the PC, then do what exactly on the pi?


if you are within the TV Show menu (that shows a list of all your TV shows) navigate to the left screen and a window will pop out. At the bottom of that is update library.

Or, if you have selected to update on boot you could just reboot if that is easier.



750 posts

Ultimate Geek


  # 1072079 22-Jun-2014 15:55
Send private message

Thanks for the remote functions... have printed out and will do an in-depth!  Some I know don't work (the obvious ones we're tried). All you get is the
red light on the remote!
OK on update method... half way through scraping and will try as soon as finished.

 
 
 
 




750 posts

Ultimate Geek


  # 1073833 25-Jun-2014 03:05
Send private message

Farcus, i think you're right about this "PCRemote" being faulty.

The mouse controls never worked, but I found the scan back/forward did. My wife started using these
instead of the mobile app tonight and got about 15mins of use when they just stopped working. I pressed
"Enter" to see what that might do and the OSD went into a mad repeatative cycle of play/pause which could
only be stopped by powering down the pi!

I tend to think these el cheapo plastic membrane things aren't worth bothering with; the key under the mouse wheel always
sticks and none have a decent positive feel about them. But what else is there?

If nothing , I'll get in touch with Sam who designed the pi and ask if the Panasonic remote can be mapped to have 'scan' (and right click) capability.
That's about all that's missing from it, apart from skip ahead/back by mm:ss  which would be nice but not essential. (And PCRemote had no numeric keypad anyway.)



1016 posts

Uber Geek


  # 1073837 25-Jun-2014 06:14
Send private message

there are plenty of MCE Remote controls that will work just fine with xbmc . . .

like this

http://tinyurl.com/lzmsnfj

I'm sure you would be able to source something locally.

http://wiki.xbmc.org/index.php?title=Remote_controls/MCE



750 posts

Ultimate Geek


  # 1074685 25-Jun-2014 22:27
Send private message

That one looks pretty good farcus and may be nice quality being HP.  But a call to them (and JB Hifi) went nowhere.
I've contacted the trademe seller to see if he'll swap the crook one out.
Regard, ADKM



750 posts

Ultimate Geek


  # 1076782 30-Jun-2014 02:19
Send private message

Farcus - an update FYI.  The Trademe seller has offered a full refund.  And a friend in the US is getting
that HP remote in your link.  Specs read well so here's hoping!   Had to do it that way as they wouldn't
ship to NZ.   Wonder why some people are like that - do they think we're a bit backward or dodgy ?? !!



750 posts

Ultimate Geek


  # 1090879 17-Jul-2014 16:35
Send private message

Hi again Farcus, well I was able to return that remote and managed to get the HP MCE Remote  shipped over form USA.

Looks nice, feels really good but doesn't work in the pi.  No keys do anything !  This is the 3rd one that's failed so I'm sure it has to be something in the Pi.  Found plenty of links says they work out of the box with  XBMCLive.  Nothing says "works out of the box with rasp pi" though.
Came without any drivers, documentation or anything. There's a oddball lead with a 3.5mm mono jack and a small sensor that fits into the back of the receiver. (Could be something to do with IR blaster, whatever that is!). Tried with and without, no change to anything. The 'input devices' screen doesn't seem to have any settings  or options to make it work. Sometimes with it plugged in the TV CEC remote stops working ot goes sluggish, not always - just sometimes.

Sadly the forums are no real help so as a last resort I'll email Sam Nazarko. If I ever find a fix or solution I'll advise here.  I've now spent more on remotes than the whole Pi !

If anyone has a rasp pi with one of these remotes, please let me know if you had any setup problems or solutions.  Thanks laughing


1016 posts

Uber Geek


  # 1090919 17-Jul-2014 17:53
Send private message

As you have consistently had trouble getting any remote to work the most likeley reason is a corrupt raspbmc install. If you can, is try doing a full new install. Try to avoid the noobs installer. If you can get your hands on a Linux or Mac system this will give you the most reliable way to install.

I've set up 2 pis for friends over the past couple of weeks and the remotes (cheap pcremote) have just worked.



750 posts

Ultimate Geek


  # 1091866 19-Jul-2014 04:02
Send private message

It's the strangest darn thing...  a chap was helping in the xbmc forum and told me  to apply 2 command via Putty
to generate URL's he could look at for diagnostics.  And to do it after a reboot without the HP remote plugged in.
Maybe I had always plugged it in first.  I really don't think so but this time a message came up about LIRC detected
and the bloody thing started working. 

Not sure whether to laugh or cry!  I know for sure previously when connecting the HP remote with the Pi on no
message came up and it could affect the TV remote. Sometimes it would stop working, other times become sluggish.

Haven't tried all buttons yet (nearly 4am here) but the common nav controls are not showing the OSD panel and are functioning
just like the mobile app (which was what was hoped for).

Fingers crossed it doesn't return to it's delinquent state tomorrow !



1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Facebook Portal to land in New Zealand
Posted 19-Sep-2019 18:35


Amazon Studios announces New Zealand as location for its upcoming series based on The Lord of the Rings
Posted 18-Sep-2019 17:24


The Warehouse chooses Elasticsearch service
Posted 18-Sep-2019 13:55


Voyager upgrades core network to 100Gbit
Posted 18-Sep-2019 13:52


Streaming service Acorn TV launches in New Zealand with selection with British shows
Posted 18-Sep-2019 08:55


Bitcoin.com announces partnership with smartphone manufacturer HTC
Posted 16-Sep-2019 21:30


Finalists Announced for Microsoft NZ Partner Awards
Posted 16-Sep-2019 19:37


OPPO Showcases New CameraX Capabilities at Google Developer Days China 2019
Posted 15-Sep-2019 12:42


New Zealand PC Market returns to growth
Posted 15-Sep-2019 12:24


Home sensor charity director speaks about the preventable death which drives her to push for healthy homes
Posted 11-Sep-2019 08:46


Te ao Maori Minecraft world set to inspire Kiwi students
Posted 11-Sep-2019 08:43


Research reveals The Power of Games in New Zealand
Posted 11-Sep-2019 08:40


Ring Door View Cam now available in New Zealand
Posted 11-Sep-2019 08:38


Vodafone NZ to create X Squad
Posted 10-Sep-2019 10:25


Huawei nova 5T to be available 20th September
Posted 5-Sep-2019 11:55



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.